The OnePlus 6 is officially on sale! Buy now →
FORUMS
Remove All Ads from XDA
OnePlus 6 On Sale

[APP][2.2+] [v.1.5+] Wakelock Detector- What keeps your phone awake when it sleeps?

224 posts
Thanks Meter: 683
 
By ahikmat, Senior Member on 7th March 2013, 03:27 AM
Post Reply Email Thread
19th April 2018, 11:12 PM |#1011  
Member
Thanks Meter: 1
 
More
Help
Could someone help please? I am doing everything correctly in order to make this app work without root access but I always get the error message:

Operation not allowed: java.lang.SecurityException: grantRuntimePermission: Neither user 2000 nor current process has android.permission.GRANT_RUNTIME_PERMISSIONS.

(screenshot attached)

Device: Xiaomi Redmi 4 Prime
ROM: Stock 6.0.1 with MIUI

Edit: This is what solved it:

Turn on the following option:

USB debugging -Debug mode when USB is connected

Install via USB -Allow installing apps via USB

USB debugging (Security Settings)- Allow granting permissions and simulating input via USB debugging
Attached Thumbnails
Click image for larger version

Name:	adb error.png
Views:	184
Size:	209.6 KB
ID:	4481050  
 
 
21st April 2018, 02:27 PM |#1012  
IanHodgson's Avatar
Senior Member
Thanks Meter: 30
 
More
I'm running WLD with root on a redmi note 4 running Pixel Experience, but even after an overnight, when there has been definite CPU activity going on (I can tell because of battery drain and percentage awake), WLD still tells me I need to leave the phone longer to be able to get some stats. Is this maybe an Oreo bug or should I leave the phone longer than 10 hours?

Thanks.

Ian

Edit: I think I found the answer: I just had to enable advanced features in settings.

Edit 2: So it still doesn't show any stats for CPU, that is after 'show processes used by Android OS' is on. I left it overnight, making sure WiFi was turned on and leaving it on before letting the phone go to deep sleep by itself. Still no stats. It says in the 'how to' to leave phone idling for at least 2-3 hours. Either I'm missing something or there is an Oreo bug. Anyone with similar experience? The only thing I haven't tried is installing as system.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes