FORUMS
Remove All Ads from XDA
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
SOLVED: This was fixed by adding and using e2fsck, see the link in post #3. I had issues using adb push to install the tools, see the CyanogenMod thread. I do NOT believe the parted files he linked were intended to be used on ext4, so YMMV, but it did convert my fscked up ext4 partition to a over-writable ext2.
*********************************

I am having a problem with my sd-ext partition being unable to mount. After a relatively routine procedure, I suddenly have this problem (below), for example when I tried to Nandroid Restore my sd-ext partition.
Code:
E:Can't mount /dev/block/mmcblk0p2
(File exists)
Setup: HTC Desire; HBOOT 0.93, S-ON; ClockWorkMod v2.5.0.7; CyanogenMod-6.0.2; DTapps2sd

I was trying the relatively simple procedure of removing a couple of system Apps, according to the instructions on the CyanogenMod Wiki:Barebones.
I had minor problems with capitalization since I'm using Windows.

I removed Calculator, Email, and Calendar. Upon restart, all of my Apps are gone, except the few system apps and GApps that were not moved via dtapps2sd.

The phone still "works", I can send/receive SMS, make calls etc., but it's pretty highly crippled.

I've tried a Nandroid Restore, but it gives this message above (as did my attempt to do a Nandroid Backup).

The dtapps2sd "repair" command also said something about "cannot mount".

I tried to wipe and reflash CyanogenMod, which worked (in that it did re-flash). But when I tried to then Restore, I got the same "Can't mount" problem.

I also tried the following fastboot command I found in another thread, with no effect
Code:
fastboot oem enableqxdm 0
fastboot reboot
I have noticed that whey I use Terminal Emulator, the Permissions on mmcblk0p2 don't match the other blocks. Could this be related? Sadly, my Linux karate is weak :/
Code:
$ cd /dev/block
$ ls -al
..
..
brw------ .. .. .. .. .. mmcblk0p1
brw-r--r--.. .. .. .. .. mmcblk0p2
brw------ .. .. .. .. .. mmcblk0p1
..
I guess I haven't yet tried the HTC RUU, which is always a possible fallback. Or I could try to flash a stock PB99IMG.ZIP file. But those seem like just a generic "solution" that doesn't really involve any understanding. And it certainly doesn't help others with this same problem, or to figure out what I did to create this problem, so others could avoid that.

UPDATE: Link for PB99IMG.ZIP. It's ~140MB, and ROM+Radio specific, so no I won't post it here.
http://shipped-roms.com/shipped/Bravo/
The Following User Says Thank You to ScottHW For This Useful Post: [ View ] Gift ScottHW Ad-Free
Subscribe to Thread

Tags
apps2sd, mount, partitions, sd-ext

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes