FORUMS
Remove All Ads from XDA

[CMC-GUI] [DAILY] [PPA] Cyanogenmod Compiler Daily [Depreciated]

3,189 posts
Thanks Meter: 2,980
 
By lithid-cm, Inactive Recognized Developer on 28th December 2011, 05:45 PM
Thread Closed Email Thread
9th May 2012, 07:42 PM |#921  
jamcar's Avatar
Senior Member
Flag Orlando
Thanks Meter: 400
 
More
Quote:
Originally Posted by lithid-cm

run the compiler via terminal, what output do you get?

i am running it from terminal it says "No files nothing to do"
 
 
9th May 2012, 07:44 PM |#922  
lithid-cm's Avatar
OP Inactive Recognized Developer
Flag Cleveland
Thanks Meter: 2,980
 
More
Quote:
Originally Posted by jamcar

i am running it from terminal it says "No files nothing to do"

There are two different versions, one of which I am active in and developing, and the other a announced a while back that I won't be looking into much.

If you are using the CLI, that usually means its missing sync.
9th May 2012, 07:47 PM |#923  
[GER]Roxxor's Avatar
Senior Member
Flag Nürnberg
Thanks Meter: 285
 
More
Quote:
Originally Posted by lithid-cm

Try updating, this is a known issue and bug that was fixed.

https://bugs.launchpad.net/cmcompiler/+bug/996719

Just installed a few minutes ago.
Linux Mint 12 is based on Ubuntu oneiric.
Is there a fast fix for that? Want to compile a new build with the new theme manager
Thank you for this tool
9th May 2012, 08:00 PM |#924  
lithid-cm's Avatar
OP Inactive Recognized Developer
Flag Cleveland
Thanks Meter: 2,980
 
More
Quote:
Originally Posted by [GER]Roxxor

Just installed a few minutes ago.
Linux Mint 12 is based on Ubuntu oneiric.
Is there a fast fix for that? Want to compile a new build with the new theme manager
Thank you for this tool

What version do you have installed?
Code:
[email protected]:~$ dpkg -s cmcompiler-daily
Package: cmcompiler-daily
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 1065
Maintainer: lithid <[email protected]>
Architecture: i386
Version: 0.4-0~5~precise1
Depends: python
Description: Cyanogenmod Compiler daily build
 Build cyanogenmod for offically supported devices (daily development builds)
Homepage: http://forum.xda-developers.com/showthread.php?t=1415661
9th May 2012, 08:02 PM |#925  
[GER]Roxxor's Avatar
Senior Member
Flag Nürnberg
Thanks Meter: 285
 
More
Code:
dpkg -s cmcompiler-daily
Package: cmcompiler-daily
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 1192
Maintainer: lithid <[email protected]>
Architecture: i386
Version: 0.4-0~5~oneiric1
Depends: python
Description: Cyanogenmod Compiler daily build
 Build cyanogenmod for offically supported devices (daily development builds)
Homepage: http://forum.xda-developers.com/showthread.php?t=1415661
9th May 2012, 08:06 PM |#926  
jamcar's Avatar
Senior Member
Flag Orlando
Thanks Meter: 400
 
More
Quote:
Originally Posted by lithid-cm

There are two different versions, one of which I am active in and developing, and the other a announced a while back that I won't be looking into much.

If you are using the CLI, that usually means its missing sync.

im using the CLI, but how do i add the sync//fix its?

sorry for being a noob
9th May 2012, 08:18 PM |#927  
lithid-cm's Avatar
OP Inactive Recognized Developer
Flag Cleveland
Thanks Meter: 2,980
 
More
Quote:
Originally Posted by [GER]Roxxor

Code:
dpkg -s cmcompiler-daily
Package: cmcompiler-daily
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 1192
Maintainer: lithid <[email protected]>
Architecture: i386
Version: 0.4-0~5~oneiric1
Depends: python
Description: Cyanogenmod Compiler daily build
 Build cyanogenmod for offically supported devices (daily development builds)
Homepage: http://forum.xda-developers.com/showthread.php?t=1415661

Damn, must have missed that. Sorry. Fix it like this.

Code:
gksudo gedit /usr/share/cmcompiler/prog/cmcompiler.py
Change line 54 from:
Quote:

cmd = "/usr/bin/cmc --sync &"

to:
Quote:

cmd = "/usr/bin/compiler --sync &"

Change line 59 from:
Quote:

cmd = "/usr/bin/cmc --compile &"

to:
Quote:

cmd = "/usr/bin/cmcompiler --compile &"

9th May 2012, 08:31 PM |#928  
jamcar's Avatar
Senior Member
Flag Orlando
Thanks Meter: 400
 
More
ok when i type in " repo init " i get

Code:
gpg: keyring `/home/james/.repoconfig/gnupg/secring.gpg' created
gpg: keyring `/home/james/.repoconfig/gnupg/pubring.gpg' created
gpg: /home/james/.repoconfig/gnupg/trustdb.gpg: trustdb created
gpg: key 920F5C65: public key "Repo Maintainer <[email protected]>" imported
gpg: Total number processed: 1
gpg:               imported: 1

Get https://android.googlesource.com/tools/repo
remote: Counting objects: 1529, done
remote: Finding sources: 100% (84/84)
remote: Total 1529 (delta 999), reused 1529 (delta 999)
Receiving objects: 100% (1529/1529), 454.54 KiB | 442 KiB/s, done.
Resolving deltas: 100% (999/999), done.
From https://android.googlesource.com/tools/repo
 * [new branch]      maint      -> origin/maint
 * [new branch]      master     -> origin/master
 * [new branch]      stable     -> origin/stable
 * [new tag]         v1.0       -> v1.0
 * [new tag]         v1.0.1     -> v1.0.1
 * [new tag]         v1.0.2     -> v1.0.2
 * [new tag]         v1.0.3     -> v1.0.3
 * [new tag]         v1.0.4     -> v1.0.4
 * [new tag]         v1.0.5     -> v1.0.5
 * [new tag]         v1.0.6     -> v1.0.6
 * [new tag]         v1.0.7     -> v1.0.7
 * [new tag]         v1.0.8     -> v1.0.8
 * [new tag]         v1.0.9     -> v1.0.9
 * [new tag]         v1.1       -> v1.1
 * [new tag]         v1.2       -> v1.2
 * [new tag]         v1.3       -> v1.3
 * [new tag]         v1.3.1     -> v1.3.1
 * [new tag]         v1.3.2     -> v1.3.2
 * [new tag]         v1.4       -> v1.4
 * [new tag]         v1.4.1     -> v1.4.1
 * [new tag]         v1.4.2     -> v1.4.2
 * [new tag]         v1.4.3     -> v1.4.3
 * [new tag]         v1.4.4     -> v1.4.4
 * [new tag]         v1.5       -> v1.5
 * [new tag]         v1.5.1     -> v1.5.1
 * [new tag]         v1.6       -> v1.6
 * [new tag]         v1.6.1     -> v1.6.1
 * [new tag]         v1.6.10    -> v1.6.10
 * [new tag]         v1.6.10.1  -> v1.6.10.1
 * [new tag]         v1.6.10.2  -> v1.6.10.2
 * [new tag]         v1.6.2     -> v1.6.2
 * [new tag]         v1.6.3     -> v1.6.3
 * [new tag]         v1.6.4     -> v1.6.4
 * [new tag]         v1.6.5     -> v1.6.5
 * [new tag]         v1.6.6     -> v1.6.6
 * [new tag]         v1.6.7     -> v1.6.7
 * [new tag]         v1.6.7.1   -> v1.6.7.1
 * [new tag]         v1.6.7.2   -> v1.6.7.2
 * [new tag]         v1.6.7.3   -> v1.6.7.3
 * [new tag]         v1.6.7.4   -> v1.6.7.4
 * [new tag]         v1.6.7.5   -> v1.6.7.5
 * [new tag]         v1.6.8     -> v1.6.8
 * [new tag]         v1.6.8.1   -> v1.6.8.1
 * [new tag]         v1.6.8.10  -> v1.6.8.10
 * [new tag]         v1.6.8.11  -> v1.6.8.11
 * [new tag]         v1.6.8.2   -> v1.6.8.2
 * [new tag]         v1.6.8.3   -> v1.6.8.3
 * [new tag]         v1.6.8.4   -> v1.6.8.4
 * [new tag]         v1.6.8.5   -> v1.6.8.5
 * [new tag]         v1.6.8.6   -> v1.6.8.6
 * [new tag]         v1.6.8.7   -> v1.6.8.7
 * [new tag]         v1.6.8.8   -> v1.6.8.8
 * [new tag]         v1.6.8.9   -> v1.6.8.9
 * [new tag]         v1.6.9     -> v1.6.9
 * [new tag]         v1.6.9.1   -> v1.6.9.1
 * [new tag]         v1.6.9.2   -> v1.6.9.2
 * [new tag]         v1.6.9.3   -> v1.6.9.3
 * [new tag]         v1.6.9.4   -> v1.6.9.4
 * [new tag]         v1.6.9.5   -> v1.6.9.5
 * [new tag]         v1.6.9.6   -> v1.6.9.6
 * [new tag]         v1.6.9.7   -> v1.6.9.7
 * [new tag]         v1.6.9.8   -> v1.6.9.8
 * [new tag]         v1.7       -> v1.7
 * [new tag]         v1.7.1     -> v1.7.1
 * [new tag]         v1.7.2     -> v1.7.2
 * [new tag]         v1.7.3     -> v1.7.3
 * [new tag]         v1.7.3.1   -> v1.7.3.1
 * [new tag]         v1.7.4     -> v1.7.4
 * [new tag]         v1.7.4.1   -> v1.7.4.1
 * [new tag]         v1.7.4.2   -> v1.7.4.2
 * [new tag]         v1.7.4.3   -> v1.7.4.3
 * [new tag]         v1.7.5     -> v1.7.5
 * [new tag]         v1.7.6     -> v1.7.6
 * [new tag]         v1.7.6.1   -> v1.7.6.1
 * [new tag]         v1.7.7     -> v1.7.7
 * [new tag]         v1.7.7.1   -> v1.7.7.1
 * [new tag]         v1.7.7.2   -> v1.7.7.2
 * [new tag]         v1.7.7.3   -> v1.7.7.3
 * [new tag]         v1.7.7.4   -> v1.7.7.4
 * [new tag]         v1.7.7.5   -> v1.7.7.5
 * [new tag]         v1.7.7.6   -> v1.7.7.6
 * [new tag]         v1.7.8     -> v1.7.8
 * [new tag]         v1.7.8.1   -> v1.7.8.1
 * [new tag]         v1.7.8.2   -> v1.7.8.2
 * [new tag]         v1.8.0     -> v1.8.0
 * [new tag]         v1.8.1     -> v1.8.1
 * [new tag]         v1.8.2     -> v1.8.2
fatal: manifest url (-u) is required.
now what?

---------- Post added at 08:31 PM ---------- Previous post was at 08:28 PM ----------

and i get this when (in CMC CLI) i hit 2 S
Code:
No File Nothing to do.
Traceback (most recent call last):
  File "/home/james/.repo/repo/main.py", line 385, in <module>
    _Main(sys.argv[1:])
  File "/home/james/.repo/repo/main.py", line 365, in _Main
    result = repo._Run(argv) or 0
  File "/home/james/.repo/repo/main.py", line 121, in _Run
    copts, cargs = cmd.OptionParser.parse_args(argv)
  File "/home/james/.repo/repo/command.py", line 44, in OptionParser
    self._Options(self._optparse)
  File "/home/james/.repo/repo/subcmds/sync.py", line 126, in _Options
    self.jobs = self.manifest.default.sync_j
  File "/home/james/.repo/repo/manifest_xml.py", line 228, in default
    self._Load()
  File "/home/james/.repo/repo/manifest_xml.py", line 263, in _Load
    b = m.GetBranch(m.CurrentBranch).merge
  File "/home/james/.repo/repo/project.py", line 557, in CurrentBranch
    b = self.work_git.GetHead()
  File "/home/james/.repo/repo/project.py", line 1909, in GetHead
    fd = open(path, 'rb')
IOError: [Errno 2] No such file or directory: '/home/james/.repo/manifests/.git/HEAD'

Press any key to go back to main menu...
9th May 2012, 08:36 PM |#929  
[GER]Roxxor's Avatar
Senior Member
Flag Nürnberg
Thanks Meter: 285
 
More
Thank you, worked so far (although you mistyped row 54 ;D)
But now it says Repo script needs setup.
Here my config:
Code:
[Cmc]
device = urushi
theme = Default
branch = ics
repo_path = /home/tim/Android/Repo
Or is it my Git configuration? Do I have to be registered? Where can I change the Git config again?
9th May 2012, 08:39 PM |#930  
lithid-cm's Avatar
OP Inactive Recognized Developer
Flag Cleveland
Thanks Meter: 2,980
 
More
Quote:
Originally Posted by [GER]Roxxor

Thank you, worked so far (although you mistyped row 54 ;D)
But now it says Repo script needs setup.
Here my config:

Code:
[Cmc]
device = urushi
theme = Default
branch = ics
repo_path = /home/tim/Android/Repo
Or is it my Git configuration? Do I have to be registered? Where can I change the Git config again?

http://forum.xda-developers.com/show...&postcount=873
9th May 2012, 09:10 PM |#931  
Member
Flag Marília, SP
Thanks Meter: 2
 
More
Erros
Quote:
Originally Posted by lithid-cm

still effected by the migration into launchpad. The patch was applied to the build. daily builds are ready for 32bit but 64 is another few hours off.

The error persists even reinstalling cmcompiler 32-bit
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes