FORUMS
Remove All Ads from XDA

[ How-To ] Fix SD card not being detected & USB port not working

1,645 posts
Thanks Meter: 9,139
 
By Calkulin, Recognized Developer on 5th June 2010, 12:51 AM
Post Reply Email Thread
6th June 2012, 06:21 PM |#331  
Brokerdan's Avatar
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by bubbavic

Can the USB fix be done even if the phone is not rooted?

Here's my problem, I was trying to root my HTC evo 4g for the first time using the TacoRoot method. Somewhere in the middle something went wrong and I had to pull back. Since I didn't finish the process, I don't think it's actually rooted. I thought I'd try again today but this morning I discovered the phone won't recognize my SD card and USB port isn't functioning. When the phone is on I can't charge it even with the wall charger. I can yank the battery and leave it off and it *seems* like it's charging. (I'll find out more later)

What can I do?? Help!!

EDIT: Ok, so I was able to get the SD card back working. Still can't get the USB fix to work since I'm not rooted. I know the idea is get temp rooted via z4root but from what I've read z4root no longer works for Evo 4Gs with the hboot 2.18 and the OTA from earlier this year. Is there something I'm missing?? Obviously, I'm a newb at all of this so any help or guidance is appreciated!

I'm not too familiar with your phone but there are a few things you can try... First download this app Root Checker

https://play.google.com/store/apps/d...Jvb3RjaGVjayJd

That should be able to tell you if you are rooted. If not you might try using z4root again this time use the permanent root setting. Keep in mind(From my experience) that you can unroot the device using z4root even if you choose perm. option. Hope that helps.
6th June 2012, 10:42 PM |#332  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by lafrad

Well, Turns out I have the same problem as before.


The writing to the /data/ directory allows it to persist past a reboot, (it seems), but it does NOT persist past a power-off.

Code:
# /data/flash_image misc /data/mtd0.img
mtd: MEMGETBADBLOCK returned 1 at 0x00000000 (errno=0)
mtd: read all-zero block at 0x00020000; skipping
mtd: not writing bad block at 0x00000000
error writing misc: No space left on device
This is done from a adb shell... USB works on the restart after typing it in on the device, it just didn't seem to persist past a reboot...

Quote:
Originally Posted by lafrad

Well, I'm out of ideas.

Phone can get the USB "enabled" by using this method, but it will not persist past most power-downs. RUU is even failing.

It appears something is messed up with the partitioning of the system... as I'm unable to write to the /system mount, even when its remounted in read/write. (out of memory)

"mount" reports:

Code:
mount
rootfs / rootfs ro 0 0
tmpfs /dev tmpfs rw,mode=755 0 0
devpts /dev/pts devpts rw,mode=600 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
tmpfs /sqlite_stmt_journals tmpfs rw,size=4096k 0 0
none /dev/cpuctl cgroup rw,cpu 0 0
/dev/block/mtdblock4 /system yaffs2 rw 0 0
/dev/block/mtdblock6 /data yaffs2 rw,nosuid,nodev 0 0
/dev/block/mtdblock5 /cache yaffs2 rw,nosuid,nodev 0 0
tmpfs /app-cache tmpfs rw,size=8192k 0 0
/dev/block//vold/179:1 /sdcard vfat rw,dirsync,nosuid,nodev,noexec,uid=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

Quote:
Originally Posted by lafrad

Well, the thread helped me to get to a stable state to apply the RUU from the OTA update... That fully cleared up all problems.

Now lets cross the fingers and hope I can properly re-root again when I get the time.

Thanks everyone.


How did you go about solving this again? I'm trying to apply the RUU now but I feel like I'm missing a step here. I was able to get root on the phone (htcdev method). SD card fix seems to work. But now, I'm getting the same "No space left on device" error at the last step of the USB fix. Anyone have any ideas on what I should do??

---------- Post added at 02:42 PM ---------- Previous post was at 01:57 PM ----------

I'm retarded. The RUU file I had had the extension renamed to zip instead of exe. Running the exe put my phone back to stock. SD card works and USB port works again! Hooray!

For anyone having issues with OP's method or who ran into the problem I posted above try this. It worked for me. =)

Thanks everyone!
12th June 2012, 10:57 PM |#333  
Senior Member
Thanks Meter: 69
 
More
thanks both worked perfectly, saved my phone!
23rd July 2012, 02:07 PM |#334  
Member
Thanks Meter: 1
 
More
i've HTC wildfire S Marvel. it got bricked during an ruu update. i got the boot repaired but now it does not detect sd card in Hboot. will this method work on it too?
24th July 2012, 11:09 AM |#335  
Senior Member
Flag Almaty
Thanks Meter: 11
 
More
Phone's USB port is broken HTC DROID INCREDIBLE
When iwrite in terminal this:/data/flash_image misc /data/mtd-eng.img
i have an error:
Segmentation fault
How can i repair my phone's USB port?
17th September 2012, 01:19 PM |#336  
jrny99's Avatar
Senior Member
Flag Williams AZ.
Thanks Meter: 209
 
More
Wink
Quote:
Originally Posted by West650

You tried hard resetting already?

Turn the power off.

If your HTC EVO 4G is frozen, pull the battery out and reinsert it

Hold the Volume Down button

Press and release the Power button

You are now presented with a menu that allows for Fastbook, Recovery, Clear Storage, and Simlock

Select Clear Storage by pressing the Volume Down button

Press and release the Power button

Now simply confirm your decision: Volume Up for YES and Volume Down for NO

If you selected YES, all data including third-party applications will be deleted from the HTC EVO 4G. Once the wipe is complete, the phone will reboot to its factory fresh state.

can I do this to simply reset my phone to a factory fresh state while I'm rooted running a rooted Rom and will I lose root and/ or just brick my phone and get to try some of the other stuff here

great write up . . .
26th April 2013, 12:35 AM |#337  
Senior Member
Thanks Meter: 31
 
More
Lol

Sent from my SPH-L710 using xda premium
16th February 2014, 03:00 PM |#338  
Member
Thanks Meter: 39
 
More
HOOOOORAY
Thank you so much for the help, guys like yourselves are golden.
21st August 2014, 12:35 PM |#339  
Junior Member
Thanks Meter: 1
 
More
just want to confirm, this method 100% working.
make sure your usb port working fine.

tested....
31st August 2014, 11:34 PM |#340  
Senior Member
Flag Lake Milton
Thanks Meter: 15
 
More
OG EVO 4G sdcard not mounting
hi. i have tried this fix and it is NOT working for me. i used a card reader to transfer the files but cant flash them cause it wont mount my sdcard. how do i get my sdcard to mount. ive even freshly formatted it and reflashed my recovery
3rd February 2015, 12:51 AM |#341  
Unidave199's Avatar
Senior Member
Thanks Meter: 38
 
More
Thank you!!
[QUOTE=Calkulin;6696983]Decided to update the instructions for this fix.

Thx to sruon for the fix

Original instructions pulled from IEFtm's post @ Modaco



Tried using the 'manual' method but it was a no go! Just wouldn't seem to work. I know this post was from years ago but would highly recommend loading the update zip from the above link and installing it on your SD card (I have a reader). It also fixed the problem of my phone bootlooping unless attached to the USB!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes