Remove All Ads from XDA
H10 Turbo

Battery acting weird since installing kit kat roms

124 posts
Thanks Meter: 2
By daevion0, Senior Member on 24th January 2014, 12:26 AM
Post Reply Email Thread
For some reason my battery is acting like it barely wants to charge. It'll take hours just to go up by 4% and once it reaches a certain point, it no longer moves up in percentage. Sometimes it stops at 14%, sometimes it stops at 32% and sometimes it stops at 8, it's completely random. Also when I restart it, the battery percentage is completely different than what it was before. The weirdest thing is that the battery percentage actually decreases sometimes while it's on the charger. Even when I cut the phone completely off and it's showing the battery charge icon, the phone drains in percentage. This just started a couple of days ago, maybe a week after I flashed a kit kat rom.
24th January 2014, 01:21 AM |#2  
gamepro602's Avatar
Senior Member
Flag Mesa
Thanks Meter: 341
Did you even check your port or chord? I would flash back to stock to make sure that it isn't the ROMs fault. Though it could be the battery😐

🎮 Powered By My Moga Pro 🎮
26th January 2014, 01:33 AM |#3  
Junior Member
Thanks Meter: 5
This has happened to me with third party batteries so try another battery and another charger. I'm running kit kat on my S2 and battery usage is quite a bit better.
26th January 2014, 05:12 PM |#4  
mattzeller's Avatar
Senior Member
Flag New Orleans
Thanks Meter: 577
Donate to Me
I had the same problem, I tried different USB cables, flashed back to stock, nothing fixed it. I finally figured out it's charging port was going out. I took it to a place they had it replaced in 30 minutes, I'm now able to charge my phone fully and my battery life is back to being great.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes