FORUMS
Remove All Ads from XDA

[APP] Official ViPER4Android Audio Effects (FX v2.5.0.5) - New Features & 7.0 Support

4,134 posts
Thanks Meter: 14,609
 
By zhuhang, Recognized Contributor on 15th March 2013, 05:42 AM
Post Reply Email Thread
1st May 2015, 10:19 AM |#18171  
bmccoy11's Avatar
Senior Member
Flag Seattle, WA
Thanks Meter: 80
 
Donate to Me
More
Quote:
Originally Posted by Junaid1460

I have built v4a from source ... For 5.x.x android devices in material design..

Just created a new launcher icon ... Instead the old..

Tested on Android 5.1 aarch64

Download::

[email protected]

Thanks! This version works for me in 5.1.1.
1st May 2015, 10:21 AM |#18172  
Zeuszoos's Avatar
Senior Member
Thanks Meter: 231
 
More
Quote:
Originally Posted by jmxc23

For Kit Kat you have to install XIFI as a system app. As for Lollipop the FX instructions also applies to XHIFI.

I did install it as a System App, set permissions, build.prop edit, etc..

FX works fine. It's XHiFi that won't work for me in KK.

I'm also (thanks to a link from the Admin) investigating in another "questions" thread about this issue.

I really wish the Devs had made it work at least in KK before stopping development of XHiFi, since I believe it was out at the time.
1st May 2015, 10:24 AM |#18173  
DarkBlack22's Avatar
Senior Member
Thanks Meter: 64
 
More
Viper4android keeps restarting.....

Sent from my GT-I9505 using WIGGLE WIGGLE WIGGLE
1st May 2015, 11:20 AM |#18174  
GorfDroid's Avatar
Senior Member
Flag Toronto
Thanks Meter: 194
 
More
Quote:
Originally Posted by DarkBlack22

Viper4android keeps restarting.....

Sent from my GT-I9505 using WIGGLE WIGGLE WIGGLE

Move to /system/app
1st May 2015, 11:28 AM |#18175  
Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by kvevand63

Check your /system/lib/soundfx. If you don't see the lib file for XHiFi (the driver), open the XHiFi apk and look in its assets folder for the correct lib file for your processor/android version (I use the Neon jb version on my device). Copy and paste to /system/lib/soundfx, be sure to delete the jb or ics following the so at the end of the file name and reboot. Re-install driver from XHiFi. Double check /system/etc/audio_effects conf and see if the entries for XHiFi are present. If not, you will have to make the entry yourself. I am using both V4A and XHiFi installed in /system on CM11 ROM with no problems. I hope this helps you. The same can be used for troubleshooting driver install problem with V4A.

How do you make an entry for xhifi in audio_effects conf?
1st May 2015, 12:26 PM |#18176  
Senior Member
Flag Hyderabad
Thanks Meter: 91
 
More
help unable to get to work on 5.1.1
driver installed but shows
status =abnormal
audio format = unsupported
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2015-05-01-15-46-35.png
Views:	606
Size:	66.5 KB
ID:	3291128  
1st May 2015, 12:36 PM |#18177  
Zeuszoos's Avatar
Senior Member
Thanks Meter: 231
 
More
Quote:
Originally Posted by dinaps86

No I mean a kernel for your phone I don't know what the OEM is I have a sprint galaxy s4 and a sprint galaxy note edge devs have worked on the s4 but not so much the edge

The OEM ROM simply means it's from (in my case) Samsung. I.e., it's not a Custom ROM. I was saying that I have never seen a Kernel put out by a developer to replace the Kernel that comes with a phone's OEM (Original Equipment Manufacturer) ROM. And I have searched a lot! There are things that a Custom Kernel would allow me to do, like OverClocking my CPU, while knocking the Voltage at each Frequency down, to keep the heat down while running faster, for one thing.

But hey, if you know where these Custom Kernels live, then please tell me, so I can go knock on their door. I'd be very grateful!
1st May 2015, 12:57 PM |#18178  
milski65's Avatar
Senior Member
Orange
Thanks Meter: 1,310
 
More
Quote:
Originally Posted by nik007rock

help unable to get to work on 5.1.1
driver installed but shows
status =abnormal
audio format = unsupported

It was recently answered. See the black box right hand side of enable? You need to tap that to turn it on.

Sent from my SM-N900V using Tapatalk 2
1st May 2015, 12:58 PM |#18179  
Zeuszoos's Avatar
Senior Member
Thanks Meter: 231
 
More
Quote:
Originally Posted by adf2009

Just install below apk.

Okay. And I assume that creates an app that I need to run?

Also, this will work for me, even though I am NOT running a Custom ROM? Because I am running the Samsung Stock KitKat 4.4.4 ROM (Rooted).

I don't mean to be a pain. I just would like to be sure that you know my setup before I run anything that makes changes in something that goes down to the core of the OS, you know?

Thank You!
1st May 2015, 01:37 PM |#18180  
Senior Member
Flag Heredia
Thanks Meter: 1,051
 
Donate to Me
More
Quote:
Originally Posted by Zeuszoos

Okay. And I assume that creates an app that I need to run?

Also, this will work for me, even though I am NOT running a Custom ROM? Because I am running the Samsung Stock KitKat 4.4.4 ROM (Rooted).

I don't mean to be a pain. I just would like to be sure that you know my setup before I run anything that makes changes in something that goes down to the core of the OS, you know?

Thank You!

YOU need to start doing some reading and stop being a PITA.
The Following User Says Thank You to cdzo72 For This Useful Post: [ View ] Gift cdzo72 Ad-Free
1st May 2015, 01:51 PM |#18181  
souler456's Avatar
Senior Member
Flag Calamba, Laguna
Thanks Meter: 636
 
More
Can someone help?

I'm currently using Poweramp v2.0.10 Build 579, and I can't use V4A with it. I'm switching between Normal and Compatible Mode on V4A but still no success. Can some Poweramp users here tell me how to get it work?


Post Reply Subscribe to Thread

Tags
best settings, convolver, cure tech+, fx xhifi, irs impulse response sample, settings, viper4android v4a, virtual headphone surround engine+

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes