FORUMS
Remove All Ads from XDA
Honor CEO Thread

[UPDATE]Universal Multipurpose AutoAPKTool 2.0.4a

3,987 posts
Thanks Meter: 7,952
 
By agat63, Inactive Recognized Developer on 2nd April 2012, 01:50 AM
Post Reply Email Thread
25th June 2012, 07:44 AM |#141  
lorjay589's Avatar
Senior Member
Flag Baltimore, MD
Thanks Meter: 2,663
 
Donate to Me
More
lol ok one more time, so everyone can get it. I know that to, but its not recompiling the resource with the new edits its making an exact copy of the original in the out folder and its no use to dragging any of the stuff over because its still the same
 
 
25th June 2012, 11:56 AM |#142  
tdunham's Avatar
Recognized Contributor
TampaBay
Thanks Meter: 36,513
 
Donate to Me
More
Quote:
Originally Posted by lorjay589

lol ok one more time, so everyone can get it. I know that to, but its not recompiling the resource with the new edits its making an exact copy of the original in the out folder and its no use to dragging any of the stuff over because its still the same

Maybe you can post your original framework so we can take a look at it?
25th June 2012, 08:00 PM |#143  
Senior Member
Flag Atlanta, GA
Thanks Meter: 88
 
More
Quote:
Originally Posted by tdunham

So this is when you're compiling it correct? That window that pops up when you decompile, it says everything is perfect right?
Also, have to tried to compile right away after decompile without making any changes first? Post your mms.apk so I can try it too when you have time. I don't feel up to downloadling the entire rom.

This is my mms.apk and my twframework-res.apk, they are ICS 4.0.3 apks
Attached Files
File Type: apk Mms.apk - [Click for QR Code] (1.46 MB, 5 views)
File Type: apk twframework-res.apk - [Click for QR Code] (553.2 KB, 4 views)
25th June 2012, 11:45 PM |#144  
tdunham's Avatar
Recognized Contributor
TampaBay
Thanks Meter: 36,513
 
Donate to Me
More
Quote:
Originally Posted by jrod091

This is my mms.apk and my twframework-res.apk, they are ICS 4.0.3 apks

Ok, I only loaded your twframework with option 81 since it is the only framework you sent us. It decompiled fine. It appeared to recompile fine also except for this:
[*] G:\Sync\Android\AutoAPKTool2.0.4\_INPUT_APK\Mms
recompiling G:\Sync\Android\AutoAPKTool2.0.4\_INPUT_APK\Mms...
I: Copying classes.dex file...
I: Building resources...
aapt: warning: string 'cc_address_label' has no default translation in G:\Sync\Android\AutoAPKTool2.0.4\_INPUT_APK\Mms\re s; found: de fr it ko
I: Building apk file...

I don't know what the cc_address_label is but anyway it compiled fine for me otherwise.

Then I used Apk Manager 5.02 with pretty much the exact same results, the log reflects the same string problem but still compiles fine.

Edit: I don't use the AutoAPKtool for everything so I don't know if it tells you or not but some apk files work with the twframework file but not the framework-res file so maybe that is the only problem. Don't use the framework-res (option 1), just the other (option 81) and try it again.
With APK Manager if I use the wrong framework, APK Manager will tell me if it is the wrong dependency so then I have to try the other framework file (in this case twframework).
The Following User Says Thank You to tdunham For This Useful Post: [ View ] Gift tdunham Ad-Free
26th June 2012, 12:12 AM |#145  
sleshepic's Avatar
Recognized Themer
Flag PA
Thanks Meter: 7,053
 
Donate to Me
More
Yeah don't worry about that translation issue, looks like it compiled fine

Sent from my SPH-D710 using xda premium
The Following User Says Thank You to sleshepic For This Useful Post: [ View ] Gift sleshepic Ad-Free
26th June 2012, 12:21 AM |#146  
agat63's Avatar
OP Inactive Recognized Developer
Las Vegas, NV
Thanks Meter: 7,952
 
Donate to Me
More
You can disregard that translation warning since the aapt.exe did find them in de (german) fr (french) it (italian) ko (korean).
In general if there are real errors you won't see the last line:
I. Building apk.
If the line is there apk is compiled correctly.
As for framework files.
I always have both installed. framework-res.apk with option 1 and twframework-res.apk with option 81.
This way any app can use dependency it needs and I don't have to worry about it.
26th June 2012, 12:23 AM |#147  
Senior Member
Flag Atlanta, GA
Thanks Meter: 88
 
More
Quote:
Originally Posted by tdunham

Ok, I only loaded your twframework with option 81 since it is the only framework you sent us. It decompiled fine. It appeared to recompile fine also except for this:
[*] G:\Sync\Android\AutoAPKTool2.0.4\_INPUT_APK\Mms
recompiling G:\Sync\Android\AutoAPKTool2.0.4\_INPUT_APK\Mms...
I: Copying classes.dex file...
I: Building resources...
aapt: warning: string 'cc_address_label' has no default translation in G:\Sync\Android\AutoAPKTool2.0.4\_INPUT_APK\Mms\re s; found: de fr it ko
I: Building apk file...

I don't know what the cc_address_label is but anyway it compiled fine for me otherwise.

Then I used Apk Manager 5.02 with pretty much the exact same results, the log reflects the same string problem but still compiles fine.

Edit: I don't use the AutoAPKtool for everything so I don't know if it tells you or not but some apk files work with the twframework file but not the framework-res file so maybe that is the only problem. Don't use the framework-res (option 1), just the other (option 81) and try it again.
With APK Manager if I use the wrong framework, APK Manager will tell me if it is the wrong dependency so then I have to try the other framework file (in this case twframework).

Interesting, thanks for all your help, I'll try just the twframework

Only apks I got to decompile correctly so far were both the framework-res apks, weird, lol

Sent from my SGH-I777 using XDA
26th June 2012, 12:33 AM |#148  
sleshepic's Avatar
Recognized Themer
Flag PA
Thanks Meter: 7,053
 
Donate to Me
More
Quote:
Originally Posted by jrod091

Interesting, thanks for all your help, I'll try just the twframework

Only apks I got to decompile correctly so far were both the framework-res apks, weird, lol

Sent from my SGH-I777 using XDA

If that's the case it sounds like your having issues with the classes.dex? Try pulling out that before you decompile and see what happens. Are you getting errors relating to bad magic values? The reason I say this is because the frameworks don't have a classes.dex file....

Sent from my SPH-D710 using xda premium
The Following User Says Thank You to sleshepic For This Useful Post: [ View ] Gift sleshepic Ad-Free
26th June 2012, 12:38 AM |#149  
Senior Member
Flag Atlanta, GA
Thanks Meter: 88
 
More
Grr...

that didn't help either. I tried twframework-res.apk and framework-res.apk again, and they both decompile and recompile fine, but any other apk I try from this ROM give me the same exact error when I decompile it with option 14...

when I try to decompile an apk from my AOKP ROM, they all decompile fine and recompile fine

In conclusion, I'm utterly lost, lol

---------- Post added at 07:38 PM ---------- Previous post was at 07:35 PM ----------

Quote:
Originally Posted by sleshepic

If that's the case it sounds like your having issues with the classes.dex? Try pulling out that before you decompile and see what happens. Are you getting errors relating to bad magic values? The reason I say this is because the frameworks don't have a classes.dex file....

Sent from my SPH-D710 using xda premium

that's what I'm about to try, I remember reading something about that before

Thank you sir! that worked!!
26th June 2012, 02:28 AM |#150  
sleshepic's Avatar
Recognized Themer
Flag PA
Thanks Meter: 7,053
 
Donate to Me
More
Quote:
Originally Posted by jrod091

Grr...

that didn't help either. I tried twframework-res.apk and framework-res.apk again, and they both decompile and recompile fine, but any other apk I try from this ROM give me the same exact error when I decompile it with option 14...

when I try to decompile an apk from my AOKP ROM, they all decompile fine and recompile fine

In conclusion, I'm utterly lost, lol

---------- Post added at 07:38 PM ---------- Previous post was at 07:35 PM ----------



that's what I'm about to try, I remember reading something about that before

Thank you sir! that worked!!

Or if you know how to use apk manager this one is modded for ics and works on most
http://forum.xda-developers.com/show...0&postcount=14

Sent from my SPH-D710 using xda premium
The Following User Says Thank You to sleshepic For This Useful Post: [ View ] Gift sleshepic Ad-Free
26th June 2012, 02:34 AM |#151  
Senior Member
Flag Atlanta, GA
Thanks Meter: 88
 
More
Quote:
Originally Posted by sleshepic

Or if you know how to use apk manager this one is modded for ics and works on most
http://forum.xda-developers.com/show...0&postcount=14

Sent from my SPH-D710 using xda premium

Thanks! I've been looking for an ICS mod to apk manager!

Sent from my SGH-I777 using XDA
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes