FORUMS
Remove All Ads from XDA

[APP][2.3+] Lux Auto Brightness

599 posts
Thanks Meter: 652
 
By Cyb3rGlitch, Senior Member on 19th October 2012, 12:58 PM
Post Reply Email Thread
18th December 2013, 10:49 PM |#1101  
Bob823's Avatar
Senior Member
Thanks Meter: 87
 
More
I think you have to join the G+ community and opt-in for beta builds via Google Play.
 
 
19th December 2013, 05:51 AM |#1102  
Cyb3rGlitch's Avatar
OP Senior Member
Thanks Meter: 652
 
More
Quote:
Originally Posted by AutomaticFailure27

Latest beta seems to go to max brightness randomly. Been happening more on my nexus 7 than my galaxy nexus. If logs are needed, what should I be using? Currently has catlog installed on both.

Sent from my Nexus 7 using Tapatalk 4

Is this the 2012 or 2013 model? Do you have multiple user accounts?

Quote:
Originally Posted by erowntip

Hmm, is last version buggy? Last 1-2 weeks for no apparent reason the app detects a completely dark room as 3000 lx. It's not the phone, as soon as I reinstall the app it correctly detects the light correctly. This is getting very annoying.

Which device are you using?

Quote:
Originally Posted by SamBG

If i keep a persistent notification ll this app drain battery.. Usin this app for the first tym!!

If my post helped u a bit...help me by pressin the THANK button!!!

It will not drain any more battery than when the notification is off.

Quote:
Originally Posted by bongostl

I tried.... but I couldn't get the bottom corners to catch easily, so I had to universal lux

Sent from my XT1058 using Tapatalk

SwipePad incompatibilities should be fixed with the latest Lux update.

Quote:
Originally Posted by klyzon

i do not have any apps that uses overlays...

The latest update of Lux should solve your issue.
The Following 3 Users Say Thank You to Cyb3rGlitch For This Useful Post: [ View ] Gift Cyb3rGlitch Ad-Free
19th December 2013, 06:23 AM |#1103  
122ninjas's Avatar
Senior Member
Arizona
Thanks Meter: 952
 
More
I've been having times where the lux count shoots up to 10240 or whatever the max is for no reason. It fixes itself after a while. Even restarting lux doesn't fix it. Doesn't seem to happen much on kitkat but it used to happen twice a week on jelly bean. Using an att s2 (i777)

Sent from my SGH-I777 using Tapatalk
19th December 2013, 06:23 AM |#1104  
AutomaticFailure27's Avatar
Senior Member
Thanks Meter: 333
 
More
Quote:
Originally Posted by Cyb3rGlitch

Is this the 2012 or 2013 model? Do you have multiple user accounts?

2013 model and only my account. Since that post it hasn't happened so maybe it was just a fluke.


Sent from my Nexus 7 using Tapatalk 4
19th December 2013, 06:55 PM |#1105  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Cyb3rGlitch

Is this the 2012 or 2013 model? Do you have multiple user accounts?
Which device are you using?

Note 2 N7100
Android 4.1.2

I've done some testing and it seems the app gets stuck on the last reading in light. E.g. it detects X LX from a light source correctly. I turn off all lights. The app seems to try to read the light ten times and fails I guess. So even though it's completely dark the last reading will be used to set the brightness. I've never had this problem before.

I dunno. Maybe my phone is broken now less than 6 months after purchase.

Here's send feedback data (which I accidently mailed a few minutes ago without any bug report): http://pastebin.com/B8HA17te
20th December 2013, 03:38 AM |#1106  
Member
Thanks Meter: 9
 
More
Just want to ask the dev why it isn't possible for Lux to use the Camera Source for the Dynamic Mode?
20th December 2013, 02:04 PM |#1107  
Cyb3rGlitch's Avatar
OP Senior Member
Thanks Meter: 652
 
More
Quote:
Originally Posted by 122ninjas

I've been having times where the lux count shoots up to 10240 or whatever the max is for no reason. It fixes itself after a while. Even restarting lux doesn't fix it. Doesn't seem to happen much on kitkat but it used to happen twice a week on jelly bean. Using an att s2 (i777)

Sent from my SGH-I777 using Tapatalk

Does it do this on the Lux Debug page in settings?

Quote:
Originally Posted by erowntip

Note 2 N7100
Android 4.1.2

I've done some testing and it seems the app gets stuck on the last reading in light. E.g. it detects X LX from a light source correctly. I turn off all lights. The app seems to try to read the light ten times and fails I guess. So even though it's completely dark the last reading will be used to set the brightness. I've never had this problem before.

I dunno. Maybe my phone is broken now less than 6 months after purchase.

As above, does it do this on the Lux Debug page in settings?

Quote:
Originally Posted by thewaywardgeek013

Just want to ask the dev why it isn't possible for Lux to use the Camera Source for the Dynamic Mode?

Because keeping the camera on would be detrimental to battery life.
The Following User Says Thank You to Cyb3rGlitch For This Useful Post: [ View ] Gift Cyb3rGlitch Ad-Free
20th December 2013, 03:14 PM |#1108  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Cyb3rGlitch

Does it do this on the Lux Debug page in settings?

No. The app is now stuck at 3000 lx while both light and prox sensor works fine in debug.
21st December 2013, 04:28 PM |#1109  
Senior Member
Thanks Meter: 173
 
More
I'm using Lux Pro (latest) on a Nexus 4, including the root plugin. I'm on 4.4.2 stock using SuperSU.

Two problems:

- root plugin does not work for subzero levels (just doesn't adjust below zero), while subzero works when the plugin is disabled. Logcat doesn't show anything special.

- sometimes the display doesn't adjust. Lux shows correct values, they change, everything seems ok - only the actual display brightness is not changed. It also doesn't help to adjust brightness via android settings. This happens without the plugin.

Any ideas?

Gesendet von meinem Nexus 7 mit Tapatalk
22nd December 2013, 11:21 AM |#1110  
xxBrun0xx's Avatar
Senior Member
Flag CT
Thanks Meter: 619
 
More
First off, Id like to say this is a brilliant idea!

I've got a note 2 and I've noticed that whenever set to a value below 0, the screen will light up whenever I open a new app, then it will dim itself again. Any ideas?
22nd December 2013, 12:29 PM |#1111  
Moz007's Avatar
Senior Member
Flag France
Thanks Meter: 51
 
More
I LOVE this app, i use the full version since i see it on xda a few month ago, a must have now !
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes