FORUMS
Remove All Ads from XDA

Nexus 7 - WiFi Ad-Hoc fix for wpa_supplicant?

49 posts
Thanks Meter: 9
 
By wikid24, Member on 21st July 2012, 08:41 PM
Post Reply Email Thread
Update March 25, 2013:

Solved!! The folks over at Thinktube Inc. have developed a fix and submitted it to CyanogenMod and AOSP for merging into their code:
http://b-real.org/2013/ad-hoc-ibss-m...h-cyanogenmod/
http://www.thinktube.com/android-tec...roid-wifi-ibss

Essentially the EASIEST solution is to ROOT your phone, and install the CyanogenMod nightly as of March 25 or later (note: you will have to wait until the nightly is actually BUILT, since as of today it is not ready yet).

I have not tested this solution out myself, however others within this thread have confirmed it working.

Please if anyone develops a easier patch or a step-by-step for people who do NOT want to use CyanogenMod, post and I will update the OP

Cheers!
WiKiD24

-------------------------------------------------------
Update Oct 9, 2012:

- Nexus 7 v4.1.2 did not add Wi-Fi Ad-Hoc Support with the stock update from Google.
To do: Check if any WPA-Supplicant changes previously tested in v4.1.1 now work in 4.1.2

- Workaround (Recommended): Bluetooth Tethering to Nexus 7 Tablet (via Bluetooth DUN Profile). "BlueVPN" from Google Play Store.
Tested successfully on many Nokia Symbian phones (N7, E71, E72), and others.
However, many applications on Nexus 7 Tablet do not support it (without fixes from the developers)

Confirmed working applications:
- Pulse
- Google Chrome
- Dolphin Browser
- Facebook
- Ebuddy
- Youtube
- Others (I am too lazy to add them all)

Confirmed NOT working applications:
- Gmail
- Email
- Google Search
- Google Play Store
- Dropbox
- Words with Friends
- Scramble with Friends
- Others (I am too lazy to add them all)

More details can be found here: http://forum.xda-developers.com/show...2&postcount=27

Issue: Sometimes the phone/tablet do not connect (randomly), due to issues with either the phone or the tablet.
To resolve: Turn on and off bluetooth on phone, Turn on & off bluetooth on tablet. Try again. If does not work, reboot phone and tablet and try again. Should work.

-Workaround: Android Phone to Nexus 7 Tablet (via "FoxFI" App on Phone, "FoxFi Addon" App on Tablet, or via "PDANet", or via "Wireless Tether App")

http://forum.xda-developers.com/show...2&postcount=27

- Workaround: USB Tethering ANY Phone to Nexus 7 Tablet (via "PPP Widget" App on Tablet, requires rooted Nexus 7)

http://forum.xda-developers.com/show...3&postcount=51

- Workaround: Windows WiFi Laptop Tethering to Nexus 7 Tablet
http://www.youtube.com/watch?v=klHzMyYFGeQ
-------------------------------------------------------
Hi All,

I've just recently gotten a Nexus 7 and need to be able to enable Ad-Hoc wifi on the tablet.

I also own a Asus TF101 and previously had the same problem however there was a fix for that.

The solution was to replace the wpa_supplicant file in the /system/bin folder, however I do not know the code to change it.

If anyone has the technical know-how, they would be able to reverse-engineer it and apply the same fix.
http://forum.xda-developers.com/show....php?t=1370955
http://szym.net/2010/12/adhoc-wifi-in-android/
http://www.slatedroid.com/topic/2752...less-hotspots/
http://www.olsr.org/?q=olsr_on_android
http://hostap.epitest.fi/gitweb/gitw...upplicant.conf
The Following User Says Thank You to wikid24 For This Useful Post: [ View ] Gift wikid24 Ad-Free
22nd July 2012, 06:46 AM |#2  
demandarin's Avatar
Senior Member
Flag Alexandria, Va
Thanks Meter: 2,049
 
More
I posted a possible solution in QnA section. Thread title is similar to this one. Check it out. Doesn't involve any coding. Prime had a similar issue on a few firmware updates. This was solved for us(before Asus came around to enabling it themselves) by adding in a wifi supplicant file and renaming an older one. Then setting permissions on the new file. Here is the link to that thread. There's a good chance it will work without the file needing to be modded. It came from a galaxy tab LR something and worked fine on prime. Its worth checking out.

http://forum.xda-developers.com/show....php?t=1438297
23rd July 2012, 04:46 AM |#3  
OP Member
Thanks Meter: 9
 
More
thanks for the tip and I tried it out, which is essentially the same type of solution but it didn't think work as there is no wpa_supplicant2 file in the nexus 7.
23rd July 2012, 02:18 PM |#4  
OP Member
Thanks Meter: 9
 
More
http://forum.xda-developers.com/show....php?t=1777413
24th July 2012, 02:49 PM |#5  
OP Member
Thanks Meter: 9
 
More
here's some more useful information for enabling ad hoc:

http://szym.net/2010/12/adhoc-wifi-in-android/

http://www.slatedroid.com/topic/2752...less-hotspots/

http://www.olsr.org/?q=olsr_on_android

http://hostap.epitest.fi/gitweb/gitw...upplicant.conf

I'm doing what I can right now to try and enable it.

Some more experienced android users whom know what they're doing would be better than me trying it out, though!!
The Following User Says Thank You to wikid24 For This Useful Post: [ View ] Gift wikid24 Ad-Free
24th July 2012, 10:09 PM |#6  
Junior Member
Thanks Meter: 0
 
More
Did any of those sources of information get you any closer to enabling ad-hoc?
25th July 2012, 06:50 AM |#7  
jenda.69's Avatar
Senior Member
Thanks Meter: 33
 
More
Just FYI that Nexus S "ad hoc enabling file" doesn't work on NS with Jelly Bean.
25th July 2012, 01:57 PM |#8  
OP Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by nexususer0101

Did any of those sources of information get you any closer to enabling ad-hoc?

None yet, I need some help to do so. There is a file called "wpa_cli" that I need copied from another device, because I can't find it on the internet.

If anyone could find it in their "/system/bin" folder and attach it to this tread, I could certainly try it.

I've also requested the same thing in the Q&A forum here: http://forum.xda-developers.com/show....php?t=1793437
The Following User Says Thank You to wikid24 For This Useful Post: [ View ] Gift wikid24 Ad-Free
29th July 2012, 02:17 PM |#9  
Protocol 7's Avatar
Member
Flag New York City
Thanks Meter: 2
 
More
Bumping; I have the same condition. I'm in Italy and bought an internet package for my laptop--I'm sharing it with all my other devices but the N7 doesn't see the adhoc connection. Like OP said, I had a Transformer TF101 and remember flashing a file to fix it.

Thanks in advance.

Just an FYI: Also checked my GNex for a wpa_cli and came up empty.
30th July 2012, 11:30 AM |#10  
OP Member
Thanks Meter: 9
 
More
Just wanted to give quick update, i have not been able to find anyone to help me and also my life is kinda hectic right now... Hopefully someone will be able to pick up where I left off, in the meantime my nexus 7 is pretty much useless to me until resolved.
31st July 2012, 12:09 AM |#11  
Senior Member
Thanks Meter: 35
 
More
Unhappy One more "me too".
I'm here to share my sympathy to everyone else's pain as I have a nexus 7 that I can't connect to my phone's adhoc Hotspot. I have also posted my query in Android Central, but no one seems to have been able to know a fix as of yet. (topic can be found here: Android Forums at AndroidCentral.com > Google Nexus 7 Tablet Forum > Nexus 7 Rooting ROM's & Hack's > *** CONNECTING TO Adhoc WiFi WITH THE NEXUS 7 ***)

As I said in that thread.. not being able to connect to phones hotspot makes my beautiful nexus 7 feel like a handicapped tablet.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes