FORUMS
Remove All Ads from XDA

[GUIDE] The Generic SD Issue (READ FIRST)

410 posts
Thanks Meter: 340
 
By KingAmir, Senior Member on 29th September 2012, 10:00 PM
Post Reply Email Thread
7th November 2012, 01:47 PM |#11  
Junior Member
Thanks Meter: 4
 
More
I just bought a new Samsung 16Gb Class 10 micro SD card to replace my old 2Gb card.

First thing when I plug it in, it says it is damaged, and gives me an option to format the card. > Formatted using the phone, the card does not show up. From storage I can activate the SD card as it is still not showing, and the same thing comes up, over and over again. If I plug in the old one, no problem there, working like a charm.

I inserted it to my laptop with the SD adapter that came with it, and it shows up just fine ( size 15Gb). Windows XP format tool does not allow format to NTFS so I looked forward, ended up downloading HP USB Disk Storage Format Tool and SDFormatter. I got the card formatted to NTFS, but my phone still is saying the same thing.

What can I do next?
The Following User Says Thank You to Charius For This Useful Post: [ View ] Gift Charius Ad-Free
 
 
9th November 2012, 09:09 AM |#12  
Junior Member
Flag Bangalore
Thanks Meter: 2
 
More
Nice guide..thanks a ton...what about the "write protected" error that are frequently coming up these days - any thoughts on that one?
10th November 2012, 06:47 AM |#13  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Deftone

If the gold contacts are dirty in anyway, this will mean the device will not be able to read it. Using a finger can scratch the contacts and make it corrupt. Instead use a cloth, microfiber if you have one. The reader, (device) will also accumulate dust over time. Clean out the reader with an earbud. This may also solve this issue.

I never thought that finger scratches can be harmful with sd contacts. I used to wipe those plates with my fingers. Thanks for the info!
10th November 2012, 07:08 PM |#14  
KingAmir's Avatar
OP Senior Member
Flag London
Thanks Meter: 340
 
More
Quote:
Originally Posted by userofandroid

Nice guide..thanks a ton...what about the "write protected" error that are frequently coming up these days - any thoughts on that one?

Hey,

This is because the physical switch on your sd is on lock. Try sliding it the other way. This will un-lock it.
If this fails you could try right clicking on your sd in my computer. Going to properties and then unchecking read-only.
Thanks for this, I will add it to the guide.

Quote:
Originally Posted by Charius

I just bought a new Samsung 16Gb Class 10 micro SD card to replace my old 2Gb card.

First thing when I plug it in, it says it is damaged, and gives me an option to format the card. > Formatted using the phone, the card does not show up. From storage I can activate the SD card as it is still not showing, and the same thing comes up, over and over again. If I plug in the old one, no problem there, working like a charm.

I inserted it to my laptop with the SD adapter that came with it, and it shows up just fine ( size 15Gb). Windows XP format tool does not allow format to NTFS so I looked forward, ended up downloading HP USB Disk Storage Format Tool and SDFormatter. I got the card formatted to NTFS, but my phone still is saying the same thing.

What can I do next?

Hey There,

My best bet would be that your card is corrupt. Try formatting to other formats (FAT32). Then see if it works. Have you tried everything in the guide?

P.S: Thanks to all others for the support, I will try and answer any questions that you post here.
26th November 2012, 07:51 PM |#15  
Member
Lisbon
Thanks Meter: 6
 
More
I've had some of these problems throughout the years but 90% of the times it was because on my microSD to SD converter (those SD cards that have a microSD slot in it) I didn't put the card very well or it was just one millimeter out. I really hate how these converters don't have that "click and lock" thingy when you put the microSD card, it's really helpful to keep them inside.

Also, this caused corruption sometimes.
14th December 2012, 12:53 PM |#16  
milzaaam's Avatar
Member
Thanks Meter: 4
 
More
Looks like a nice guide buddy
16th December 2012, 09:56 PM |#17  
KingAmir's Avatar
OP Senior Member
Flag London
Thanks Meter: 340
 
More
Quote:
Originally Posted by XThe_GManX

I've had some of these problems throughout the years but 90% of the times it was because on my microSD to SD converter (those SD cards that have a microSD slot in it) I didn't put the card very well or it was just one millimeter out. I really hate how these converters don't have that "click and lock" thingy when you put the microSD card, it's really helpful to keep them inside.

Also, this caused corruption sometimes.

I will look into adding that to the guide when I have a spare moment.

Thanks

Quote:
Originally Posted by milzaaam

Looks like a nice guide buddy

Appreciate that!
24th December 2012, 12:28 AM |#18  
boyheadkick's Avatar
Senior Member
Davao City
Thanks Meter: 1,167
 
More
i bought a 32gb transcend micro sdhc yesterday..went home, placed it in card reader, wrote backup on it, worked fine, i could r/w on it with my laptop..then i placed it in my phone [xperia sola 6.1.1.B.1.54 stock rooted bl locked], booted it and explored it using astro and root explorer, worked fine, i could r/w on it with those apps...the problem is when i open walkman there are no songs/albums detected, so i tried exploring an album and playing it via astro and walkman was able to play the song but just the one song i selected..its also the same with sony album app there are no pictures detected from external card, so i tried viewing a pic the same way i played the song, i was able to view the one pic i selected..there are no errors popping up, which is why its so confusing..i managed to make it work last night by clearing dalvik cache, but when i woke up this morning the problem began again..any advice?

btw on stock camera app i selected external memory as save location, when i open the app it says memory error but when i take a pic it can save there as well, i took a pic and album was able to see the new pic but not the old ones..am i missing something with permissions?i already tried changing the permissions for external memory using root explorer but failed, something about sd file systems not allowing permission changes..i already formatted it countless times to fat32 still the same..it really is working fine, its just that the apps arent able to access it for some reason or another..

update: i just restored my phone with backup from 2days ago and cleared my dalvik cache..its working now..my concern is if i restart my phone im probably gonna go over everything again..this is really weird
14th January 2013, 12:18 PM |#19  
Junior Member
Thanks Meter: 0
 
More
hope I could get it to work with this. thanks man
27th January 2013, 09:53 AM |#20  
amputasi's Avatar
Junior Member
Neverland
Thanks Meter: 6
 
More
Question [Help] my microSD not detected
i just bought sandisk 8gb second-hand from my neioghbour.. its has been format before sold to me.. but i put in my nokia 3120 classic, the microSD not detected.. i already copy about 3gb song and pics (that assumed the microSD detected on my PC). when i told my neighbour and put in his phone, it detected.. and again when i put it back to my phone (that nokia).. agan it not detected..
are the microSD is damaged or my phone who can't read the size of the microSD ??
11th February 2013, 08:58 AM |#21  
boorhanns's Avatar
Junior Member
Flag Makassar
Thanks Meter: 3
 
More
Nice guide maby we need it to stickied.. im will try it
The Following User Says Thank You to boorhanns For This Useful Post: [ View ] Gift boorhanns Ad-Free
Post Reply Subscribe to Thread

Tags
guide

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes