FORUMS
Remove All Ads from XDA

[Recovery] [07-Jan-2011] RA-passion-v2.2.1

1,295 posts
Thanks Meter: 403
 
By Amon_RA, Retired Senior Recognized Developer on 5th January 2010, 12:00 PM
Post Reply Email Thread
13th January 2010, 12:17 AM |#101  
Senior Member
Thanks Meter: 27
 
More
move the recovery.img into the android sdk folder and you should be good

then just type fastboot flash recovery recovery.img

to be more clear, make sure you are in the fastboot usb on the phone just like on the root

type in fastboot devices and make sre you see a serial

JSHFS125321 fastboot something like that

then type
fastboot flash recovery recovery-RA-nexus-v1.5.3.img
 
 
13th January 2010, 12:19 AM |#102  
Quote:
Originally Posted by clandest

move the recovery.img into the android sdk folder and you should be good

then just type fastboot flash recovery recovery.img

to be more clear, make sure you are in the fastboot usb on the phone just like on the root

type in fastboot devices and make sre you see a serial

JSHFS125321 fastboot something like that

then type
fastboot flash recovery recovery-RA-nexus-v1.5.3.img

i was suppose to have the sdk?

ok.... now i need to figure the sdk out lol .... wow im such a noob
13th January 2010, 12:26 AM |#103  
Senior Member
Thanks Meter: 27
 
More
Quote:
Originally Posted by pr0cl1v1ty

i was suppose to have the sdk?

ok.... now i need to figure the sdk out lol .... wow im such a noob

look for a tutorial on youtube or something on how to install android adb that will tell you how to get where you need to be

then you just have to run those line of codes.
13th January 2010, 12:28 AM |#104  
Quote:
Originally Posted by clandest

look for a tutorial on youtube or something on how to install android adb that will tell you how to get where you need to be

then you just have to run those line of codes.

thank you very much im installing archives from the sdk now
13th January 2010, 12:38 AM |#105  
Senior Member
Thanks Meter: 27
 
More
might want to check out this sticky if you are using windows

http://forum.xda-developers.com/showthread.php?t=613217
13th January 2010, 12:43 AM |#106  
Quote:
Originally Posted by clandest

might want to check out this sticky if you are using windows

http://forum.xda-developers.com/showthread.php?t=613217

i did that but theres no instructions as to get adb to work

EDIT : i got adb on my pc now, AND I GOT IT!!! THANKS
13th January 2010, 03:34 PM |#107  
Junior Member
Thanks Meter: 1
 
More
Rapidshare link is corrupted
thanks for the cool recovery. Just wanted to bring to your notice that the Rapidshare link appears to be corrupted.
13th January 2010, 11:41 PM |#108  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by vishalashah

thanks for the cool recovery. Just wanted to bring to your notice that the Rapidshare link appears to be corrupted.

Yeah, the AndroidSPIN link is great though (mirror link). I think Amon better make that as default link
14th January 2010, 02:43 AM |#109  
Junior Member
Thanks Meter: 0
 
More
recovery doesn't boot
I've had no problem running the commands to get this set up. But the recovery doesn't boot.

Did:

Code:
D:\android-sdk-windows-1.6_r1\tools>fastboot.exe flash recovery recovery-RA-nexus-v1.5.3.img
sending 'recovery' (3550 KB)... OKAY
writing 'recovery'... OKAY
Then power off and boot to flashboot again. Pick bootloader, recovery. See the quad-color nexus X and lock icon, then after just a moment, the android mascot with an exclamation point in a triangle. At this point I can't do anything besides pull the battery.

I've checked the md5 of my .img and it's right. I don't know how to get a recovery.log to post.
14th January 2010, 05:01 AM |#110  
shata's Avatar
Senior Member
Flag Virginia Beach, VA
Thanks Meter: 2
 
More
Great work, cant wait to get nexus one (sigh...sense its so expensive)
14th January 2010, 05:07 AM |#111  
mixmaven's Avatar
Senior Member
Thanks Meter: 6
 
More
I am guessing your phone is rooted? I don't have an answer other than I would suggest you make sure you are using the latest version of fastboot.
-mix

Quote:
Originally Posted by arantius

I've had no problem running the commands to get this set up. But the recovery doesn't boot.

Did:

Code:
D:\android-sdk-windows-1.6_r1\tools>fastboot.exe flash recovery recovery-RA-nexus-v1.5.3.img
sending 'recovery' (3550 KB)... OKAY
writing 'recovery'... OKAY
Then power off and boot to flashboot again. Pick bootloader, recovery. See the quad-color nexus X and lock icon, then after just a moment, the android mascot with an exclamation point in a triangle. At this point I can't do anything besides pull the battery.

I've checked the md5 of my .img and it's right. I don't know how to get a recovery.log to post.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes