Remove All Ads from XDA
Win Honor 9 Lite

[Tool]SP FlashTool ||MTK Android FLASHER

65 posts
Thanks Meter: 422
By DR_MOOSAVI, Member on 9th November 2012, 08:15 PM
Post Reply Email Thread
3rd November 2016, 07:16 AM |#101  
Junior Member
Flag Lagos
Thanks Meter: 5
Originally Posted by shweeney

My phone (Freelander i30/Newman K1 MTK6589-based) failed to boot up displaying an "encryption unsuccessful" error last week.

I had CWM on it and was still able to get into that so tried flashing a ROM from needrom but it still wouldn't boot and from within CWM it appeared that /data wouldn't mount - I tried formatting all the partitions and loading a nandroid backup from a few months ago but still the encryption error. Tried to access /data from ADB also without success

so I moved on to trying the MTK SP flash tool with an appropriate factory ROM. The flash tool can see the phone but when I try to flash the ROM I get the error brom error: s_da_sdmmc_write failed (3149) Tried formatting the flash to no avail. the memory test gives the same brom error eventually.

Somewhere along the line I seem to have also messed up the boot sector as the phone no longer boots at all or shows the charging symbol - the flash tool can still see it, but I can't get into CWM or use ADB any more.

so - is the flash memory on the phone completely gone or is there another way to get it back?

You can use a Miracle Box ROM dump to recover your phone.

---------- Post added at 06:08 AM ---------- Previous post was at 05:56 AM ----------

Originally Posted by rapidsebuja

I hawe problem with SP Flashtool...
I will flash custom recovery to my MyPhone Cube 16GB.
In Flash program by flashing an error pops up : (1012) Not Enoug Memory..
sory for my english

You need to download another ROM from another source. The error occurs as a result of incompatibility between your phone's stock ROM and the stock ROM you are flashing with. See here: for detailed info and other possibles errors that may pop.

---------- Post added at 06:16 AM ---------- Previous post was at 06:08 AM ----------

Originally Posted by said4

I have Y330-u01 bricked and cant flash with sp tool
it gives error 2004
Please help

SP Flash Error Message: BROM ERROR : S_FT_DOWNLOAD_FAIL (2004)
Error Code Message: The communication between SP Flash and the device was interrupted.

1. Try another USB Cord.
2. Lunch SP Flash as admin.
3. Try another PC.
4. Check that the battery in the device is charged.

Other sggestions here: I'm sorry but I can't post links now but if you can make out something with that.
29th March 2017, 04:51 PM |#102  
Junior Member
Thanks Meter: 0
Hello,i have micromax canvas a1 mtk6582,in memory test it says nand flash was not detected,ufs not detected.Any help..?
8th March 2018, 05:01 PM |#103  
rodolfoalv89's Avatar
Junior Member
Thanks Meter: 1
Originally Posted by klingklang01

just like to know as I always use MTK_AllInOne_DA.bin but what are the purpose of the other bin bin files:



I have seen using DA_SWSEC.bin for flashing locked bootloader phones
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes