FORUMS
Remove All Ads from XDA

[Android 2.1+][03.10.2011][v3.2] Chainfire3D [ROOT][OpenGL ES 2.0+]

11,225 posts
Thanks Meter: 86,778
 
By Chainfire, Senior Moderator / Senior Recognized Developer - Where is my shirt? on 19th May 2011, 08:50 PM
Post Reply Email Thread
13th June 2014, 02:33 PM |#2581  
bigsupersquid's Avatar
Senior Member
Flag BFE, MO
Thanks Meter: 1,656
 
Donate to Me
More
Quote:
Originally Posted by Chainfire

...
By now I've given up on that approach as well, but I have since devised a new one, that might make CF3D properly possible again (at least 4.2+, maybe even 4.4+). However, now GLTools has just shown up and is slowly taking over the market, so I'm not sure I should even bother, as I personally have no use for CF3D outside of CF.lumen, so I'd be building it mostly for props and profit, neither of which really drive me.
...

I totally understand the lack of time.
I suspect that, unlike Qualcomm and etc, you might consider opening the source code if you do decide it's obsolete? I personally would really enjoy seeing just how you intercept the GL calls even if it is dangerous to the operating system. Have a 3d stereo device I'd like to change some stuff up on.

Tried the free version on my msm7627 with 4.4.3, the problem hits just after the library is loaded
Quote:

W/SurfaceFlinger( 116): getting VSYNC period from fb HAL: 16666666
E/Adreno200-EGL( 116): <qeglDrvAPI_eglChooseConfig:757>: EGL_BAD_ATTRIBUTE
E/Adreno200-EGL( 116): <qeglDrvAPI_eglChooseConfig:757>: EGL_BAD_ATTRIBUTE
W/SurfaceFlinger( 116): no suitable EGLConfig found, trying a simpler query
I/SurfaceFlinger( 116): EGL informations:
I/SurfaceFlinger( 116): vendor : Android
I/SurfaceFlinger( 116): version : 1.4 Android META-EGL
I/SurfaceFlinger( 116): extensions: EGL_KHR_get_all_proc_addresses EGL_ANDROID_presentation_time EGL_KHR_image EGL_KHR_image_base EGL_KHR_lock_surface EGL_KHR_fence_sync EGL_ANDROID_image_native_buffer EGL_ANDROID_recordable
I/SurfaceFlinger( 116): Client API: OpenGL_ES
I/SurfaceFlinger( 116): EGLSurface: 5-6-5-0, config=0x1
I/SurfaceFlinger( 116): OpenGL ES informations:
I/SurfaceFlinger( 116): vendor : Qualcomm
I/SurfaceFlinger( 116): renderer : Adreno (TM) 200 / Chainfire3D
I/SurfaceFlinger( 116): version : OpenGL ES 2.0 2131267
I/SurfaceFlinger( 116): extensions: GL_EXT_CHAINFIRE3D GL_IMG_texture_format_BGRA8888 GL_OES_mapbuffer GL_EXT_debug_marker GL_AMD_compressed_ATC_texture GL_AMD_performance_monitor GL_AMD_program_binary_Z400 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_type_2_10_10_10_REV GL_NV_fence GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth_texture GL_OES_depth24 GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_element_index_uint GL_OES_fbo_render_mipmap GL_OES_fragment_precision_high GL_OES_get_program_binary GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_3D GL_OES_texture_float GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_half_float GL_OES_vertex_type_10_10_10_2 GL_OES_vertex_array_object GL_QCOM_alpha_test GL_QCOM_binning_control GL_QCOM_driver_control GL_QCOM_perfmon_global_mode GL_QCOM_extended_get GL_QCOM_extended_get2 GL_QCOM_tiled_rendering GL_QCOM_writeonly_rendering GL_AMD_compressed_3DC_texture
I/SurfaceFlinger( 116): GL_MAX_TEXTURE_SIZE = 4096
I/SurfaceFlinger( 116): GL_MAX_VIEWPORT_DIMS = 4096
E/cutils-trace( 116): Error opening trace file: No such file or directory (2)
W/SurfaceFlinger( 116): power module not found
W/SurfaceFlinger( 116): power module not found
D/SurfaceFlinger( 116): Screen acquired, type=0 flinger=0x3d5450
I/Netd ( 176): Netd 1.0 starting
I/Netd ( 195): Netd 1.0 starting
I/Netd ( 210): Netd 1.0 starting
I/Netd ( 222): Netd 1.0 starting
I/Netd ( 237): Netd 1.0 starting
I/Netd ( 253): Netd 1.0 starting
I/Netd ( 265): Netd 1.0 starting
I/Netd ( 278): Netd 1.0 starting

and there it loops. Blank screen no bootanimation. But it loads ok up to there.
Nothing odd in dmesg at all.
I'm not expecting this log to matter, since you're short on time and motivation to extend this app right now, but had it ready to paste before looking in the thread. Figured I might as well post it.
As far as the money, I and others would contribute some. I'm cheap, but if you get tons of cheap people together and a few real contributors, it might be worth your time.
The Following 3 Users Say Thank You to bigsupersquid For This Useful Post: [ View ] Gift bigsupersquid Ad-Free
 
 
23rd July 2014, 11:26 PM |#2582  
Senior Member
Thanks Meter: 13
 
More
S i too face bootloop in micromax canvas 4 A210 ...

Sent from my A210 using XDA Free mobile app
25th July 2014, 02:00 PM |#2583  
ramrastus's Avatar
Senior Member
Flag Madurai
Thanks Meter: 145
 
More
Quote:
Originally Posted by vickys1038

S i too face bootloop in micromax canvas 4 A210 ...

Sent from my A210 using XDA Free mobile app

CF3D not for mediatek device (MTK).
if yo flash cf3D n mtk device.. defnty yo ll get bootloop..
so, yo guys.. go wid GLTools (Graphics Optimizer)

Download GLTools from here->
http://forum.xda-developers.com/show....php?t=2615514


Sent from my A110 using Tapatalk
The Following User Says Thank You to ramrastus For This Useful Post: [ View ] Gift ramrastus Ad-Free
26th October 2014, 05:57 AM |#2584  
Senior Member
Thanks Meter: 101
 
More
U faced it becoz this app is not compatible with JB
I think a210 has JB

Sent from my Micromax_A101 using XDA Free mobile app
24th January 2015, 07:00 PM |#2585  
Member
Thanks Meter: 28
 
More
Sorry for opening this thread, but... Why can not I find Chainfire3D in google Play? Neither in the pub from chainfire in Google Play.

I have tried to download from Goolge play in my desktop to my mobile, but it never goes on with the installation. i have an old SG Mini Pop Plus (GT-5570i) and I would like to try it.

Yes, I have tested GLTools yet, so that is not what I am looking for. Thanks
22nd July 2015, 10:16 PM |#2586  
darkdoll69's Avatar
Member
Flag Nagaon, Assam
Thanks Meter: 1
 
More
can i use this app on sony xperia z lolipop 5.0.2 rooted.. i am new on all this.

thank you!!!
23rd July 2015, 05:33 AM |#2587  
Senior Member
Flag Aachen
Thanks Meter: 43
 
More
NO! Pls don't even try it
this ONLY works on Android Gingerbread (Android 2)
it has never been coded to work with versions above

sorry for the harsh tone I just want to save you from getting boot loops on your device
The Following User Says Thank You to Dj_Fex For This Useful Post: [ View ] Gift Dj_Fex Ad-Free
5th May 2016, 06:32 PM |#2588  
BatDroid's Avatar
Senior Member
Look! On the rooftop!
Thanks Meter: 445
 
Donate to Me
More
A request...
@Chainfire

1st of all, Hats off to u for your great works on xda.
U have given us too many things.
Actually, I'm a big fan of u.
Can u please add kk or kk support??
Well..
I'm not saying that u have to do it for us.
U know...
Only if u have time..

Btw,Gltools can't do what cf3d did on my old phones.
The Following User Says Thank You to BatDroid For This Useful Post: [ View ] Gift BatDroid Ad-Free
14th November 2016, 04:24 AM |#2589  
Junior Member
Thanks Meter: 0
 
More
app removed
app is no longer in store
14th November 2016, 12:20 PM |#2590  
rignfool's Avatar
Senior Member
Flag The Poconos
Thanks Meter: 2,584
 
More
Quote:
Originally Posted by BSroot

app is no longer in store

It is... Its just not listed...

I bought it in 2012... And I can find the listing in settings under what I bought
The Following User Says Thank You to rignfool For This Useful Post: [ View ] Gift rignfool Ad-Free
Post Reply Subscribe to Thread

Tags
chainfire3d

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes