FORUMS
Remove All Ads from XDA

Completely hide the virtual keys in A70

68 posts
Thanks Meter: 13
 
By akmalhisyam, Member on 25th June 2011, 12:45 AM
Post Reply Email Thread
25th June 2011, 11:23 AM |#11  
akmalhisyam's Avatar
OP Member
Thanks Meter: 13
 
More
during Urukdroid installation, there is an option to copy all apps from old firmware to Urukdroid..
but it is not recommended by sauron..
The installation guide can be found @ Urukdroid wiki - http://code.google.com/p/urukdroid/w...ation#Step_one
 
 
25th June 2011, 11:32 AM |#12  
Senior Member
Thanks Meter: 813
 
More
I think, I will stay with the stock firmware.

But it would be great, if other people with stock firmware would test that, too.
25th June 2011, 12:27 PM |#13  
glimmling's Avatar
Senior Member
Thanks Meter: 109
 
More
Hi. It works with chulri's ROOT. I'm on firmware 2.3.26. First it won't work with just renaming the folder. Then I moved the folder to / but it is also still there in /system. I deleted the board_properties - folder in /system, renamed the copy in / to board_properties.bak and moved this one back to /system as a backup. After a reboot the buttons were gone. Hope this helps.

Edit: After every reboot the Archos-Widget App crashes. I think, it is looking for files in the board_properties folder and can't find them. I freezed this app with titanium-backup and now everything seems fine. Maybe it needs only to disable the archos-widget app without the need to rename the folder to get rid of the buttons.
The Following 2 Users Say Thank You to glimmling For This Useful Post: [ View ] Gift glimmling Ad-Free
25th June 2011, 12:36 PM |#14  
akmalhisyam's Avatar
OP Member
Thanks Meter: 13
 
More
Quote:
Originally Posted by glimmling

Hi. It works with chulri's ROOT. I'm on firmware 2.3.26. First it won't work with just renaming the folder. Then I moved the folder to / but it is also still there in /system. I deleted the board_properties - folder in /system, renamed the copy in / to board_properties.bak and moved this one back to /system as a backup. After a reboot the buttons were gone. Hope this helps.

nice..
glad to hear that its working
25th June 2011, 01:28 PM |#15  
Senior Member
Thanks Meter: 813
 
More
Quote:
Originally Posted by glimmling

Hi. It works with chulri's ROOT. I'm on firmware 2.3.26. First it won't work with just renaming the folder. Then I moved the folder to / but it is also still there in /system. I deleted the board_properties - folder in /system, renamed the copy in / to board_properties.bak and moved this one back to /system as a backup. After a reboot the buttons were gone. Hope this helps.

I tested the same, but it doesn't work.

I will reinstall the SDE and the kernel and will test it again.
25th June 2011, 03:11 PM |#16  
Senior Member
Thanks Meter: 813
 
More
I reformatted my Archos 70, put the SDE on it, but it still doesn't work.

Maybe it's because of the firmware 2.1.08?
25th June 2011, 06:02 PM |#17  
glimmling's Avatar
Senior Member
Thanks Meter: 109
 
More
Hey. Just recognized, that some games will work now without the softbuttons on my a70. Cut the rope and MonkeyBlast didn't run before the modification and now they do.

Sent from my A70S using Tapatalk
27th June 2011, 03:47 AM |#18  
Senior Member
Thanks Meter: 178
 
More
Anyone with Chulri's R/W root, try this:

Go into the board_properties folder, find the file that relates to your model(mine is an A101, so my file was virtualkeys.A101IT), and rename it(add .old to the end of it), and reboot. If that doesn't work, try opening the file as text and delete all the text in it, then save as the original filename(not with the .old extension). Also, make sure you haven't turned off the Soft Buttons through UrukConfig or manual edits. You have to reenable the softkeys(remove them from notification bar) to make them disappear completely with this method.
The Following User Says Thank You to msticninja For This Useful Post: [ View ] Gift msticninja Ad-Free
27th June 2011, 04:32 AM |#19  
Senior Member
Thanks Meter: 356
 
Donate to Me
More
Another option is to hide them mostly--edit the right board_properties file and set their width to something really small, like 10 pixels. Then they remain usable (though the label will be cut-off), but they take up very little screen space.
27th June 2011, 05:59 PM |#20  
bigfau's Avatar
Inactive Recognized Developer
Flag Zanesville, Ohio
Thanks Meter: 10,790
 
Donate to Me
More
Worked for me on Archos 101 Churli's R/W Root
I have the 101 with Chulri's R/W root. All I did was move the board_properties to my sd card and rebooted. Abracadabra, their gone. Renamed to board_properties.bak and put back into the system folder. Rebooted again just to make sure it stuck and it did, no soft buttons.
28th June 2011, 12:55 AM |#21  
Senior Member
Thanks Meter: 356
 
Donate to Me
More
Quote:
Originally Posted by arpruss

Another option is to hide them mostly--edit the right board_properties file and set their width to something really small, like 10 pixels. Then they remain usable (though the label will be cut-off), but they take up very little screen space.

Here's what a thinned down button bar looks like on my A43:


To generate this, just do a search and replace on virtualkeys.A43, replacing 800:480:54 with 827:480:27 in the whole file. (Make sure you save a copy as a backup.)

This might give a nice compromise between usability and not cutting off apps too much. Or for a much moral radical thinning, one can do 840:480:14, but that'll only be usable with a stylus or fingernail.

You can also add other keys with other functionalities, but unfortunately they don't get labeled.
Post Reply Subscribe to Thread

Tags
archos 70, virtual keys

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes