FORUMS
Remove All Ads from XDA

[GUIDE] Moto G - Restore stock firmware

262 posts
Thanks Meter: 517
 
By t-bon3, Senior Member on 25th November 2013, 10:36 AM
Post Reply Email Thread
23rd August 2014, 04:16 PM |#1001  
Member
Thanks Meter: 1
 
More
I tried with a the previous version of CWM and it works, for some reason. Just happy that the phone now works.
 
 
24th August 2014, 02:43 AM |#1002  
Senior Member
Thanks Meter: 109
 
More
So guys, has any way to downgrade from XT1034 version 4.4.3 KitKat to 4.3 Jellybean been found yet?
I regret upgrading..
25th August 2014, 01:15 AM |#1003  
XUTOS-83's Avatar
Member
Flag Lisboa
Thanks Meter: 20
 
More
I want to try stock Motorola again, any real difference from Retail-UE, Retail-GB, Retail-DE , etc... If I flash Retail-US I will probably get OTA releases sooner, any disadvantage for an EU use? Signal frequencies for ex.
25th August 2014, 11:48 AM |#1004  
remo0073's Avatar
Senior Member
Flag ITALY
Thanks Meter: 189
 
More
Quote:
Originally Posted by XUTOS-83

I want to try stock Motorola again, any real difference from Retail-UE, Retail-GB, Retail-DE , etc... If I flash Retail-US I will probably get OTA releases sooner, any disadvantage for an EU use? Signal frequencies for ex.

Android 4.4.4 European firmwares are the same (EU, GB, FR, DE)

I prefer EU Firmware, but it's always the last to be updated (for this reason it should be the most stable)
DE firmware is the first in Europe to be Updated

US firmware is normally updated before than European firmware, but at the momenti it is stopped at Android 4.4.3.
It din't received 4.4.4 yet.
Anyway 4.4.3 and 4.4.4 are very similar (minor updates)

There are some differencies in the SystemUI between US vs European Firmwares (only 3G icon with arrows but not H and H+ icons)

Not disavantages for EU users in US firmware
It is a Global GSM firmware (as the Europen ones)
The Following User Says Thank You to remo0073 For This Useful Post: [ View ] Gift remo0073 Ad-Free
25th August 2014, 10:47 PM |#1005  
cky2000's Avatar
Senior Member
West Palm Beach
Thanks Meter: 120
 
More
Sorry for the newbie question. I just bought an XT1032 umts for a friend in Argentina and she is using Personal Argentina. The XT1032 has 173.44.9.falcon_umts.AIO.en.US (4.4.2) on it. Should I restore it to Android 4.4.2
Blur_Version.173.44.9.falcon_umts.Personal.en.AR or 4.4.3 AR Personal version. Or will it update when she puts in the sim card when she gets home. Thank you for any info.
25th August 2014, 11:02 PM |#1006  
angelgzg's Avatar
Senior Member
Flag Maracay
Thanks Meter: 32
 
More
Good my phone has suddenly been hung and when forced reboot is then left in the logo of motorola and it's not from there, I tried to make this tutorial and "appears" that does everything well but then when rebooting just does not start as usual

When trying to enter the recovery says "boot up failed" and tried to install a custom recovery and I get the same
25th August 2014, 11:20 PM |#1007  
vinciwin's Avatar
Junior Member
Flag Liège
Thanks Meter: 9
 
More
I had to restore my XT1039 to stock using this tutorial and i was stuck at boot logo

Actually I had forgotten to flash one of the system part and it took me more time than it should have to notice.

Sent from my XT1039 using XDA Free mobile app
26th August 2014, 05:40 AM |#1008  
Member
Thanks Meter: 0
 
More
@matmutant I have tx1031 boost moto g flashed to Page plus if restore to stock boost and end my services with pp will it work with boost again ?
26th August 2014, 10:59 PM |#1009  
Junior Member
Thanks Meter: 0
 
More
Hello everyone,

I have been trying to restore my moto g to the firmware 4.4.2 from the 4.4.4.

I have followed every step in the guide but i have encountered a problem with the mfastboot.exe. Every time I start the application it pops this error, " the program can't start because AbdWinApi.dll is missing from your computer. Try reinstalling the program to fix the problem".

Any ideas what might be causing this?
27th August 2014, 12:25 AM |#1010  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by fabian_min

Hello everyone,

I have been trying to restore my moto g to the firmware 4.4.2 from the 4.4.4.

I have followed every step in the guide but i have encountered a problem with the mfastboot.exe. Every time I start the application it pops this error, " the program can't start because AbdWinApi.dll is missing from your computer. Try reinstalling the program to fix the problem".

Any ideas what might be causing this?

You need this .dll and another one in the same folder that mfastboot.exe is. If you installed Minimal ADB and Fastboot, those files are there, in the same folder you installed it.
27th August 2014, 12:48 AM |#1011  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Adonai Candido

You need this .dll and another one in the same folder that mfastboot.exe is. If you installed Minimal ADB and Fastboot, those files are there, in the same folder you installed it.

thanks man! It worked but... Im using the .xml.zip. firmware and when I try to run the mfastboot boot boot.img It fails and I get this message.



Desktop\CFC-fastboot_falcon_verizon_user_4.4.2_KXB20.9-1.10-1.
20_22_release-keys.xml>mfastboot flash logo logo.bin
target max-sparse-size: 256MB
sending 'logo' (619 KB)...
OKAY [ 0.109s]
writing 'logo'...
OKAY [ 0.078s]
finished. total time: 0.203s

Desktop\CFC-fastboot_falcon_verizon_user_4.4.2_KXB20.9-1.10-1.
20_22_release-keys.xml>mfastboot flash boot boot.img
target max-sparse-size: 256MB
sending 'boot' (10240 KB)...
OKAY [ 0.406s]
writing 'boot'...
(bootloader) Preflash validation failed
FAILED (remote failure)
finished. total time: 0.906s

Desktop\CFC-fastboot_falcon_verizon_user_4.4.2_KXB20.9-1.10-1.
20_22_release-keys.xml>
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes