FORUMS
Remove All Ads from XDA

[APP] Official ViPER4Android Audio Effects (FX v2.5.0.5) - New Features & 7.0 Support

4,103 posts
Thanks Meter: 14,209
 
By zhuhang, Recognized Contributor on 15th March 2013, 04:42 AM
Post Reply Email Thread
27th April 2013, 04:37 PM |#1001  
Kitschki's Avatar
Senior Member
Flag Seoul
Thanks Meter: 50
 
More
Quote:
Originally Posted by zhuhang

When u switch to compatible mode, high chance you cant hear anything, afer reboot should be ok.
If after reboot still the same, try safe mode (with compatible mode active)

Well my problem was that fx wasnt processing, i could actually hear something ^^

Sent from my SHW-M250K using xda app-developers app
 
 
27th April 2013, 04:45 PM |#1002  
zhuhang's Avatar
OP Recognized Contributor
Flag Petaling Jaya
Thanks Meter: 14,209
 
Donate to Me
More
Quote:
Originally Posted by Kitschki

Well my problem was that fx wasnt processing, i could actually hear something ^^

Sent from my SHW-M250K using xda app-developers app

The driver status has some bugs, if its working then no problem.
The Following User Says Thank You to zhuhang For This Useful Post: [ View ] Gift zhuhang Ad-Free
27th April 2013, 11:40 PM |#1003  
rabi347's Avatar
Senior Member
Thanks Meter: 62
 
More
I am on stock ROM (HTC One x for At&t), i installed the app but initially it did not work. I then went to build.prop and there is a line which says "lpa.decode = true". I changed that to "false" and then it worked.


Sent from my HTC One XL
The Following User Says Thank You to rabi347 For This Useful Post: [ View ] Gift rabi347 Ad-Free
28th April 2013, 02:20 AM |#1004  
zhuhang's Avatar
OP Recognized Contributor
Flag Petaling Jaya
Thanks Meter: 14,209
 
Donate to Me
More
Quote:
Originally Posted by rabi347

I am on stock ROM (HTC One x for At&t), i installed the app but initially it did not work. I then went to build.prop and there is a line which says "lpa.decode = true". I changed that to "false" and then it worked.


Sent from my HTC One XL

what is the function of that line?
28th April 2013, 02:33 AM |#1005  
PaulG1488's Avatar
Senior Member
Thanks Meter: 321
 
More
Quote:
Originally Posted by rabi347

I am on stock ROM (HTC One x for At&t), i installed the app but initially it did not work. I then went to build.prop and there is a line which says "lpa.decode = true". I changed that to "false" and then it worked.


Sent from my HTC One XL

Props that got the stock samsung music player to work for me

Should've thought of that before I remember having to do this on some aosp roms.
28th April 2013, 03:04 AM |#1006  
rabi347's Avatar
Senior Member
Thanks Meter: 62
 
More
I am no dev, so I am not sure of the function, but before I tried this, I used "kingbeatz" at the HTC one xl forum, and the instruction said to modify that line on build prop. So when I did a clean install of stock ROM, at first this mod did not work, but after modifying that line and rebooted the phone it started working. This happened multiple times already. So I don't know whether this is coincidence or not.

Sent from my HTC One XL
The Following User Says Thank You to rabi347 For This Useful Post: [ View ] Gift rabi347 Ad-Free
28th April 2013, 03:06 AM |#1007  
zhuhang's Avatar
OP Recognized Contributor
Flag Petaling Jaya
Thanks Meter: 14,209
 
Donate to Me
More
Quote:
Originally Posted by rabi347

I am no dev, so I am not sure of the function, but before I tried this, I used "kingbeatz" at the HTC one xl forum, and the instruction said to modify that line on build prop. So when I did a clean install of stock ROM, at first this mod did not work, but after modifying that line and rebooted the phone it started working. This happened multiple times already. So I don't know whether this is coincidence or not.

Sent from my HTC One XL

Thanks for this info, we will discuss about it and decide whether its necessary or not.
28th April 2013, 03:15 AM |#1008  
Member
Thanks Meter: 24
 
More
Working great on my SE LWW running cm10, FX and xHiFi coexist installation, using the recommended setting, and then tweak it a bit, and the sound is superb!
The only problem is just when convolver is activated, the music is kinda delayed, so I have to turn it off when I play music rhytim game, because I can't get a high score If the music is late.
The rest is wotking great
Thanks zhuhang and viper
28th April 2013, 04:31 AM |#1009  
Senior Member
Flag Chennai
Thanks Meter: 28
 
Donate to Me
More
Post
Quote:
Originally Posted by zhuhang

what is the function of that line?

Most of the the boards on android devices have two modes to play audio :
1 low power audio (lpa) mode - Consumes less power but the audio quality may be affected.
2 high performance audio (hpa) mode - Good for applications in which high quality of audio is desired.

lpa.decode=false means low power audio is turned off by default and only high performance audio is working.
The Following User Says Thank You to ghost_razr For This Useful Post: [ View ] Gift ghost_razr Ad-Free
28th April 2013, 05:48 AM |#1010  
Member
Thanks Meter: 6
 
More
somene know if this last version is compatible with Ac!d audio ? i tried that mix with the version before this one and it didnt work.
28th April 2013, 06:06 AM |#1011  
PaulG1488's Avatar
Senior Member
Thanks Meter: 321
 
More
Quote:
Originally Posted by Abufom

somene know if this last version is compatible with Ac!d audio ? i tried that mix with the version before this one and it didnt work.

Get rid of acid this is way better.
The Following User Says Thank You to PaulG1488 For This Useful Post: [ View ] Gift PaulG1488 Ad-Free
Post Reply Subscribe to Thread

Tags
best settings, convolver, cure tech+, fx xhifi, irs impulse response sample, settings, viper4android v4a, virtual headphone surround engine+

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools
Display Modes