FORUMS
Remove All Ads from XDA

[Kernel] Flykernel-13 "Back from the Grave"

1,437 posts
Thanks Meter: 459
 
By erasmux, Retired Recognized Developer on 20th July 2010, 12:29 PM
Post Reply Email Thread
6th October 2010, 04:48 AM |#501  
Senior Member
Thanks Meter: 40
 
More
Quote:
Originally Posted by lukesky

it seems to me that when the phone wakes up, it doesn't scale fast enough to the wake up freq that's why the phone appears to hang and it's only after an indefinite period of button mashing, does the phone wake up normally and present the lock screen.

Maybe I should test my theory, like using SetCPU to set a higher max freq for the screen off profile, like a screenoff profile of MinMax, 480mhz/176mhz and see what happens...

Ok after 2 hrs of testing based on the Info tab of SetCPU, it seems to me that whatever profile I set for ScreenOff profile, the phone remains 99.9% of the time at the max freq that you set for that profile. So if I set the ScreenOff profile to 480/176, MinMax, leave the phone on standby for 10 mins, the Info tab on SetCPU shows me that it hardly even touches 176Mhz at all and spends most, if not all of it's time at 480mhz. Same goes to if I set it to 352/176mhz or 352/245mhz, it always stays at 352mhz when the screen is off.

I also tried not setting a ScreenOff profile at all just to test the default smartass governor. So I disabled SetCPU by unchecking the 'Set at Boot' option and the checkboxes in the Profiles tab and rebooted the phone. Looking at the Info tab, I realised it's a lot harder to see whether the phone remains at 176 or 352mhz when the screen is off because both numbers keep jumping when the screen is on, due to the smartass governor also using both 176 and 352mhz when the screen is on.

So in SetCPU, I forced the min freq to 480mhz and left the max freq at 614mhz, governor was smartass and I checked the 'Set at Boot' box. I didn't set a ScreenOff profile, so I'm guessing that when the screen is off, it will be the default smartass governor doing it's thing. I rebooted the phone and left it there for 10 mins. After 10 mins, I checked the Info tab and it showed me that the phone was in 480mhz, which is the expected behaviour of smartass, but the funny thing is that it never went down to 176mhz at all during this 10 mins. I'm pretty sure if i left it long enough like maybe a couple of hours, it will scale down and i will get wake up issues cos that's what happened previously before I installed SetCPU and forced ScreenOff profile to 352/352.

Of course with such short testing, nothing is conclusive but it does give me an impression that most of the time the phone is not fully sleeping, there must be something that's running in the background that doesn't allow the CPU to scale down to the min freq when the screen is off, regardless of what governor u set for ScreenOff. I even tried Conservative and that didn't force the CPU to go down to the min freq during ScreenOff either.

And those rare times that the phone does sleep at 100%, then what you set as the min freq will come into play, i.e. in my case if i set it to anything lower than 352mhz, the phone will have problems waking up occasionally. So if this theory is right, I could set it to 352/19mhz even and i won't have problems most of the time since my phone would rarely scale down to 19mhz , but if it did, i'm sure no amount of button mashing would wake it up without a batt pull.

So the next question is how the stock rom could sleep at 245mhz using perflock and yet not have any problems waking up. I'm not familiar with perflock but could we set it for a ScreenOff profile and yet use smartass or whatever governor we choose when the screen is on? After all, I'd rather lock the ScreenOff profile to 245mhz since it's more batt saving than running at 352mhz 99% of the time when the screen is off.
 
 
6th October 2010, 11:30 AM |#502  
erasmux's Avatar
OP Retired Recognized Developer
Thanks Meter: 459
 
Donate to Me
More
Quote:
Originally Posted by lukesky

Ok after 2 hrs of testing based on the Info tab of SetCPU, it seems to me that whatever profile I set for ScreenOff profile, the phone remains 99.9% of the time at the max freq that you set for that profile. So if I set the ScreenOff profile to 480/176, MinMax, leave the phone on standby for 10 mins, the Info tab on SetCPU shows me that it hardly even touches 176Mhz at all and spends most, if not all of it's time at 480mhz. Same goes to if I set it to 352/176mhz or 352/245mhz, it always stays at 352mhz when the screen is off.
....

First if we are going to dive into this level, please note that phone can be with the screen off (what we usually call "sleeping") but it can also be totally suspended - lets call this "deep sleep". When it is deep sleeping the counters will not change at all (as the CPU is suspended). You can avoid the deep sleep by connecting it to the USB (connecting to a computer works for sure, not sure about charger).

Your "actual" results do not make much sense to me:
a) My phone does spend, say around ~80% of its cycles @ 176Mhz (according to the SetCPU counters).
b) According to what your are saying with a sleep profile @ 352/176 (or smartass with no sleep profile) it spends 99.9% of time @ 352. But @ 352 you do not have wake up issues and @ 352/176 you do?! Ironically if you did have something working all the time in the background I would expect it to solve all wakeup issues....

My only guess is you didn't give it enough time to stabilize. In order to avoid the deep sleep connect it to the computer USB. Reboot phone (to reset counters). Let it sleep for at least 30 minutes then check the counters. What are the results of this test with flykernel-11 and setcpu inactive (meaning leaving it with the default smartass xxx/176 setting)?
6th October 2010, 01:10 PM |#503  
ziggy1001's Avatar
Senior Member
London
Thanks Meter: 971
 
More
Interesting reading i have used this new kernel with Elelinux, Floyo, and CM nightlies and in every case with various settings ie no settings, SetCPU used to set max screen on speed only and with a screen off profile in every case the info stats report a lot of time spent @ 176 which is great
So maybe the above is not typical behaviour
6th October 2010, 02:13 PM |#504  
Senior Member
Thanks Meter: 40
 
More
Quote:
Originally Posted by erasmux

First if we are going to dive into this level, please note that phone can be with the screen off (what we usually call "sleeping") but it can also be totally suspended - lets call this "deep sleep". When it is deep sleeping the counters will not change at all (as the CPU is suspended). You can avoid the deep sleep by connecting it to the USB (connecting to a computer works for sure, not sure about charger).

If deep sleep really causes the counters not to change then it's a bit hard to know when the phone is in real deep sleep, especially if deep sleep is the one causing problems at a freq lower than 352mhz.
Quote:
Originally Posted by erasmux


Your "actual" results do not make much sense to me:
a) My phone does spend, say around ~80% of its cycles @ 176Mhz (according to the SetCPU counters).

Could the reason behind this 80% be due to the fact that in the absence of SetCPU interfering with anything, the smartass kernel would spend quite a substantial amount of time at 176mhz during Screen On? What my testing was doing is to find out the amount of time spent at 176mhz during Screen Off, which I found was very little time if any.

Quote:
Originally Posted by erasmux

b) According to what your are saying with a sleep profile @ 352/176 (or smartass with no sleep profile) it spends 99.9% of time @ 352. But @ 352 you do not have wake up issues and @ 352/176 you do?! Ironically if you did have something working all the time in the background I would expect it to solve all wakeup issues....

That's what I thought too, but what if that whatever service that was running in the background 99% of the time got killed by Android's task killer after awhile, or maybe it just stopped by itself after a long period of inactivity? Who knows? I'm just taking a stab in the dark... I'm not a developer so I don't know enough of how Android works so I'm just throwing theories around based on whatever I've learnt in these forums and by my own little 'experiments'.

Quote:
Originally Posted by erasmux

My only guess is you didn't give it enough time to stabilize. In order to avoid the deep sleep connect it to the computer USB. Reboot phone (to reset counters). Let it sleep for at least 30 minutes then check the counters. What are the results of this test with flykernel-11 and setcpu inactive (meaning leaving it with the default smartass xxx/176 setting)?

Yeah I can try this test in awhile.. and I'll report the results back later..
6th October 2010, 02:49 PM |#505  
ziggy1001's Avatar
Senior Member
London
Thanks Meter: 971
 
More
Quote:
Originally Posted by lukesky

What my testing was doing is to find out the amount of time spent at 176mhz during Screen Off, which I found was very little time if any.

That is odd i rebooted my phone just before going to bed last night, when i checked my stats first thing this morning it had as it's supposed to do spent a lot of time @ 176
This was with SetCPU OC @ 691 but no other profiles set up
6th October 2010, 03:31 PM |#506  
Senior Member
Thanks Meter: 40
 
More
Talking
Quote:
Originally Posted by erasmux

My only guess is you didn't give it enough time to stabilize. In order to avoid the deep sleep connect it to the computer USB. Reboot phone (to reset counters). Let it sleep for at least 30 minutes then check the counters. What are the results of this test with flykernel-11 and setcpu inactive (meaning leaving it with the default smartass xxx/176 setting)?

Yeah I can try this test in awhile.. and I'll report the results back later..
---------------------------------------------------------

Okie dokie, I've tried the test and I'm happy to say erasmux was right!

I guess my previously very unscientific 10 min test was way off the mark.

This time round,using the default smartass settings without interference from SetCPU, the 176mhz counter definitely did chalk up a lot of time during ScreenOff. But sad to say, the wake up issues are there so even though it does sleep at 176mhz, it's not usable for me which is a damn pity...
6th October 2010, 08:30 PM |#507  
Senior Member
Thanks Meter: 11
 
More
Also not usable for me at 176 unfortunately and I suffered from auto brightness not working correctly

Did seem 'snappier' using smartass overall but had to nindroid back to the original kernall that came with Froyd
7th October 2010, 12:58 PM |#508  
Junior Member
Thanks Meter: 0
 
More
Hi,

I just installed this very nice kernel on my FroyVillain 1.5.

I tried the 176-653 version first, wich sucked up too much battery, but it was insanely fast. I sadly did not check the frequency with SetCPU this time.
After that, i took the 614 version, the same I had running from the original kernel variations, wich gave me about one day of battery.

Interestingly, SetCPU showed me that this kernel was going up to 748Mhz, and it seemed to actually run at that frequency.

So: If i take a stock kernel from FroydVillain, the upper frequency in the name of the kernel is the maximum of the kernel, and it can not go higher. If you want to go higher, take another kernel.
Does the upper frequency here only show the speed which it takes to boot, and not the upper overclock limit?
This would explain it.

Greetings
7th October 2010, 05:55 PM |#509  
Senior Member
Flag york
Thanks Meter: 0
 
More
Hi using the 614 version with froydvillain and my battery is excellent now. i am using average 20% a day compared to 60% without it! so top work on this mate cheers you have a new convert.
8th October 2010, 10:27 AM |#510  
Senior Member
Flag Singapore
Thanks Meter: 61
 
More
Hi erasmux,

I just flashed this and boy I'm loving the snappiness. But just in case, am I doing it right with my setCPU settings? It's the 576Mhz kernel.

8th October 2010, 01:44 PM |#511  
jeremy89632's Avatar
Senior Member
Flag Singapore
Thanks Meter: 3
 
More
I have some issues with the GPS Fix, it causes the phone to restart, FroydVillain.

Great kernel and all the best!

Cheers.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes