FORUMS
Remove All Ads from XDA
Honor 7x
Win an Honor 7X!
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
Hi guys,

I bought a t-mobile samsung galaxy s3 lte in the states when I was travelling around earlier this year.
I am now back in Norway, and I only get EDGE-speed on the phone, and i know the phone supports 2100mhz wcdma.

During the last weeks I have googled and tried everything for finding a solution, so posting here would be the last attempt to fix the phone before buying a s4.. (International, will never buy a us-version again)

When i select wcdma in the settings the status bar shows the "no-signal"-picture. When i then try to search for networks it gives me the "error while searcing"-message.

Things I've tried:
-Rooted the phone and tried all versions of the sgh-t999 modems which has been uploaded on xda-dev.
-Tried about every custom rom that is available for the phone.
-punching *#2263# and select wcdma int-2000 (This is 2100mhz i hope)
-imei no is still there

So I really hope someone can have a solution for me here. I really love fixing gadgets, but this thing is killing me. Starting to think this could be a hardware issue. GSM is working, so that didnt give any sence either..
Hoping someone out there have a solutions for configure the phone for wcdma2100 or something.

Looking forward to hearing from you wise people! http://forum.xda-developers.com/imag...ies/cowboy.gif
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes