FORUMS
Remove All Ads from XDA

[APP] BarcodeZilla / BarcodeZilla Lite 0.9.5 (Updated 22/05/2009)

99 posts
Thanks Meter: 2
 
By w3t, Member on 11th April 2009, 09:55 AM
Post Reply Email Thread
11th April 2009, 02:51 PM |#11  
OP Member
Flag Geneva
Thanks Meter: 2
 
More
Hello,

I think that i have a clue regarding the issue, i can reproduce it using .NET Configuration Editor.

If i set the default .NET Framework to use for BarcodeZilla to 2.0.7045 instead of 3.5.7283 then i'll get this error as well on my HTC.

If somebody can download this, extract and copy to his device to verify this theory.

I have uploaded a new .Cab to the main thread, now the application is forced to start using .NET 3.5, i suppose the issue happens if you have both .NET 2.0 and 3.5

Thanks
Attached Files
File Type: zip NetConfigurator.zip - [Click for QR Code] (132.0 KB, 133 views)
 
 
11th April 2009, 04:08 PM |#12  
Member
Flag Kassel
Thanks Meter: 14
 
More
nope sorry ... same error again...

On my Touch Pro there is only 3.5 not 2.0
11th April 2009, 04:13 PM |#13  
OP Member
Flag Geneva
Thanks Meter: 2
 
More
Hello,

Do you have this line in BarcodeZilla.exe.config with the latest version

<configuration>
<appSettings>
<setting name="UPCE" value="false"/>
<setting name="QR" value="false"/>
<setting name="EAN13" value="true"/>
<setting name="TryHard" value="false"/>
<setting name="UPCA" value="false"/>
<setting name="Resolution" value="default"/>
<setting name="Quality" value="l"/>
<setting name="UserCountry" value="CH"/>
<setting name="CODE128" value="true"/>
<setting name="SaveDecodedImages" value="false"/>
<setting name="CODE39" value="false"/>
<setting name="EAN8" value="true"/>
<setting name="DM" value="false"/>
</appSettings>
<startup>
<supportedRuntime version="v3.5.7283"/>
</startup>

</configuration>


If you check with .NET Configuration what is being reported ?

I know that some roms do only have a subset of .NET 3.5 but i don't know how to verify this actually.
11th April 2009, 04:21 PM |#14  
Member
Flag Kassel
Thanks Meter: 14
 
More
jup this lines are there.
.NET Conf reports that i only have "3.5.7283.0" installed and nothing else.
I also forced BarcodeZilla to use this version but the same error appears
11th April 2009, 05:37 PM |#15  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by w3t

Btw there are no server files actually. It's a SQL database which is behind the WCF WebService, i didn't even prepare any web interface actually, i just have a small windows client which can check what's going on on the webservice.

is there a way to change the server adres in the client then? to redirect it to a sql server of my own?

i will also try the cliennt if it works on my TP with nrg 2.0 rom
11th April 2009, 10:44 PM |#16  
snark_be's Avatar
Senior Member
Thanks Meter: 73
 
More
Nice piece of software.
Could you change the program so it uses UPC Database?

Instead of using your own DB, which will take some time to grow, UPC Database has already more than 1 million entries.
11th April 2009, 11:40 PM |#17  
MiKA7's Avatar
Senior Member
Thanks Meter: 11
 
More
Snark_be did the software work for you?? and if it did what phone do you have?? as it didnt work on my raphael with PROven 3.2..
12th April 2009, 07:18 AM |#18  
snark_be's Avatar
Senior Member
Thanks Meter: 73
 
More
Quote:
Originally Posted by MiKA7

Snark_be did the software work for you?? and if it did what phone do you have?? as it didnt work on my raphael with PROven 3.2..

Yes, it works fine for me. I had to install SQL Compact Edition on my TP and then no issues. The "camera" mode is easier to use than the "live" one to get the barcode picture.
12th April 2009, 07:59 AM |#19  
OP Member
Flag Geneva
Thanks Meter: 2
 
More
Quote:
Originally Posted by snark_be

Nice piece of software.
Could you change the program so it uses UPC Database?

Instead of using your own DB, which will take some time to grow, UPC Database has already more than 1 million entries.


Hello,

it's what i did for the very first version but i didn't like this for several reasons :

- no EAN-13 / EAN-8 support which are the mainly used formats for europe
- no price information
- not a webservice but only web based

the idea was really to be able to insert prices at different stores so the softwares reports the 3 best prices (per country, during the 3 last months).

also i wanted to avoid having to use Opera or any other browser and to have the possibility to directly create the new products on the device (even when you are disconnected) and to be able to synchronize at any time.

Once again it's really a preliminary release, the advantage is that even if the product isn't known by the server it takes 5-10 seconds to enter just the company name / product name and you can start storing the price of a product at the current moment.
12th April 2009, 08:10 AM |#20  
OP Member
Flag Geneva
Thanks Meter: 2
 
More
For those having issues, here's a screenshot of my \Windows folder on my HTC Touch HD.



Can you please verify you have those files as well, the following assemblies are being required by BarcodeZilla :

System
System.Data
System.Runtime.Serialization
System.ServiceModel
System.Web.Services
System.Xml

Normally those files are part of CF 3.5 but i remember in the past i have loaded a ROM where the framework was incomplete...
12th April 2009, 08:13 AM |#21  
snark_be's Avatar
Senior Member
Thanks Meter: 73
 
More
The problem is always "the critical mass".

You need some amount of data before people finds this interesting and starts to use your programs to add stuff. But to get that data, you need already people to input it. "chicken & egg" problem.
Post Reply Subscribe to Thread

Tags
barcode, barcodezilla, qr-code, reader, sql, zxing

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes