FORUMS
Remove All Ads from XDA
Honor CEO Thread

[01/10] [DEV] [FIXED] Low Speakerphone Mic Gain & High Background Noise ONE CLICK FIX

907 posts
Thanks Meter: 204
 
By memin1857, Senior Member on 10th July 2011, 10:46 AM
Post Reply Email Thread
13th July 2011, 09:31 PM |#21  
Inactive Recognized Developer
Flag ┌┐(●_●)┌┐
Thanks Meter: 816
 
More
Quote:
Originally Posted by memin1857

It is pinned (stickied) because this is last "major" problem left that happens on every rom. All other problems can be considered minor. Please stay on topic and don't discuss about things unrelated to the problem mentioned in first of this thread. This is not only my problem, every hd2 user has it. This is the best way to get a developers attention, it is the "developers" forum.
I asked noellenchris to make this sticky for some time to see if it will get attention from a developer. I thank him here for that since I believe he shares my belief that this thread is important for the hd2 android project. Sticky making is a decision of a forum moderator.

I edited the opening post to be more detailed and specific btw.

It is not on every rom aosp roms dont have this thanks to iamgpc. Try tytungs or iamgpc's rom and you will see it is not there.
 
 
13th July 2011, 11:09 PM |#22  
Senior Member
Thanks Meter: 113
 
More
Post
Hi in my ROM

After applying:
http://forum.xda-developers.com/showthread.php?t=860850
Mic gain is perfect. I beleive is letama's file.

Speakerphone is "OK" (however as you said, mic gain doesn't not change).

No background noise here either.

edit:Also Tyween CM7 doesn't have this problem, I never experienced in the 4+ months I used it.

I have the Tmo version
14th July 2011, 07:46 AM |#23  
Senior Member
Thanks Meter: 1
 
More
I'm not sure if you ever noticed my old thread on the Q&A forum but this is possibly related:

http://forum.xda-developers.com/show....php?t=1042051

Not sure if that code I posted there can help you, but maybe...

There's also this thread I found a while ago on the Galaxy S forum relating to sound issues that could be of help:

http://forum.xda-developers.com/showthread.php?t=806195
14th July 2011, 09:31 AM |#24  
ozkaya's Avatar
Senior Member
Thanks Meter: 291
 
More
I don't agree with you that this is the LAST major issue remaining nor the most important for HD2. These things are all subjective, you can say it is really important for you, but for me never using speakerphone, 720p recording is more important. Anyway hope this gets solved as well, along with some other bugs we're still facing.
The Following User Says Thank You to ozkaya For This Useful Post: [ View ] Gift ozkaya Ad-Free
14th July 2011, 09:38 AM |#25  
codiak's Avatar
Senior Member
Thanks Meter: 141
 
More
At least, its a phone. If the phone is not functioning properly, I would also call it a major issue.
Just my 2 cents.
14th July 2011, 11:19 AM |#26  
raven_raven's Avatar
Senior Member
Flag Poznań
Thanks Meter: 39
 
More
Quote:
Originally Posted by ozkaya

I don't agree with you that this is the LAST major issue remaining nor the most important for HD2. These things are all subjective, you can say it is really important for you, but for me never using speakerphone, 720p recording is more important. Anyway hope this gets solved as well, along with some other bugs we're still facing.

There is a difference. If the phone functionality in a, very advanced, but still phone is bugged, so it is an issue. 720p recording is just a feature, it is optional. HD2s were designed to record in 480x800 and higher resolutions are something nice to see, but... we can live without it.

PS. I missed "Quote" button and clicked "Thanks". I really didn't mean to.

Oh, and one more thing. This is a development thread. Not "Post most bugging you issue on your HD2", not "Off-topic discussion about bugs in Android on HD2" or so. I think only devs should post here. If you have nothing relevant and useful to say, please don't say it. If you want to say "HEL YEAH IT'S A AWFUL ISSUE PLS FIX IT" then just clicking "Thanks" button under first post will do. Everyone want to have this bug fixed, so... nobody really cares, if you post it.
14th July 2011, 11:45 AM |#27  
OP Senior Member
Flag Istanbul
Thanks Meter: 204
 
More
Quote:
Originally Posted by jan-willem3

It is not on every rom aosp roms dont have this thanks to iamgpc. Try tytungs or iamgpc's rom and you will see it is not there.

Are you saying aosp roms change their mic gain when speakerphone is enabled/disabled????
I'll just try that now.

EDIT: I tested the mentioned roms and they have the same problem, it makes sense since they are using the same kernel with same acdb files. I think you misunderstood what the actual problem is. iamgpc told me that the problem is not related to libaudio.so which he modified. And this is written in the first post, please read it throughly again, it has been edited lately.
14th July 2011, 11:48 AM |#28  
clyder's Avatar
Senior Member
Flag Indjija
Thanks Meter: 475
 
More
Quote:
Originally Posted by memin1857

Are you saying aosp roms change their mic gain when speakerphone is enabled/disabled??
I'll just try that now.

Sent from my HTC HD2 using XDA App

I haven't had that impression while using any AOSP rom (NexusHD, every CM7 rom I tried, UltimateDroid...). People are always complaining to me that they barely hear me when I use the speakerphone while driving.
14th July 2011, 02:13 PM |#29  
OP Senior Member
Flag Istanbul
Thanks Meter: 204
 
More
Quote:
Originally Posted by clyder

I haven't had that impression while using any AOSP rom (NexusHD, every CM7 rom I tried, UltimateDroid...). People are always complaining to me that they barely hear me when I use the speakerphone while driving.

Yes, I tested the mentioned roms and they have the same problem since they are using the same kernel with same acdb files. I think jan-willem3 misunderstood what the actual problem is.
14th July 2011, 02:43 PM |#30  
Inactive Recognized Developer
Flag ┌┐(●_●)┌┐
Thanks Meter: 816
 
More
Quote:
Originally Posted by memin1857

Yes, I tested the mentioned roms and they have the same problem since they are using the same kernel with same acdb files. I think jan-willem3 misunderstood what the actual problem is.

Well Iamgpc made a different default.acdb file.
I had the idea that with that file the problem was fixed.
14th July 2011, 10:08 PM |#31  
OP Senior Member
Flag Istanbul
Thanks Meter: 204
 
More
Quote:
Originally Posted by jan-willem3

Well Iamgpc made a different default.acdb file.
I had the idea that with that file the problem was fixed.

I found the acdb file made by iamgpc (it is 125868 bytes)
I tested it and it has the same levels as default.acdb. The mic gain is always high in both normal and speakerphone mode. I was unable to find information about what he wrote when he released it.
I pm'ed him to ask about what was different from default.acdb or LeTama's htcleo.acdb
So sorry for us, iamgpc's file doesn't work either.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes