FORUMS
Remove All Ads from XDA

Possible A2DP skipping solution!

54 posts
Thanks Meter: 6
 
By crushsuitandtie, Member on 26th May 2009, 02:54 AM
Post Reply Email Thread
26th May 2009, 11:36 PM |#21  
chunga's Avatar
Senior Member
Thanks Meter: 0
 
More
Very nice tip! I have s9 also, but the "hick ups" happens more frequently in my car!
 
 
26th May 2009, 11:37 PM |#22  
Junior Member
Flag Highland, UT
Thanks Meter: 0
 
More
Quote:
Originally Posted by dan0zone

if you guys remember windows mobile , the BT stack by default is set with the bit pool min and max @ 31 ,it works great but the sound quality sucks.. if you use a registry editor and increase the max bit pool sound quality gets better . i used to do this with my wing , using this same S9 headphone ,the trick was not to go to high with max bitpool and to lower min to 12 and this worked great,, max was @ 46 min was @ 12 ,, no skipping at all.. and great sound . WE need to find a way to get these adjusted on android , this should fix
now i do believe the wing and G1 both use boardcom stacks ,could be wrong>>

In my testing on the G1, the maximum bitpool is not fixed. It selects the maximum bitpool that the headset advertises (as it should). Unfortunately, some headsets advertise a max in the low 30's (pretty mediocre). A better value would be around 53. The Sony DR-BT21G advertises 53, and the G1 uses that value.
27th May 2009, 02:55 AM |#23  
dan0zone's Avatar
Senior Member
Flag LYNN
Thanks Meter: 18
 
More
Your right,53 is better even 68 ,anything higher will clip ,maybe the fix is keeping from switching
BTW what's the min bitpool look like ?
27th May 2009, 03:00 AM |#24  
Senior Member
Thanks Meter: 323
 
More
Quote:
Originally Posted by paesano

In my testing on the G1, the maximum bitpool is not fixed. It selects the maximum bitpool that the headset advertises (as it should). Unfortunately, some headsets advertise a max in the low 30's (pretty mediocre). A better value would be around 53. The Sony DR-BT21G advertises 53, and the G1 uses that value.

Is there a way to check what bitpool a headset supports?

I have a sony DR-BT22 and I haven't noticed too much skipping. I'm guessing it supports at least 53, since your bt21g supports that value.
27th May 2009, 04:34 PM |#25  
Junior Member
Flag Highland, UT
Thanks Meter: 0
 
More
Quote:
Originally Posted by dwang

Is there a way to check what bitpool a headset supports?

I have a sony DR-BT22 and I haven't noticed too much skipping. I'm guessing it supports at least 53, since your bt21g supports that value.

If you have a Bluetooth Sniffer or write some code you can. I don't know of any apps that will do it.
27th May 2009, 11:00 PM |#26  
Junior Member
Flag Highland, UT
Thanks Meter: 0
 
More
Quote:
Originally Posted by dan0zone

Your right,53 is better even 68 ,anything higher will clip ,maybe the fix is keeping from switching
BTW what's the min bitpool look like ?

The minimum bitpool on my headset is 2, and that is what Android selects. However, it never actually uses that bitpool.
27th May 2009, 11:03 PM |#27  
chunga's Avatar
Senior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by chunga

Very nice tip! I have s9 also, but the "hick ups" happens more frequently in my car!

Your tip isn't working for me
5th June 2009, 04:21 PM |#28  
Member
Thanks Meter: 5
 
More
I've seen this a little as well. My difficulty is that my bluetooth car streo doubles as a handsfree speakerphone so I don't really have the option of turning off either profile.

However, most of the time things work fine. I've found that following a reboot it tends to skip a lot less. I'm sure it will get cleared up.
5th June 2009, 04:26 PM |#29  
Member
Thanks Meter: 5
 
More
I've seen this a little as well. My difficulty is that my bluetooth car streo doubles as a handsfree speakerphone so I don't really have the option of turning off either profile.

However, most of the time things work fine. I've found that following a reboot it tends to skip a lot less. I'm sure it will get cleared up.
5th June 2009, 04:38 PM |#30  
Junior Member
Thanks Meter: 0
 
More
I tested this skipping issue some time ago. Just check if you disabled wireless or data radio. I notice it tends to skip very often when the wireless is scanning or the network is reconnecting. You can try enabling wireless in an area with no wireless and your a2dp will skip very often. Just disable wireless and data radio when you are in a region with no signal will help (at least for me)
5th June 2009, 05:39 PM |#31  
Member
Thanks Meter: 5
 
More
Thanks - I'll try disabling wifi the next time it happens. Of course, this really isn't ideal (an extra step to perform) but at least I'm unlikely to be using wifi while listening to music in the car...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes