FORUMS
Remove All Ads from XDA

[GUIDE/TIPS] How to Port OEM Apps / Vendor Apps to Your Current ROM

1,612 posts
Thanks Meter: 15,988
 
By Rizal Lovins, Recognized Developer / Recognized Themer / Recognized Contributor on 9th October 2013, 04:23 AM
Post Reply Email Thread
22nd February 2014, 12:11 PM |#31  
GalaxyUser's Avatar
Senior Member
Flag Aix-en-Provence
Thanks Meter: 3,737
 
Donate to Me
More
Quote:
Originally Posted by slink722

@Rizal Lovins, bro is it possible that u can make a tutorial also on how to port themes? specially 4.3 themes to 4.1.2? btw, great tutorial bro..congrats!

Hi,

As it's a framework file i think you need to edit your bootclasspath to match with this files and others dependencies files.

So edit your boot.img and copy all necessary framework files to /system/framework and try again to port this app.

Do a backup of your rom and be carreful or you will just break your phone

Sent from my Nexus 5 using xda app-developers app
10th March 2014, 10:26 AM |#32  
Junior Member
Thanks Meter: 2
 
More
It would be possible to port the samsung dialer with swipe left to call and right to sms, for all 4.4.2 roms ?
10th March 2014, 04:11 PM |#33  
CNexus's Avatar
Senior Member
Flag ~/android
Thanks Meter: 14,053
 
Donate to Me
More
Quote:
Originally Posted by vindau

It would be possible to port the samsung dialer with swipe left to call and right to sms, for all 4.4.2 roms ?

Nearly impossible because of all the dependencies it has on the touchwiz framework
11th March 2014, 04:44 PM |#34  
vyaskd's Avatar
Senior Member
Thanks Meter: 16
 
More
hi devs. can anyone port Gionee E3 default notepad apk? thanks in advance
26th March 2014, 12:23 AM |#35  
oracle01642's Avatar
Senior Member
Flag XDA
Thanks Meter: 282
 
More
On average, how long would you say it takes to learn this stuff, decompiling and recompiling apps etc?

Rizal, could you or some other 'recognised contributor' or 'recognised developer' port the S5's apps to the S4? You seem to know a lot about this stuff, so I thought id ask you.
26th March 2014, 01:10 AM |#36  
CNexus's Avatar
Senior Member
Flag ~/android
Thanks Meter: 14,053
 
Donate to Me
More
Quote:
Originally Posted by oracle01642

On average, how long would you say it takes to learn this stuff, decompiling and recompiling apps etc?

Rizal, could you or some other 'recognised contributor' or 'recognised developer' port the S5's apps to the S4? You seem to know a lot about this stuff, so I thought id ask you.

They require kitkat

http://forum.xda-developers.com/show....php?t=2690997
The Following User Says Thank You to CNexus For This Useful Post: [ View ] Gift CNexus Ad-Free
26th March 2014, 01:23 AM |#37  
oracle01642's Avatar
Senior Member
Flag XDA
Thanks Meter: 282
 
More
Quote:
Originally Posted by CNexus

They require kitkat

http://forum.xda-developers.com/show....php?t=2690997

Thanks for the reply. I have most of those apps already installed. Some of them don't work perfectly, and need some work. There is also some apps that don't work at all, such as music player and TW launcher. Just thought id ask you guys, but you probably don't have an S4, so you wouldn't be interested in porting all of the S5 stuff to the S4. Oh well, I guess I will just have to wait and hope someone in the S4 forums gets them all working soon.
26th March 2014, 07:32 AM |#38  
Aman_Arora's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 1,037
 
More
While trying to port Z2 conversations from its dump to n5
All permissions except 1 (for internet -->platform.xml) were not in dump.I have checked files thoroughly and didnot find any others.
BEcause of which Conversations couldn't be used to send & receive mms sms .
So how i get those perm files
4th April 2014, 12:33 PM |#39  
Hajime's Avatar
Senior Member
Flag Stuttgart Germany
Thanks Meter: 239
 
More
Thumbs up Help
Can you help me port galaxy s4 launcher for kitkat pls
12th April 2014, 09:48 AM |#40  
qvgahub's Avatar
Senior Member
Flag new delhi
Thanks Meter: 35
 
More
thanks for ur great guide i was trying to port an app to gingerbread ....but when i searched the androidmanifest.xml it does not contain any line with minsdkversion...instead it uses <receiver ="com.adjust.sdk.ReferrerReceiver" ="true"> can anyone help me out ...i want to change the minsdkversion required by the app
12th April 2014, 06:18 PM |#41  
Aman_Arora's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 1,037
 
More
Quote:
Originally Posted by qvgahub

thanks for ur great guide i was trying to port an app to gingerbread ....but when i searched the androidmanifest.xml it does not contain any line with minsdkversion...instead it uses <receiver ="com.adjust.sdk.ReferrerReceiver" ="true"> can anyone help me out ...i want to change the minsdkversion required by the app

Even if you change sdk version it is not 100% sure that it will work.
To change it go to the decompiled apk folder there will be a *.yml file generally named apktool.yml in that you can find min and target SDK version .Hope it helps.
All the Best 👍

Sent from my Nexus 5 using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes