Remove All Ads from XDA

[HELP] SMS only goes through after outward call

6 posts
Thanks Meter: 0
By matt.vansickle, Junior Member on 3rd April 2012, 04:41 AM
Post Reply Email Thread
I flashed CM7 TG reloaded last night and so far I'm loving it! Everything seemed to be working fine at first (i.e.- placed and received calls, sent and received SMS and MMS). After I performed said tests to make sure the ROM was functioning properly I went ahead and began restoring all my previous apps through Titanium Backup. It all went without a hitch until this morning when I tried sending a SMS. I'm using the default messaging app and where the "Sent: x:xx" would be displayed, it instead stays on "Sending...". Incoming SMS messages are also not coming in (I tried sending multiple texts from my gf's phone.) The odd thing is I can send and receive MMS without any issues and the phone will both send and receive delayed SMS if I place a phone call. Also, all incoming phone calls do not get through to me.

So to clarify, I CAN make phone calls and send MMS. I CAN'T receive phone calls or send/receive SMS UNLESS I place a phone call. Any help would be appreciated.
3rd April 2012, 07:08 PM |#2  
OP Junior Member
Thanks Meter: 0
I just did a factory reset on my phone, cleared data/cache, wiped dalvik cache, and reflashed the ROM. I have not restored any of my apps so I'm running a clean install. I'm still experiencing the same issues. If there is a step I'm missing it'd be great to know so I have a fully functioning phone. Should I wipe /system as well or would that not help? I'm open to any suggestions at this point.
4th April 2012, 05:48 PM |#3  
OP Junior Member
Thanks Meter: 0
One more thing I've observed is that the signal strength stays at -120dBm until I open a call. Once a call is opened I gain signal strength to about -89dBm (this is at home for me) and that's when I receive a swarm of texts and any texts I tried to send prior to calling get sent. Is this any indication of something? If anyone could help, please do. I really don't want to go back to the stock rom haha.

edit: Ok, so if I disable the EvDo network then all of my problems are solved. Obviously I'd like to keep 3G, but this is where I'm at right now.
10th April 2012, 06:12 PM |#4  
Junior Member
Thanks Meter: 1
SAME PROBLEM. Started this past week. Was fine for months on TG reloaded.
I was thinking it was new app related, but you wiped and still have the problem?
I'm not going to wipe if you already tried it.

I'm going to try turning off EVDO and see what happens.
edit: INSTANTLY dozens of missing texts sent/received when going from EVDO only to CDMA only mode!

I am pondering if flashing back to stock ROM and re-running Virgin Activation app would help....
Damn I wish you could run Activation in CM7
11th April 2012, 09:02 PM |#5  
Junior Member
Thanks Meter: 1
So last night I did a little more digging... ended up clearing data and cache on messaging app, powering down, removing the battery for 30 min, powering back up and switching radio to cdma/evdo (vs one or the other).

So far texts / sms are working today, and I have neither made nor received any phone calls. Perhaps incoming are still going straight to voicemail, but I receive very few calls so I will check later.

Sent from my Triumph using Tapatalk
The Following User Says Thank You to raiser1 For This Useful Post: [ View ] Gift raiser1 Ad-Free
14th April 2012, 08:59 PM |#6  
OP Junior Member
Thanks Meter: 0
Things seemed to also work for me when I went into System select (the option in Mobile network settings) and changed the cdma roaming mode from "Home", which was selected by default, to "Automatic". Haven't run into problems since changing that setting.
14th April 2012, 10:24 PM |#7  
JTAKER's Avatar
Thanks Meter: 13
Well, I found this in the TG-Reloaded thread: "DO NOT use the Titanium Backup App, which can cause more problems"

I flashed mine about a week ago and haven't had any problems.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes