FORUMS
Remove All Ads from XDA

[APP][4.0+][ROOT] SCR Screen Recorder

165 posts
Thanks Meter: 375
 
Post Reply Email Thread
17th June 2015, 01:34 PM |#521  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by iwobanas

Did you get the hard-install warning dialog (asking about the modification of system partition)? What's error exactly are you getting?
Recently I haven't got time to work on SCR but I should have some time to look into it this or next week.

I attached a screenshot of my error when i try to record with internal audio recording selected.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2015-06-17-15-25-58.jpg
Views:	244
Size:	246.4 KB
ID:	3366746  
 
 
17th June 2015, 01:59 PM |#522  
OP Senior Member
Thanks Meter: 375
 
Donate to Me
More
Quote:
Originally Posted by Adisorx

I attached a screenshot of my error when i try to record with internal audio recording selected.

That's interesting. I wonder if it's really a problem with SELinux or some other Lollipop audio issue. When you get this error please go to SCR Settings, select "Send bug report" and send the generated email.
Please mention your XDA nick in the email so that I can relate issue to the report.

Also try selecting "Software MPEG4" video encoder and reducing resolution.
The software encoder is really slow on high resolutions but testing it may help me in diagnosing the problem.
17th June 2015, 02:09 PM |#523  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by iwobanas

That's interesting. I wonder if it's really a problem with SELinux or some other Lollipop audio issue. When you get this error please go to SCR Settings, select "Send bug report" and send the generated email.
Please mention your XDA nick in the email so that I can relate issue to the report.

Also try selecting "Software MPEG4" video encoder and reducing resolution.
The software encoder is really slow on high resolutions but testing it may help me in diagnosing the problem.

Tried as you said (lower resolution and mpeg4 and same error. Bug reports send via email.
17th June 2015, 02:14 PM |#524  
Senior Member
Thanks Meter: 16
 
More
Unhappy No solutions?
Quote:
Originally Posted by mekar07

My Galaxy Mega Gt-I9205 can't record screen after I updated to Kitkat..the problem only when i choose -internal audio...or..internal+mic..other than that no problem persist
this the scrnshot ..

No solutions for this??
17th June 2015, 03:02 PM |#525  
OP Senior Member
Thanks Meter: 375
 
Donate to Me
More
If you're having issues with SELinux enforcing on Lollipop please try H264 (no root) video encoder with Internal audio and let me know if it works for you.
17th June 2015, 03:46 PM |#526  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by iwobanas

If you're having issues with SELinux enforcing on Lollipop please try H264 (no root) video encoder with Internal audio and let me know if it works for you.

Did it with h264 no root enabled and it seems i have succeeded to record with internal audio enabled. However, the audio it's a mess. Bug report sent, if helps.
17th June 2015, 05:58 PM |#527  
fred_pitoizet's Avatar
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by iwobanas

Does the problem only affect Audio source settings or other settings as well?
Audio source is intentionally reset to Mute (and information dialog is displayed) after Android audio subsuctem crash/restart.
It's meant to prevent destabilising system in case of incompatible audio driver.

No, it affects resolutions, output directory, mic settings too.
If I kill the app and restart it : the settings seem to be reloaded as default, as if they weren't recorded...

EDIT: I've made some investigations.
Looked into logcat : nothing special.
The settings are well stored in /data/data/com.iwo...screenrecorder.pro/shared_prefs/ScreenRecorderSettings.xml.
But when I kill/restart the app : the settings are defaults in ui, when I only change one thing, only one thing changes in the .xml
If I kill/restart the app and start a record, the recorder uses default settings has displayed in UI, not the parameters defined in the SharedPrefs (.xml).
17th June 2015, 06:02 PM |#528  
Senior Member
Thanks Meter: 16
 
More
Unhappy
Quote:
Originally Posted by mekar07

My Galaxy Mega Gt-I9205 can't record screen after I updated to Kitkat..the problem only when i choose -internal audio...or..internal+mic..other than that no problem persist
this the scrnshot ..

Sadly how abt this problem, iwo?...please rply..
17th June 2015, 06:55 PM |#529  
OP Senior Member
Thanks Meter: 375
 
Donate to Me
More
Quote:
Originally Posted by mekar07

Sadly how abt this problem, iwo?

Dunno, you may try some alternative KitKat ROM. I'm going to have a look at new audio compatibility issues tomorrow but I can't promise I'll be able to fix yours.
17th June 2015, 07:09 PM |#530  
fred_pitoizet's Avatar
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by fred_pitoizet

No, it affects resolutions, output directory, mic settings too.
If I kill the app and restart it : the settings seem to be reloaded as default, as if they weren't recorded...

EDIT: I've made some investigations.
Looked into logcat : nothing special.
The settings are well stored in /data/data/com.iwo...screenrecorder.pro/shared_prefs/ScreenRecorderSettings.xml.
But when I kill/restart the app : the settings are defaults in ui, when I only change one thing, only one thing changes in the .xml
If I kill/restart the app and start a record, the recorder uses default settings has displayed in UI, not the parameters defined in the SharedPrefs (.xml).

I've done some screenshots.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2015-06-17-20-03-32.png
Views:	158
Size:	179.8 KB
ID:	3367116   Click image for larger version

Name:	Screenshot_2015-06-17-20-04-02.png
Views:	160
Size:	128.6 KB
ID:	3367117  
18th June 2015, 04:33 AM |#531  
Senior Member
Thanks Meter: 16
 
More
Quote:
Originally Posted by iwobanas

Dunno, you may try some alternative KitKat ROM. I'm going to have a look at new audio compatibility issues tomorrow but I can't promise I'll be able to fix yours.

Just to inform u....I already sent logcat to your hotmail 5 days ago.. ☺
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes