FORUMS
Remove All Ads from XDA

[ROM][ICS] CM9-based Port [Updated: Nov 5th '12]

510 posts
Thanks Meter: 873
 
Post Reply Email Thread
17th March 2012, 08:07 PM |#201  
eoghan2t7's Avatar
Recognized Contributor
Flag Belfast
Thanks Meter: 2,817
 
Donate to Me
More
Quote:
Originally Posted by munjeni

No, it have blue screen now, but I think something in boardconfig.mk need to change, for example to uncoment comented line USE_OPENGL_RENDERER := true or maybe something to change in COMMON_GLOBAL_CFLAGS... in any way I plaing with it, maybe get something
Trying to debug:
E/libEGL ( 113): eglMakeCurrent:629 error 3009 (EGL_BAD_MATCH)

E/SurfaceFlinger( 113): Couldn't create a working GLES context. check logs. exiting...

from the HTC marvel forums we thanks you as this rom works with my kernel now that HWA is sort of working

so

BIG THANKS
17th March 2012, 08:33 PM |#202  
Senior Member
Thanks Meter: 211
 
More
Quote:
Originally Posted by munjeni

http://paste.ubuntu.com/888017/

What does this mean? Seems like its good news...

Sent from my SAMSUNG-SGH-I997 using xda premium
17th March 2012, 08:33 PM |#203  
eoghan2t7's Avatar
Recognized Contributor
Flag Belfast
Thanks Meter: 2,817
 
Donate to Me
More
also i just synced the cm repo and got these possibly the CM team have done the work for us

Code:
From git://github.com/CyanogenMod/android_hardware_qcom_display
   da60cfc..e73c94b  ics        -> github/ics
Fetching projects:  69% (171/247)  remote: Counting objects: 20, done.
remote: Compressing objects: 100% (6/6), done.
remote: Total 15 (delta 13), reused 11 (delta 9)
Unpacking objects: 100% (15/15), done.acking objects:  33% (5/15)   
From git://github.com/CyanogenMod/android_hardware_qcom_media
   3bb5ce0..dab9641  ics        -> github/ics
17th March 2012, 08:46 PM |#204  
OP Senior Member
Thanks Meter: 873
 
Donate to Me
More
Quote:
Originally Posted by eoghan2t7

also i just synced the cm repo and got these possibly the CM team have done the work for us

Code:
From git://github.com/CyanogenMod/android_hardware_qcom_display
   da60cfc..e73c94b  ics        -> github/ics
Fetching projects:  69% (171/247)  remote: Counting objects: 20, done.
remote: Compressing objects: 100% (6/6), done.
remote: Total 15 (delta 13), reused 11 (delta 9)
Unpacking objects: 100% (15/15), done.acking objects:  33% (5/15)   
From git://github.com/CyanogenMod/android_hardware_qcom_media
   3bb5ce0..dab9641  ics        -> github/ics

http://review.cyanogenmod.com/#q,sta...branch:ics,n,z
Some audio stuff for 7x30.
17th March 2012, 09:26 PM |#205  
munjeni's Avatar
Senior Member
Thanks Meter: 21,693
 
Donate to Me
More
Quote:
Originally Posted by eoghan2t7

also i just synced the cm repo and got these possibly the CM team have done the work for us

https://github.com/CyanogenMod/andro...media/tree/ics I see there is last commit 3 months ago, so I dont think there have hw fix! But as I see cm team already included KAI hw fix (simple add MISSING_EGL_EXTERNAL_IMAGE := true), but other definition (that not exist in liberty tree) that I trying now is SURFACEFLINGER_FORCE_SCREEN_RELEASE... maybe I get something... or maybe we need another proprietary libs (for example from froyo)?

---------- Post added at 08:26 PM ---------- Previous post was at 08:03 PM ----------

Quote:

E/libEGL ( 1301): eglMakeCurrent:629 error 3009 (EGL_BAD_MATCH)

E/SurfaceFlinger( 1301): Couldn't create a working GLES context. check logs. exiting...

Found something about it. http://www.khronos.org/opengles/sdk/...akeCurrent.xml

Quote:

EGL_BAD_MATCH is generated if draw or read are not compatible with context, or if context is set to EGL_NO_CONTEXT and draw or read are not set to EGL_NO_SURFACE, or if draw or read are set to EGL_NO_SURFACE and context is not set to EGL_NO_CONTEXT.

so maybe EGL_NO_CONTEXT ? I tried many combinations with same result! But will try with SURFACEFLINGER_FORCE_SCREEN_RELEASE and without QCOM_HARDWARE
17th March 2012, 09:37 PM |#206  
eoghan2t7's Avatar
Recognized Contributor
Flag Belfast
Thanks Meter: 2,817
 
Donate to Me
More
Quote:
Originally Posted by WinSuk

http://review.cyanogenmod.com/#q,sta...branch:ics,n,z
Some audio stuff for 7x30.

no im talking about this tree

https://github.com/CyanogenMod/andro...e_qcom_display

it was updated 3 days ago?
17th March 2012, 10:03 PM |#207  
munjeni's Avatar
Senior Member
Thanks Meter: 21,693
 
Donate to Me
More
Sorry, I checked it in my source and this is allready removed (I use latest comits from yesterday)
17th March 2012, 10:55 PM |#208  
eoghan2t7's Avatar
Recognized Contributor
Flag Belfast
Thanks Meter: 2,817
 
Donate to Me
More
Quote:
Originally Posted by munjeni

Sorry, I checked it in my source and this is allready removed (I use latest comits from yesterday)

So my repo downloading old source code then?

Sent from my Wildfire S using xda premium
17th March 2012, 11:03 PM |#209  
munjeni's Avatar
Senior Member
Thanks Meter: 21,693
 
Donate to Me
More
Yesterday I have updated repo from here -> repo init -u git://github.com/CyanogenMod/android.git -b ics so I dont know if you have latest "synced" repo
18th March 2012, 12:56 AM |#210  
munjeni's Avatar
Senior Member
Thanks Meter: 21,693
 
Donate to Me
More
Enabled cm7 debug log http://paste.ubuntu.com/888439/ so we can compare it with cm9 log

Diference cm9:
msm7k.gralloc( 113): yres_virtual = 1440 px
cm7:
msm7k.gralloc( 226): yres_virtual = 960 px
cm9:
msm7k.gralloc( 113): refresh rate = 0.00 Hz
cm7:
msm7k.gralloc( 226): refresh rate = 60.00 Hz


gralloc problem?
960/3=320
1440/3=480 so we use wrong yres and I think its an reason why it not working
The Following 2 Users Say Thank You to munjeni For This Useful Post: [ View ] Gift munjeni Ad-Free
18th March 2012, 06:51 AM |#211  
themacman1000's Avatar
Senior Member
Flag Portland
Thanks Meter: 124
 
More
Quote:
Originally Posted by munjeni

Enabled cm7 debug log http://paste.ubuntu.com/888439/ so we can compare it with cm9 log

Diference cm9:
msm7k.gralloc( 113): yres_virtual = 1440 px
cm7:
msm7k.gralloc( 226): yres_virtual = 960 px
cm9:
msm7k.gralloc( 113): refresh rate = 0.00 Hz
cm7:
msm7k.gralloc( 226): refresh rate = 60.00 Hz


gralloc problem?
960/3=320
1440/3=480 so we use wrong yres and I think its an reason why it not working

Really working on this, aren't you? Thank you so much!

Sent from my HTC Intruder
Post Reply Subscribe to Thread

Tags
cm9, cyanogenmod, ice cream sandwich, ics

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes