FORUMS

Pantech Element TWRP Recovery and Stock Rooted Roms

3,628 posts
Thanks Meter: 4,498
 
By jmz, Inactive Recognized Developer on 9th May 2013, 11:41 PM
Post Reply Email Thread
11th May 2013, 06:58 PM |#11  
Member
Thanks Meter: 11
 
More
Quote:
Originally Posted by dagadu

I'm stuck on fastboot mode. <waiting on device>
I tried unplug/replug USB to different connector, and it's still on <waiting for device>
I even tried to install driver manually from each files pantech folder and still no response
TWRP is on same folder and also set on environment variable
I have done adb devices and it detects as PORORO03111xxxxxxxxxxx
Any suggestion guys?

Did you check "USB debugging" on the tablet?

Also, I had to set USB connection on the tablet to the last choice "PC Data Mode".

Hope it helps.
12th May 2013, 01:49 AM |#12  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by jmztaylor

Waiting on device in fastboot means drivers aren't installed or the wrong ones are. Download the software upgrade app from pantech site then install. Browse to the install directory and run the installer for the drivers. But before that uninstall whatever drivers you have installed currently. I'm mobile or else I would link you directly

Sent from my M7 using xda premium

Is this what you're referring to? I download it from Pantech website.
htt p://c7240 62.r62 .cf2.rackcdn. com/PantechPCSuite_1.1.1.3437. exe

When do I need to install the driver? During fastboot mode, or normal mode?
I also notice that when I change the usb mode to MTP, it detects missing driver as well.
During normal mode it detects 2 pantech drivers in order to connect to pc suite.

Oya, when you guys do adb devices, does your device detect POROROxxxxxxx as well or only numbers?
I wonder this has anything to do with it, because I was trying to root with honeycomb version earlier and my pantech is ICS 4.0.4
12th May 2013, 02:00 AM |#13  
jmz's Avatar
OP Inactive Recognized Developer
Flag Lawton, OK
Thanks Meter: 4,498
 
More
Quote:
Originally Posted by dagadu

Is this what you're referring to? I download it from Pantech website.
htt p://c7240 62.r62 .cf2.rackcdn. com/PantechPCSuite_1.1.1.3437. exe

When do I need to install the driver? During fastboot mode, or normal mode?
I also notice that when I change the usb mode to MTP, it detects missing driver as well.
During normal mode it detects 2 pantech drivers in order to connect to pc suite.

Oya, when you guys do adb devices, does your device detect POROROxxxxxxx as well or only numbers?
I wonder this has anything to do with it, because I was trying to root with honeycomb version earlier and my pantech is ICS 4.0.4

Anytime when the tablet is not plugged in. This will make the computer automatically install anything needed for the tablet and you won't have issues with fastboot or adb anymore

Sent from my M7 using xda premium
12th May 2013, 10:17 AM |#14  
Member
Thanks Meter: 18
 
More
Quote:
Originally Posted by jmztaylor

Instructions for installing TWRP Recovery:

1. Ensure you have Android SDK installed with adb and fastboot working
2. Download both the twrprecovery.img and twrprecovery.zip from here
3. Copy twrprecovery.zip to external sdcard
4. Reboot tablet to bootloader by issuing the command "adb reboot bootloader"
5. Then "fastboot boot twrprecovery.img"
6. When in recovery choose install then browse to /sdcard and choose twrprecovery.zip and flash that zip
7. Now TWRP is installed permanently.

I did not understand anything of this manual...
I took the CWM file for Pantech A810S and replaced it recovery to ours, flashed(connect working Element to PC and start cwm.but), everything works.
Attached Files
File Type: rar PantechElementTWRP.rar - [Click for QR Code] (7.59 MB, 845 views)
12th May 2013, 05:00 PM |#15  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by 1806

I did not understand anything of this manual...
I took the CWM file for Pantech A810S and replaced it recovery to ours, flashed(connect working Element to PC and start cwm.but), everything works.

Actually it's similar steps; however, yours is more like 1-click root
Anyway, I tried everything all above, but it didn't solve my problem, then I found the solution from other website
I just want to share in case others are stuck in fastboot mode like me:

1. When your tablet screen is on fastboot mode (white), go to device manager on your pc
2. Right click on Android > Update driver
3. Click on Browse driver
4. Choose Let me pick manually from my pc list
5. Choose Android phone and pick the first list there. It should be "Android ADB..."
6. Install and fastboot continued

if you can't find Android ADB from your pc list, then you should unplug device then install PC Suite.
here's the old tuts: youtube com/watch?v=UHRonVzBMsI

Hopefully it helps others and thank you very much for all your help!
15th May 2013, 11:52 PM |#16  
Junior Member
Thanks Meter: 0
 
More
Delete!
7th June 2013, 11:58 PM |#17  
Junior Member
Thanks Meter: 4
 
More
Finally! and a question
Finally a recovery for the element! Rhanks to the OP. Now I am less afraid to tinker with my tablet.

Question: The most important thing right now that I'd like to do is move the folder /data/data from the internal storage, to the internal SD card. This is stopping me from using Google Magazines and Google music, since their data is being stored there, and it shares space with actual applications. 1GB is not that much space for APPS, Dalvik Cache and APPs' data when you add magazines, and when google starts caching Music and Chrome data there. I currently only have 300MB left before I install Music and magazines. And that is AFTER I've used app2sd on all apps that can be moved. How do I do this?

I have tried simply creating a Link using "ln - s /mnt/sdcard/data /data/data" once I copied/moved the contents of the directory, which sort of works initially, but it will not work after a reboot. It actually stops my tablet from booting. (again, thanks to the OP for the recovery).

right now, I am just doing an "ln" on the specific folder inside the /data/data folder, but it acts weird when I use Titanium Backup to restore data


-> Android noob <-
27th November 2013, 08:27 PM |#18  
ALD3's Avatar
Senior Member
Flag OC, Florida
Thanks Meter: 155
 
More
Installing TWRP went smooth as silk. With twrprecovery.zip on you micro sdcard and Element connected with usb cable and USB debuuging checked 1.Just copy twrprecovery.img into your sdk folder/ platform-tools and also have a copy of cmd.exe from windows in the platform-tools folder. 2. Start cmd.exe and type or copy & paste command reboot bootloader 3. Then on white screen(fastboot) type or paste command fastboot boot twrprecovery.img 4. When you boot into TWRP install twrprecovery.zip.....As you rebbot system TWRP should ask if you want Supersu installed and swipe to install. Once rebooted install supersu from the Play store and open Supersu to update SU file all should be good

Thanks for the info and files. I know I'm a little late on this Tablet but picked it up cheap and with ATT 4G it goes along with my devices. The orginial owner hadn't even installed ICS and she wasn't even aware of an update. She now owns an Apple device LOL
4th February 2014, 04:51 PM |#19  
marcustaz's Avatar
Senior Member
Thanks Meter: 177
 
More
I just picked one up for $90 bucks off ebay. It was on slickdeals .net

Figured i'd use it around the pool and save my phone!

No one has deved a JB rom though Could KK even be possible?
4th February 2014, 08:32 PM |#20  
ALD3's Avatar
Senior Member
Flag OC, Florida
Thanks Meter: 155
 
More
Quote:
Originally Posted by marcustaz

I just picked one up for $90 bucks off ebay. It was on slickdeals .net

Figured i'd use it around the pool and save my phone!

No one has deved a JB rom though Could KK even be possible?

Yes good deal, got mine last month on Craigslist for $70.00 and works really well. The owner hadn't even updated to 4.0 or even knew how. It is a good tablet and have rooted it. I think its development is pretty well dead as not many sold. Only thing bad about it is the Element reads 2nd partition instead of 1st as most android devices do, so harder to use link2sd or folder mount as they both use 2nd partition.

Sent from my PantechP4100 using XDA Premium 4 mobile app
23rd December 2014, 07:46 PM |#21  
Junior Member
Thanks Meter: 3
 
More
Hi, does anyone have original files in the OP? The links go nowhere right now. Thanks in advance.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes