Remove All Ads from XDA

For those with 'partial' root after JB update - regain root!

162 posts
Thanks Meter: 61
By thenrz, Senior Member on 29th September 2012, 09:53 AM
Post Reply Email Thread
23rd October 2012, 08:10 PM |#91  
Senior Member
Thanks Meter: 50
hmmmmmm very interesting. I had the exact same problem with the constant reboots and had to wipe. Thought I was SOL for my root for awhile.

Don't understand most of this process, but guess its a good time to learn!
24th October 2012, 06:45 PM |#92  
Senior Member
Flag Ypsi
Thanks Meter: 43
Is there no one here who has any suggestions for me? I'm desperate here, folks. I really don't want to lose the data and pictures I have on the thing by doing a wipe. I've already posted my situation in the Prime Q&A thread, with no replies. I'm begging the community here for help. Please, y'all, any help would be more than appreciated.

Originally Posted by scooter1979

I was rooted using ViperMod. I took the JB OTA, thinking rootkeeper would work. Wound up with the partial root issue (some apps worked, i.e. Anti, Network Spoofer, Root Explorer, but root checker and the Linux Installer for Backtrack gave no root errors), so I tried the method in the OP.

I got through step 3. Step 4 gave me a permission denied error, so I used Root Explorer to turn on all permissions for /data/local/tmp. At that point, adb push claimed to have worked through step 6, but I noticed my Prime had frozen. Before I went any further, I decided to hard reboot (hold down power button), to be sure everything was running proper before I started in with shell commands.

Upon reboot, it now sticks at the initial splash screen. I can vol-down & get to the bootloader there, giving me the 4 standard options. Recovery gives me the dead-looking Andy with exclamation mark (I assume because I don't have a backup image, which yes, I know, was stupid not to have. Hindsight.). The OS option says it's starting from a cold boot, but freezes there and does nothing else. I can access fastboot, and at least the reboot command seems to work, but I haven't tried anything else, as I'm not familiar with fastboot, and have no idea where to go from there. I'm hoping against hope I don't have to use the wipe action, as I have a lot of time and data invested in the thing.

I'm also able to vol-up and have APX recognized on my Win7 machine, but I admittedly have no idea what to do with that.

If anyone could help me here, especially if it would include NOT wiping my Prime, I would be forever grateful. Thank you in advance for any advice.

25th October 2012, 10:49 AM |#93  
Thanks Meter: 3
I installed SuperSU before the jb update and still got partial root in some apps (i could not su in terminal but tb and others kept root).
Then i noticed i could no longer turn on bluetooth :-\ i tried the regain root as the OP and i got full root back.
After securing the su binary i did a factory reset hoping bluetooth would start working but no dice :'( still rooted but same problem..

Anyone else got this after the upgrade and/or got a solution?

Sent from my Transformer Prime TF201
31st October 2012, 06:33 PM |#94  
lukcinek's Avatar
Senior Member
Thanks Meter: 9
Before this solution I have working su command in adb. After I dont have root and su command in adb doesnt work I have every file in good directories but it esnt work

Wysyłane z mojego Transformer Prime TF201 za pomocą Tapatalk 2

---------- Post added at 05:33 PM ---------- Previous post was at 04:46 PM ----------

Pls help me. Before it was partial root. Adblock work for me. Su command in adb works. I do everything like instruction from first page said. I have su-backup from ota rootkeeper on my sdcard. Su in /system/bin busybox in /system/bin and /xbin and two peruser.apk in /system/app. Pls sameone help me

Wysyłane z mojego Transformer Prime TF201 za pomocą Tapatalk 2
8th November 2012, 06:33 PM |#95  
copc's Avatar
Senior Member
Flag Orange County, CA
Thanks Meter: 163
Thanks to the OP, this thread should be a sticky...

I had upgraded from ICS rooted to JB when it was fisrt released, JB was then running rooted and I was all happy. My TFP has been running great, but after reading all those posts about a fresh wipe and how fast it was I decided to give it a shot. Mind you it was running fine before the wipe, I just wanted to see if there was any difference. So I backed up everything on titanium and such, Wiped it, and ran the OTA voodoo rootkeeper and I lost root? I was pissed at my self and I need root to use my TFP at work with our ISA proxy.

So I read this post and gave it a shot, 20min later I was again rooted on a freshly wiped JB. Man I am even ahppoer with JB, I thought it was quick before, now it flys!!!

Thanks again OP and a mod should really sticky this, Hint Hint...

Originally Posted by thenrz

This will only work if you can access a root prompt (#) in adb shell! THIS WAS DONE AFTER DOING A WIPE FROM THE VOLUME DOWN MENU WHEN BOOTING THE PRIME! I do not know if this will work without the wipe, but it very well may. Maybe someone more knowledgeable can chime in here.

It may be possible to restore from a su-backup if you have a su binary still in /system/bin or xbin. Even if you can't access a root prompt (#) by just typing su, read starting at page 6. Places to look for a su-backup include /system/ /system/usr/we-need-root/ and /system/bin/

I have a batch script in the works that will determine if you can re-root and take the appropriate steps to do so if possible.

I had to do a voldown wipe after my update to JB. My prime would reboot after 5-10 seconds into the homescreen after boot. After wiping, I thought for sure my root was screwed until a new exploit was found.

I accessed my device through adb, and realized that I could invoke a root prompt using the su command at the $ prompt. Using ES file explorer, I could see su in /system/bin/ but no su-backup or superuser.apk in /system/app/.

I tried simply installing superuser from the market, but it did not work. The busybox installer would not work, either.

ATTACHED ARE THE EXACT THREE FILES I USED. I do not know if using different version will affect the process!

Here is what worked for me:

1. adb shell
2. su
(# - you should see this now! This will not work without this specific prompt!)
3. type 'exit' press enter, and then 'exit' again. You will now be back at the regular command prompt.
4. adb push C:\(location of attached files)\superuser.apk /data/local/tmp
5. adb push C:\(location of attached files)\su /data/local/tmp
6. adb push C:\(location of attached files)\busybox /data/local/tmp
7. Access the adb shell again, and type su
8. chmod 644 /data/local/tmp/superuser.apk
9. chmod 755 /data/local/tmp/busybox
10. chmod 6755 /data/local/tmp/su
11. mount -o remount,rw /system
12. dd if=/data/local/tmp/Superuser.apk of=/system/app/Superuser.apk
13. dd if=/data/local/tmp/busybox of=/system/bin/busybox
14. dd if=/data/local/tmp/busybox of=/system/xbin/busybox
14a. Chmod 755 /system/bin/busybox
14b. Chmod 755 /system/xbin/busybox
15. Reserved
16. busybox rm /system/bin/su
17. busybox cp /data/local/tmp/su /system/bin
18. type su once again to assure you still have access to the # prompt
18a. Chmod 644 /system/app/superuser.apk
18b. mount -o remount,ro /system
19. type exit, and exit again, returning to the regular windows command prompt.
20. type 'adb reboot' (without quotes)
NOTE - you will not need to install the superuser.apk app in the normal sense. It will be installed upon the reboot as a system app automatically!
21. Once your prime has rebooted, go download root checker basic or the like from the play store. Open it, and wait for your superuser prompt!
22. Get the busybox installer from the play store as well, and use that to get the newest version of busybox.
23. Get SuperSU from the market. It seems to be the safest method to keep root with JB...

ALSO! Make sure to keep a backup root with voodoo or super su after completing this guide! I have lost root (VERY WELL may have been my own fault... too much poking around) Anyway, better safe than sorry!!!

Thanks to daymz from the debugfs thread in development for the basic instructions of what needed to be done!! And also thanks to all before me who got us root in the first place!

I will answer questions to the best of my ability. I am not a developer and do not try to present myself as so... I can tinker with the best, and after losing root, I set out to see if I could figure it out!

Changes made as per tsmt971

20th November 2012, 09:51 PM |#96  
Junior Member
Flag Plymouth
Thanks Meter: 0
Hi all.

Been reading through the thread and been unable to get root. I think the reason is because, although I had root and an unlocked bootloader on ICS I couldn't get the OTA update to JB. I had to do it manually. When I did I did a full wipe and install. Although I did run Rootkeeper before wiping on installing the JB Stock Rom and loading the RootKeeper app it gave no options to update. I stupidly (with hindsight) thought it would perform the back up in the cloud, clearly it must have done it locally, on my Prime, which I then wiped. Doh!

So, I 've accepted I won't get root on my JB install.

However, the reason I want to root is to install a custom ROM. So, my question is can I do a full wipe and install the ICS Stock ROM, root that and then simply install a JB Custom ROM. Or will this not work??

Many thanks in advance.
23rd November 2012, 11:34 AM |#97  
Junior Member
Thanks Meter: 1
Thumbs up
I'd like to thank everybody on this thread
When I initially upgraded my rooted (but stock) Prime to JB I lost Root, the guide on page 1 got root back.
I have now upgraded to the new JB released this week, I lost root again, and regained it, again using the guide on page 1.
The initial JB upgrade was easier as I just followed the guide changing s for S and C for c where required. I had the # after typing su in an adb shell.
This recent upgrade (update) was a little more long winded, I did not have the # prompt. I did however have a su-backup in the /system/usr/we-need-root/ folder. I got the # prompt and re-rooted.

Thanks guys
23rd November 2012, 03:10 PM |#98  
Senior Member
Thanks Meter: 15
How do you know if you have partial root? Rootkeeper has everything ticked by Adaway kept quitting because it couldn't get SU permission and a Root checker from the market says I don't have root. I take it this method should work for me then?

24th November 2012, 10:29 AM |#99  
Flag groningen
Thanks Meter: 3
Originally Posted by scooter1979

Is there no one here who has any suggestions for me? I'm desperate here, folks. I really don't want to lose the data and pictures I have on the thing by doing a wipe. I've already posted my situation in the Prime Q&A thread, with no replies. I'm begging the community here for help. Please, y'all, any help would be more than appreciated.

are you on unlocked bootloader? then you could use urkel's_fresh_start_1.0 choose the fresh root you will loose nothing but gain root. it worked for me. i am on stock jb unlocked bootloader and rooted again in 10 min. and did not loose anythink. only had to install busybox again
27th November 2012, 04:47 AM |#100  
Thanks Meter: 3
Thankyouthankyouthankyouthankyouthankyou!!! I did a data wipe on my Prime today, I have a Voodoo root backup but my root was still borked. Your guide worked perfectly!
30th November 2012, 01:13 PM |#101  
brainimpact's Avatar
Senior Member
Thanks Meter: 121
damn looks like I'll be unlocking bootloader just hope i'm not one of the unlucky people who cant get asus tool to work
Post Reply Subscribe to Thread

prime, restore root, root, tf201

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes