FORUMS
Remove All Ads from XDA

[APP][1.6+] Link2SD

354 posts
Thanks Meter: 931
 
By bakpinar, Inactive Recognized Developer on 18th January 2011, 09:11 PM
Post Reply Email Thread
27th January 2011, 09:51 AM |#101  
cuks's Avatar
Senior Member
Thanks Meter: 36
 
Donate to Me
More
Quote:
Originally Posted by sur1k

Secondly (mainly), is there a way to copy ext2 partition to a new sdcard? Or is it the best way to backup all linked apps with Titanium and then restore them one after another and link manually again?

i used gparted live cd to copy/clone sd card.

you should plug in both of cards (old and new one) into your pc, boot from gparted live cd and then just copy/clone partitions from one to another card.

EDIT: or you can do it on your pc directly if you have installed any linux os with gparted app.
The Following User Says Thank You to cuks For This Useful Post: [ View ] Gift cuks Ad-Free
 
 
27th January 2011, 10:00 AM |#102  
OP Inactive Recognized Developer
Istanbul
Thanks Meter: 931
 
More
Quote:
Originally Posted by anotherloony

Hi
I am trying to use link2sd on Optimus One.
I have ext2 partition not found message. It does not ask for su.
I created /data/sdext2 folder and after I mount my ext2 with this command
# mount -t ext2 /dev/block/mmcblk0p2 /data/sdext2
After that, Link2sd detect my ext2 partition but I have to mount it after every reboot. Maybe this will help you to extend rom support.

Thank you for your great work.

Thanks.

Which version of Link2SD are you using?
The Following User Says Thank You to bakpinar For This Useful Post: [ View ] Gift bakpinar Ad-Free
27th January 2011, 10:24 AM |#103  
Member
Flag Bucharest
Thanks Meter: 7
 
More
Same problem with 1.0.6 and 1.0.7
27th January 2011, 10:41 AM |#104  
OP Inactive Recognized Developer
Istanbul
Thanks Meter: 931
 
More
Quote:
Originally Posted by anotherloony

Same problem with 1.0.6 and 1.0.7

Can you provide outputs of the following commands?

ls -l /dev/block/vold

mount
27th January 2011, 11:09 AM |#105  
Member
Flag Sydney
Thanks Meter: 0
 
More
Hi,

Here is the log you requested. The device is ZTE v9 (optus version).

Thanks heaps !!
Attached Files
File Type: txt adb logcat link2sd.txt - [Click for QR Code] (12.3 KB, 669 views)
27th January 2011, 11:15 AM |#106  
Member
Flag Sydney
Thanks Meter: 0
 
More
Post
Quote:
Originally Posted by bakpinar

Can you provide outputs of the following commands?

ls -l /dev/block/vold

mount

Hope this helps:

$ ls -l /dev/block/vold
ls -l /dev/block/vold
brw-rw---- root root 179, 2 2011-01-26 18:29 179:2
brw-rw---- root root 179, 1 2011-01-26 18:29 179:1
brw-rw---- root root 179, 0 2011-01-26 18:29 179:0
$ mount
mount
rootfs / rootfs rw 0 0
tmpfs /dev tmpfs rw,mode=755 0 0
devpts /dev/pts devpts rw,mode=600 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
/dev/block/mtdblock5 /system yaffs2 rw 0 0
/dev/block/mtdblock6 /data yaffs2 rw,nosuid,nodev 0 0
/dev/block/mtdblock8 /persist yaffs2 rw,nosuid,nodev 0 0
tmpfs /sqlite_stmt_journals tmpfs rw,size=4096k 0 0
/dev/block/mtdblock4 /cache yaffs2 rw,nosuid,nodev 0 0
/dev/block//vold/179:2 /data/sdext2 ext2 rw,errors=continue 0 0
/dev/block//vold/179:1 /sdcard vfat rw,dirsync,nosuid,nodev,noexec,uid=1000,gid=
1015,fmask=0702,dmask=0702,allow_utime=0020,codepa ge=cp437,iocharset=iso8859-1,s
hortname=mixed,utf8 0 0
$



Thanks,

SrMoure
27th January 2011, 11:53 AM |#107  
OP Inactive Recognized Developer
Istanbul
Thanks Meter: 931
 
More
Quote:
Originally Posted by SrMoure

Hi,

Here is the log you requested. The device is ZTE v9 (optus version).

Thanks heaps !!

Thank you, I'll fix in next release.
The Following User Says Thank You to bakpinar For This Useful Post: [ View ] Gift bakpinar Ad-Free
27th January 2011, 12:04 PM |#108  
OP Inactive Recognized Developer
Istanbul
Thanks Meter: 931
 
More
Quote:
Originally Posted by SrMoure

Hope this helps:
/dev/block//vold/179:2 /data/sdext2 ext2 rw,errors=continue 0 0

You said you mounted ext2 with this command
mount -t ext2 /dev/block/mmcblk0p2 /data/sdext2

But it is mounted as
/dev/block//vold/179:2 /data/sdext2 ext2 rw,errors=continue 0 0

This is the way Link2SD mounts ext2 and seems ok.

Do you still get "ext2 not found" message when you open Link2SD?
27th January 2011, 12:58 PM |#109  
Member
Flag Sydney
Thanks Meter: 0
 
More
Quote:
Originally Posted by bakpinar

You said you mounted ext2 with this command
mount -t ext2 /dev/block/mmcblk0p2 /data/sdext2

But it is mounted as
/dev/block//vold/179:2 /data/sdext2 ext2 rw,errors=continue 0 0

This is the way Link2SD mounts ext2 and seems ok.

Do you still get "ext2 not found" message when you open Link2SD?

Before the FC message I can see in the back the message "ext2 mount found"
27th January 2011, 01:13 PM |#110  
subham964's Avatar
Member
Flag Siliguri
Thanks Meter: 17
 
More
Quote:
Originally Posted by SrMoure

Before the FC message I can see in the back the message "ext2 mount found"

Hey can u suggest me a way to directly install apps to sdcard without first installing it to internal memory and den moving it to the ext2 partition.
27th January 2011, 01:17 PM |#111  
Member
Flag Sydney
Thanks Meter: 0
 
More
Talking
Quote:
Originally Posted by subham964

Hey can u suggest me a way to directly install apps to sdcard without first installing it to internal memory and den moving it to the ext2 partition.

Android 2.2
Post Reply Subscribe to Thread

Tags
link2sd, link2sd issues

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes