FORUMS
Remove All Ads from XDA

Sony Ericsson MBW-150 OLED repairs

488 posts
Thanks Meter: 52
 
By netstat_EVO, Senior Member on 29th March 2011, 06:28 PM
Post Reply Email Thread
6th April 2011, 12:46 PM |#21  
netstat_EVO's Avatar
OP Senior Member
Thanks Meter: 52
 
Donate to Me
More
Still waiting for the displays I ordered to get here. I hate when things that say they will take 4-8 weeks actually seem like they are going to take that long lol

Apparently it is being handled as a 1-off order and they are actually being made per my order. Seems kind of stupid to me, but it is what it is. I can't believe they don't have two displays sitting in a warehouse somewhere.

Edit: Just went and checked my order status (not like I was expecting any change), it's still listed as "Processing". But today makes one week since the order was accepted... Only one week, it feels like 3 birthdays have already gone by... This is going to be the longest 4-8 weeks of my life.
18th April 2011, 01:40 PM |#22  
netstat_EVO's Avatar
OP Senior Member
Thanks Meter: 52
 
Donate to Me
More
Unconventional Update:

There is no update...

Display order is still showing as "Processing".

So I guess the update is that the project hasn't gone dead, I just can't do anything without parts lol
24th April 2011, 03:04 AM |#23  
netstat_EVO's Avatar
OP Senior Member
Thanks Meter: 52
 
Donate to Me
More
Just checked my order status for the displays.

Status is changed to SHIPPED

Now I don't know if that is "shipped from china to US distribution center" or "shipped to me" but either way, they should he here soon
25th April 2011, 10:22 PM |#24  
Senior Member
Thanks Meter: 141
 
More
I am on the same boat too. In the past month the screen of my MBW-150 exec (white one) had dimmed to a degree it is only readable in rather dark environment, certainly invisible in daylight..
I am going on the wait list too here! Looking forward for good news!
29th April 2011, 02:13 AM |#25  
Senior Member
Flag Secret
Thanks Meter: 39
 
More
MBW-100
I have an MBW-100 that suffers from No Display (Went from Dim to gone) and would be keen to try out one of these. Its been sitting in a box in my room for like a year so might be a fun project!

Did you have issues with ordering just a couple?
1st May 2011, 01:59 PM |#26  
netstat_EVO's Avatar
OP Senior Member
Thanks Meter: 52
 
Donate to Me
More
Quote:
Originally Posted by slipudatung

I have an MBW-100 that suffers from No Display (Went from Dim to gone) and would be keen to try out one of these. Its been sitting in a box in my room for like a year so might be a fun project!

Did you have issues with ordering just a couple?

other than the fact that it took forever (received Friday) no.

I have to find a watch shop to help me out with one of the last steps of disassembly. I am scared to pull the hands off the watch face, and it has to happen. I'd rather pay someone $10 to do it than break it myself...

more updates to come over the next week.
4th May 2011, 01:19 PM |#27  
BOTICSELLI's Avatar
Junior Member
Flag BUDAPEST
Thanks Meter: 1
 
More
Hello there!
I'm from Hungary, and I have exactly the same problem with my MBW-150 Classic.
If this project will working to you, I will order 2 yellow display...

Any news?
How it's going?
6th May 2011, 01:08 AM |#28  
Junior Member
Vancouver
Thanks Meter: 0
 
More
Great to hear you are progressing netstat_EVO. Count me in on the 'watching with keen interest list'. I can still see my LCD but only in medium to dim light.

Thanks for your efforts!
6th May 2011, 10:04 AM |#29  
CyberDemonVZ's Avatar
Senior Member
Flag Varazdin
Thanks Meter: 2
 
More
Hi!
I will get MBW-150 in few days, and I am reading on XDA to find everything about it
I've found your thread, and I am waiting to see if this will be solution for dim LCD

But then I saw you wrote this:

Quote:
Originally Posted by netstat_EVO

From what I have read, there seems to be two major issues with these watches that are deal breakers for most people, as SE won't repair/replace your device unless it is still under warranty (kind of hard to do since they are out of production).
1) Battery issues. Status: solved, thanks to XDA members
2) Fading/dead OLED display. Status: doesn't appear that anyone has tackled this problem yet.

What is the battery issue? And where is the solution?

Thank you in advance
6th May 2011, 10:01 PM |#30  
Junior Member
Flag St. Albans
Thanks Meter: 3
 
More
Hi

Just as a bit of background info re OLED in general:

I asked a guy I know who designs visual based stuff for a very high profile 'solutions' company, and his remark was that the issue with OLED displays is that they are killed by air getting into them. This is true of all OLED's and is the main reason there are no really large panels (TV's) at present as no manufacturer has managed to produce one that excludes air over a long period of time - all the current glass types leak a very small amount. As air gets in the panels gradually dim until Nada.

Not of any real help for you guys, but now you know why....
The Following User Says Thank You to zaphodbb1 For This Useful Post: [ View ] Gift zaphodbb1 Ad-Free
8th May 2011, 05:38 PM |#31  
netstat_EVO's Avatar
OP Senior Member
Thanks Meter: 52
 
Donate to Me
More
To the guy with the battery question. Just Google search for mbw-150 battery. Replacements are now readily available thanks to xda members.

Moisture is also a leading killer of oled displays. I think our problem is that Sony didn't seal these units as well as they should have.

To everyone else, been busy with work lately, getting the hands removed soon to continue this project. Just gotta find time to get to a shop.

Sent from my HTC Evo 4G using Tapatalk
Post Reply Subscribe to Thread

Tags
mbw-150, oled, sony sucks

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes