FORUMS
Remove All Ads from XDA

[TOOL/ST18] [UPDATE 07/01/2013] Flashtool version 0.9.10.0 - Windows / Linux / Mac

1,095 posts
Thanks Meter: 2,844
 
Post Reply Email Thread
4th January 2012, 10:52 PM |#11  
Member
Flag Colima
Thanks Meter: 30
 
More
Exclamation Root Xperia Ray ST18a
Hello,

I have an Xperia Ray ST18a , and tried to root it with this tool, but the application doesn't recognize the phone. I already made sure the phone is in the correct mode (MSC) and installed the phone model drivers that are in /Flashtool/Drivers/ ... but still says "Device connected with USB debugging off" .

Could be that this tool is only compatible with ST18i and not with ST18a?

Please help. Thank you!
 
 
5th January 2012, 06:33 AM |#12  
OP Recognized Developer
Flag Paris
Thanks Meter: 2,844
 
Donate to Me
More
What version are you using ?
The Following 2 Users Say Thank You to Androxyde For This Useful Post: [ View ]
5th January 2012, 05:29 PM |#13  
Member
Flag Colima
Thanks Meter: 30
 
More
tried with both

Flashtool 0.6.4.0 - Windows and
Flashtool 0.6.5.0 - Windows

In different computers, ...same results.



05/028/2012 11:28:15 - INFO - <- This level is successfully initialized
05/028/2012 11:28:15 - INFO - Flashtool Version 0.6.5 built on 2012-01-04 19:11:08
05/028/2012 11:28:23 - INFO - Device connected with USB debugging off
05/028/2012 11:28:23 - INFO - For 2011 devices line, be sure you are not in MTP mode
5th January 2012, 06:12 PM |#14  
OP Recognized Developer
Flag Paris
Thanks Meter: 2,844
 
Donate to Me
More
And when you go to help check drivers what is the result ?

Envoyé depuis mon X10i avec Tapatalk
The Following User Says Thank You to Androxyde For This Useful Post: [ View ]
5th January 2012, 09:10 PM |#15  
Member
Flag Colima
Thanks Meter: 30
 
More
05/009/2012 14:09:15 - INFO - List of connected devices (Device Id) :
05/009/2012 14:09:15 - INFO - - USB\VID_0FCE&PID_E161\43423531315642464C54 Driver installed : true
05/009/2012 14:09:15 - INFO - List of ADB devices :
05/009/2012 14:09:15 - INFO - - none
05/009/2012 14:09:15 - INFO - List of fastboot devices :
05/009/2012 14:09:15 - INFO - - none


But this is weird as I already installed all drivers in \Flashtool\drivers\Flashtool-drivers

Thanks so much for the help!.

---------- Post added at 03:10 PM ---------- Previous post was at 02:11 PM ----------

Ok found the problem. Was missing this first step:

enable "USB DEBUGGING" from Menu -> Settings -> Applications -> Development
enable "UNKNOWN SOURCES" from Menu -> Settings -> Applications
set Connectivity mode to MSC from Menu -> Sony Ericsson -> Connectivity -> USB Connection Mode

Added the other two steps so can be helpful for anyone else having issues, make sure all of above is set prior to trying this tool to root the phone.


Thanks so much for the help!
The Following User Says Thank You to GiBraiNe For This Useful Post: [ View ] Gift GiBraiNe Ad-Free
5th January 2012, 09:26 PM |#16  
OP Recognized Developer
Flag Paris
Thanks Meter: 2,844
 
Donate to Me
More
Quote:
Originally Posted by GiBraiNe

05/009/2012 14:09:15 - INFO - List of connected devices (Device Id) :
05/009/2012 14:09:15 - INFO - - USB\VID_0FCE&PID_E161\43423531315642464C54 Driver installed : true
05/009/2012 14:09:15 - INFO - List of ADB devices :
05/009/2012 14:09:15 - INFO - - none
05/009/2012 14:09:15 - INFO - List of fastboot devices :
05/009/2012 14:09:15 - INFO - - none


But this is weird as I already installed all drivers in \Flashtool\drivers\Flashtool-drivers

Thanks so much for the help!.

---------- Post added at 03:10 PM ---------- Previous post was at 02:11 PM ----------

Ok found the problem. Was missing this first step:

enable "USB DEBUGGING" from Menu -> Settings -> Applications -> Development
enable "UNKNOWN SOURCES" from Menu -> Settings -> Applications
set Connectivity mode to MSC from Menu -> Sony Ericsson -> Connectivity -> USB Connection Mode

Added the other two steps so can be helpful for anyone else having issues, make sure all of above is set prior to trying this tool to root the phone.


Thanks so much for the help!

Hehe Flashtool was not lying so ;) USB Debug was not ON
7th January 2012, 03:14 PM |#17  
Senior Member
nowhere?
Thanks Meter: 44
 
More
Question confused
now which tool should I use to install recovery on my Ray(.368),
Flashtool or SE Extreme Tweak Installer v1.8 by quangnhut123?
9th January 2012, 04:11 PM |#18  
Junior Member
Thanks Meter: 0
 
More
Hi i get this when flashing and am stuck to the connect device menu but i have connected my phone

09/059/2012 17:59:30 - INFO - <- This level is successfully initialized
09/059/2012 17:59:30 - INFO - Flashtool Version 0.6.5 built on 2012-01-04 19:11:08
09/059/2012 17:59:35 - INFO - Device connected with USB debugging on
09/059/2012 17:59:35 - INFO - Connected device : ST18
09/059/2012 17:59:35 - INFO - Installed version of busybox : BusyBox v1.19.3-cm7 bionic (2011-11-14 16:52 +0100) multi-call binary.
09/059/2012 17:59:35 - INFO - Android version : 2.3.7 / kernel version : 2.6.32.9-FXP
09/059/2012 17:59:35 - INFO - Root Access Allowed
09/059/2012 17:59:46 - INFO - Selected ST18i_4.0.2.A.0.42_(Central-Europe).ftf
09/059/2012 17:59:46 - INFO - Preparing files for flashing
09/000/2012 18:00:06 - INFO - Please connect your device into flashmode.
09/000/2012 18:00:10 - INFO - Device disconnected
09/000/2012 18:00:39 - INFO - Device connected in fastboot mode
9th January 2012, 04:25 PM |#19  
OP Recognized Developer
Flag Paris
Thanks Meter: 2,844
 
Donate to Me
More
Quote:
Originally Posted by theuri

Hi i get this when flashing and am stuck to the connect device menu but i have connected my phone

09/059/2012 17:59:30 - INFO - <- This level is successfully initialized
09/059/2012 17:59:30 - INFO - Flashtool Version 0.6.5 built on 2012-01-04 19:11:08
09/059/2012 17:59:35 - INFO - Device connected with USB debugging on
09/059/2012 17:59:35 - INFO - Connected device : ST18
09/059/2012 17:59:35 - INFO - Installed version of busybox : BusyBox v1.19.3-cm7 bionic (2011-11-14 16:52 +0100) multi-call binary.
09/059/2012 17:59:35 - INFO - Android version : 2.3.7 / kernel version : 2.6.32.9-FXP
09/059/2012 17:59:35 - INFO - Root Access Allowed
09/059/2012 17:59:46 - INFO - Selected ST18i_4.0.2.A.0.42_(Central-Europe).ftf
09/059/2012 17:59:46 - INFO - Preparing files for flashing
09/000/2012 18:00:06 - INFO - Please connect your device into flashmode.
09/000/2012 18:00:10 - INFO - Device disconnected
09/000/2012 18:00:39 - INFO - Device connected in fastboot mode

you are connected in fastboot mode while flashtool waits for the device to be in flashmode.
connect it in the right mode
9th January 2012, 04:53 PM |#20  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Androxyde

you are connected in fastboot mode while flashtool waits for the device to be in flashmode.
connect it in the right mode

how do i connect to flashmode
i switched off my phone and pressed the vol. up button while plugging it into the usb port
9th January 2012, 04:59 PM |#21  
OP Recognized Developer
Flag Paris
Thanks Meter: 2,844
 
Donate to Me
More
Quote:
Originally Posted by theuri

how do i connect to flashmode
i switched off my phone and pressed the vol. up button while plugging it into the usb port

I only know the procedure for X10 :) for ST18, I don't know.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes