Remove All Ads from XDA
H10 Turbo
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
I searched and searched and couldn't find anything to help me.

I followed one of the threads to root my S4 on 4.3 MK2. I was in such a rush and tried to install TWRP.... and then I saw the bottom of the post saying you can ONLY use Safestrap.

Long story short, I butchered my recovery and sent it into the ethos. Upon booting into recovery I see the Android robot with a red caution symbol and "no command," and it throws me into android system recovery.

I tried installing SafeStrap and it claims that it can install successfully, but when I reboot it's not there.

So apparently I need to reflash my phone with a clean install of 4.3.

I cannot find a 4.3 ROM for MK2 anywhere. SAMmobile,, Google searches, I can find 4.2.2 roms, but apparently once you're on 4.3 you can't go back to 4.2.2.

How can I fix this? Or do I need to visit one of the guys at the Samsung Experience Shop in my local Best Buy...?
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes