FORUMS
Remove All Ads from XDA

[KK 4.4.2][ROM]Mackay OMNI ROM (27-Feb-2014)

5,294 posts
Thanks Meter: 16,105
 
By kasper_h, Recognized Developer on 15th December 2013, 10:27 AM
Thread Closed Email Thread
26th January 2014, 06:35 PM |#701  
kasper_h's Avatar
OP Recognized Developer
Thanks Meter: 16,105
 
Donate to Me
More
Quote:
Originally Posted by MrOban

I 've attached the different Keyboards in the order Omni english, Omni german, CM english, CM german.
Omni english has all keys with a second function but the colour of the second function ist black on Grey.
Omni german has no second function on the y-m-row.
CM english is like Omni but with light Grey on dark Grey.
CM german has no second function on keys a and s.
I preferred CM-Layout with second fuction on all keys. light Grey on dark Grey is better readable to my old tired eyes than black on Grey. Better would be for me to have the colour of the second function in White, not Grey.

At the Moment I allways replace the Omni-Keyboard with the CM-Keyboard for better readability and to have more keys with second functions.

Clear, will take a good look at this
The Following 2 Users Say Thank You to kasper_h For This Useful Post: [ View ]
 
 
26th January 2014, 06:49 PM |#702  
kasper_h's Avatar
OP Recognized Developer
Thanks Meter: 16,105
 
Donate to Me
More
Fixed the keyboard:
https://github.com/kasperhettinga/an...ts/mackay-omni

The top 2 commits were missing in my LatinIME when I compared it to CM. So I picked those up and now it should be exactly the same
The Following 4 Users Say Thank You to kasper_h For This Useful Post: [ View ]
26th January 2014, 07:23 PM |#703  
MrOban's Avatar
Senior Member
Flag Lohmar
Thanks Meter: 59
 
More
Quote:
Originally Posted by kasper_h

Clear, will take a good look at this

Thanks.
If you really want to change the German layout, please keep in mind, that a and s have to have double function because of the language. A has ä etc. S has ß etc.
On my non rooted S3 I use Kii keyboard, which added @ to a and # to s.

Gesendet von meinem GT-I9300 mit Tapatalk 2

---------- Post added at 08:23 PM ---------- Previous post was at 08:05 PM ----------

Quote:
Originally Posted by kasper_h

Fixed the keyboard:
https://github.com/kasperhettinga/an...ts/mackay-omni

The top 2 commits were missing in my LatinIME when I compared it to CM. So I picked those up and now it should be exactly the same

Thanks, I will have a look at this with your next Omni-release which allows twrp to access the external SD

Gesendet von meinem GT-I9300 mit Tapatalk 2
26th January 2014, 07:43 PM |#704  
Senior Member
Flag Dresden
Thanks Meter: 108
 
More
It's a bit minor, but it doesn't look perfect with it: the open with window. Click image for larger version

Name:	uploadfromtaptalk1390765264735.jpg
Views:	156
Size:	37.8 KB
ID:	2540807

Also concerning double tap status bar, I came from CM Mackay, it worked there, and is nice to spare the power button a bit. Maybe pick it from CM?

No problems with this ROM, Mackay is the best for i9000!

Gesendet von meinem GT-I9000 mit Tapatalk
26th January 2014, 09:01 PM |#705  
kasper_h's Avatar
OP Recognized Developer
Thanks Meter: 16,105
 
Donate to Me
More
There is a new update, as test. Regular location.

-removed dysfunctional stuff (multi-window, KitKat-white ui, double-tap-to-sleep, network speed, and many other minor patches).
-stock omni kernel (hopefully external SD now works in both ROM and recovery) - so also no Mackay Settings.
-updated keyboard as mentioned above.
-improved privacy guard
-additional lockscreen options

Verstuurd van mijn GT-I9000
The Following 4 Users Say Thank You to kasper_h For This Useful Post: [ View ]
26th January 2014, 09:42 PM |#706  
Senior Member
Thanks Meter: 56
 
More
I am having a very strange problem in the past 2 days.
I am getting ALL of my whatsapp messages only once a day at 23:30 local time.
I chack my whatsapp regularly, but I get nothing, and then, at 23:30 I am getting a flood of messages. That is so weird!
Can anyone confirm?
26th January 2014, 10:06 PM |#707  
MrOban's Avatar
Senior Member
Flag Lohmar
Thanks Meter: 59
 
More
@kasper_h keyboard is like the one from cm colour incl. A and s in German layout could have @ and # in addition, but it's OK for me. I don't have to replace it now.
But twrp has no access to external sd-card.

Gesendet von meinem GT-I9300 mit Tapatalk 2
26th January 2014, 10:29 PM |#708  
kasper_h's Avatar
OP Recognized Developer
Thanks Meter: 16,105
 
Donate to Me
More
Quote:
Originally Posted by MrOban

@kasper_h keyboard is like the one from cm colour incl. A and s in German layout could have @ and # in addition, but it's OK for me. I don't have to replace it now.
But twrp has no access to external sd-card.

Gesendet von meinem GT-I9300 mit Tapatalk 2

OK, then the external sd-card is not an issue of my kernel specifically, but it seems to be a more general issue then for the omni kernel + device trees. Will look into it later, but I can't find an easy solution.
26th January 2014, 10:51 PM |#709  
MrOban's Avatar
Senior Member
Flag Lohmar
Thanks Meter: 59
 
More
Quote:
Originally Posted by kasper_h

OK, then the external sd-card is not an issue of my kernel specifically, but it seems to be a more general issue then for the omni kernel + device trees. Will look into it later, but I can't find an easy solution.

The releases before 20140124 worked.
I have an Omni on my Acer tablet A500 too. It's from Thor on tegraowners. This works, but it's no twrp, it's a cwm, I think.
You're sure, it's a kernel issue? I think, it might be a recovery issue.

Gesendet von meinem GT-I9300 mit Tapatalk 2
26th January 2014, 11:40 PM |#710  
Senior Member
Flag Morsang sur Orge
Thanks Meter: 439
 
More
Each time my sgs goes in sleeping, the download speed seems decreasing.
Is that right? And is there something to do to, because I don't like that.
27th January 2014, 05:20 AM |#711  
kasper_h's Avatar
OP Recognized Developer
Thanks Meter: 16,105
 
Donate to Me
More
Quote:
Originally Posted by MrOban

The releases before 20140124 worked.
I have an Omni on my Acer tablet A500 too. It's from Thor on tegraowners. This works, but it's no twrp, it's a cwm, I think.
You're sure, it's a kernel issue? I think, it might be a recovery issue.

Gesendet von meinem GT-I9300 mit Tapatalk 2

Yeah kernel/recovery is one image for our device. The problem is off course in recovery. Anyway, I know that on older releases it does work, but I didn't change anything in recovery in between those builds. I only added the patches to enable external SD in the ROM itself.

Quote:
Originally Posted by hollandais

Each time my sgs goes in sleeping, the download speed seems decreasing.
Is that right? And is there something to do to, because I don't like that.

Known issue, nothing that I know off can solve it.
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes