FORUMS
Remove All Ads from XDA
Honor 7x
Win an Honor 7X!
Post Reply Email Thread
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Update 02/03/2015

This guide I posted is well out of date, there are other methods to follow now days.
Please use http://www.aftvnews.com/tag/guide/ as it is up to date and current.


-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Thanks to AFTVNews.com for the OTA link and rbox for pointing me in the right direction I've successfully manually upgraded to the latest firmware, downgraded back to 51.1.0.2 and am now upgrading back to 51.1.1.0.

This is the process I followed. I take it for granted that you rooted, have SU and Busybox free installed.

Don't blame me if you **** your device up and you have a brick.

So lets get to it:

1. Download which ever firmware you wish to restore to:
Code:
51.1.0.1
http://amzdigitaldownloads.edgesuite.net/obfuscated/e6f65fefb36aaf7b94fd370f516b9c11/bueller-ota-51.1.0.1_user_510055620-signed.bin

51.1.0.2
http://amzdigitaldownloads.edgesuite.net/obfuscated/cec02756d1964c9cb1f71d52056cc81a/bueller-ota-51.1.0.2_user_510058520-signed.bin

51.1.1.0
http://amzdigitaldownloads.edgesuite.net/obfuscated/568eef32595f034b4304e19aa566befb/bueller-ota-51.1.1.0_user_511069920-signed.bin

51.1.1.0 Update 1
http://amzdigitaldownloads.edgesuite.net/obfuscated/4edaba705e98dee475680c33d3f41132/bueller-ota-51.1.1.0_user_511070220-signed.bin
2. Rename which ever one you wish to restore to update.zip

3. adb shell

4. su

5. chmod 777 cache

6. cd cache

7. chmod 777 recovery

8. cd recovery

9. echo --update_package=/cache/update.zip > command

10. ctrl + c

11. adb push update.zip /cache

--- Go make coffee or take a ****....The pushing of 466MB takes forever over wireless.---

An alternative is to copy update.zip to a USB Flash Drive, use StickMount to mount on the FireTV then copy it with the following command:

cp /sdcard/usbStorage/sda1/update.zip /cache

12. adb reboot recovery

Now it should reboot and start installing whatever update you downloaded and called update.zip

If you get the out of space error:

Quote:
Originally Posted by roligov

No it's not because the updates are blocked, it's because you out of space in your cache partition. ADB shell to the box and run
ll /cache
If you have any bin files, delete them.

1. adb shell

2. su

3. rm /cache/*.bin
The Following 14 Users Say Thank You to roligov For This Useful Post: [ View ] Gift roligov Ad-Free
26th June 2014, 09:19 PM |#2  
{ParanoiA}'s Avatar
Senior Member
Flag Ocean View, NJ
Thanks Meter: 175
 
More
Nice
26th June 2014, 09:34 PM |#3  
danknee's Avatar
Senior Member
Flag Las Vegas
Thanks Meter: 20
 
More
Nice work and great news! No reason not to update to the latest version since we can downgrade too.
26th June 2014, 09:44 PM |#4  
Junior Member
Thanks Meter: 2
 
More
Thanks. Should we delete the file after the update to save on the space or is it automatically deleted?
26th June 2014, 09:56 PM |#5  
roligov's Avatar
OP Senior Member
Flag Durban
Thanks Meter: 96
 
More
It automatically gets deleted. It's late this side so I'm going to bed.

Will do some testing tomorrow before I give the go ahead and tell everyone it's all working!
The Following User Says Thank You to roligov For This Useful Post: [ View ] Gift roligov Ad-Free
26th June 2014, 10:04 PM |#6  
Senior Member
Central FL
Thanks Meter: 184
 
More
Wow!! I knew someone would figure it out, just did not think it would be this soon. Thank you for the work!!

One step closer to an unlocked bootloader...
26th June 2014, 10:21 PM |#7  
Senior Member
Thanks Meter: 34
 
More
Super guide, worked like a charm - thank you!
26th June 2014, 11:16 PM |#8  
Junior Member
Thanks Meter: 2
 
More
Good work! Thank-you.
26th June 2014, 11:39 PM |#9  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by zahir32

Super guide, worked like a charm - thank you!

would there be a way to do this via shh
27th June 2014, 12:41 AM |#10  
Senior Member
Thanks Meter: 34
 
More
Getting It Done
Quote:
Originally Posted by bdscds

would there be a way to do this via shh


This method gets it done. I've tried others, but these instructions - and the fact that the OP has kindly prepared the "command" file for us - make it an easy ride. Just put the update zip in the same folder as your ADB setup, open your command window in that folder and adb will find it.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes