FORUMS
Remove All Ads from XDA

[APP] Official ViPER4Android Audio Effects (FX v2.5.0.5) - New Features & 7.0 Support

4,134 posts
Thanks Meter: 14,616
 
By zhuhang, Recognized Contributor on 15th March 2013, 05:42 AM
Post Reply Email Thread
20th March 2015, 09:30 PM |#17561  
Senior Member
Thanks Meter: 44
 
More
Quote:
Originally Posted by mupel

its okay pal, but it looks like the culprit of my problem is not knox after all, thanks anyway

Quote:
Originally Posted by junghyun01

Can't install driver on Xperia Z3 official lollipop 5.0.2
Change to Permissive already still failed!

Sent from my D6603 using XDA Free mobile app

Try to check the following as mentioned in the OP.

"Correctly-installed Busybox is required before installing V4A.

If you see V4A installation pop-up loop, its probably due to incomplete root."

It happens to me earlier when updated to Stock Android 5.1. However, the issue was resolved by doing the following.
1. Clean rom (no other audio mode, remove musicfx/audiofx.apk or similar apk)
2. ensure 100% working root and busy box
3. Set permissive SELinux mode and disable NUplayer
5. ensure enough space in system partition for installing viper
6. install viper4A

Hope it helps.

Viper4A is working great with my device default build.prop.
May be some device may need build.prop tweak.

---------- Post added at 11:23 PM ---------- Previous post was at 11:12 PM ----------

Quote:
Originally Posted by xarunx

guys hi have a small problem

viper shows processing : YES when not running any media apps ,and when i run any media app it shows processing status NO.(tried both normal and compatible even forcing) effects not working

note 3 running lollipop with darkqueen kernel 1.0
can someone guide me??

thanks guys...

edit: everything is yes and audio format suported

Try set permissive SELinux mode and disable NUplayer

---------- Post added at 11:30 PM ---------- Previous post was at 11:23 PM ----------

Quote:
Originally Posted by stew1411

Not sure if this helps, but on lg stock lollipop I was having the same issue as you. Here is what I did.

SE change to permissive, reboot.
Install driver, reboot.
Open V4A and hit menu to change FX compatible mode to compatible, reboot.

I now have viper. Hope this helps.

Im glad you made it works with that simple trick.
The Following User Says Thank You to adf2009 For This Useful Post: [ View ] Gift adf2009 Ad-Free
21st March 2015, 01:57 AM |#17562  
Junior Member
Thanks Meter: 6
 
More
Thanks whoever made Viper4AndroidLP_v2.3.4.0.zip, that finally got it working on my Nexus 6 (stock 5.1 rom).
The official apk was installing fine but always changing from processing: yes to processing: no every time I started music playback.
21st March 2015, 02:28 AM |#17563  
seriosbrad's Avatar
Senior Member
Flag Alberta
Thanks Meter: 230
 
More
Quote:
Originally Posted by Creamy Goodness

Thanks whoever made Viper4AndroidLP_v2.3.4.0.zip, that finally got it working on my Nexus 6 (stock 5.1 rom).
The official apk was installing fine but always changing from processing: yes to processing: no every time I started music playback.

Link to that zip file? I'm having the same issues in CM12.
21st March 2015, 03:18 AM |#17564  
Junior Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by seriosbrad

Link to that zip file? I'm having the same issues in CM12.

It's from somewhere around page 1735, maybe same as from here: http://forum.xda-developers.com/onep...3-4-0-t3040014
Just make sure you take a full backup because these will change your prop files and you can get a boot loop if something is missing. I know it says aosp only on that one but I think it's the same as worked for me. Installs some extra libs but unless you can find some more info on fixing the prop files just try it.
Md5 of the file that worked for me is 3624404da4b66adc6fc6d7846fd0137e
Size is 6,773,750 bytes
21st March 2015, 06:21 AM |#17565  
cyberzone5's Avatar
Senior Member
Flag delhi
Thanks Meter: 27
 
More
Going to try this on CM12 Redmi 1s. Let's see!
21st March 2015, 08:22 AM |#17566  
dj88's Avatar
Senior Member
Flag God's Own city
Thanks Meter: 93
 
More
Unhappy what's wrong with my XT1033(KK)
After installation it gives some error to patch some system files
It patched successfully
But when i open the application music play stop/pause
No effects
:crying:
Recently tried on 5.0.2 but same issue
21st March 2015, 05:19 PM |#17567  
Senior Member
Thanks Meter: 35
 
More
Hi I need help. I don't really get if android 5.1 is supported and if so which zip should I flash in TWRP. Is 2.3.4.0 OK?
Tnx

Sent from my Nexus 5 using XDA Free mobile app
21st March 2015, 05:26 PM |#17568  
commencal661's Avatar
Senior Member
Flag Ljubljana
Thanks Meter: 341
 
Donate to Me
More
Quote:
Originally Posted by lolzas

Hi I need help. I don't really get if android 5.1 is supported and if so which zip should I flash in TWRP. Is 2.3.4.0 OK?
Tnx

Sent from my Nexus 5 using XDA Free mobile app

You didn't read, did ya? You don't flash the zip. You download it, extract the APKs, and install the one that has 4.x in the filename.
21st March 2015, 05:36 PM |#17569  
Senior Member
Thanks Meter: 35
 
More
Thanks I'll try that.. It's not that I didn't read. I couldn't find anything about what you just said and got lost in this huge thread.. I searched 5.1 in search box.. Couldn't find something useful really

Sent from my Nexus 5 using XDA Free mobile app
21st March 2015, 06:12 PM |#17570  
Mentalmuso's Avatar
Recognized Developer
Flag Austin
Thanks Meter: 8,340
 
Donate to Me
More
I have been using Viper4android for ever, and there has always been a small delay before the effects kick in when you skip a song. Mostly noticeable on Spotify. Does anybody have a method to stop this happening?
21st March 2015, 06:21 PM |#17571  
wrongway213's Avatar
Retired Forum Moderator
Flag Canton, OH
Thanks Meter: 8,039
 
Donate to Me
More
@ahrion I've attempted to search for this - apparently 1758 pages is a lot to sift through. I am unable to find this if it has been posted. I am curious if there is a flashable zip for just the audio_policy.conf from the EIA fixwithout the META-inf folder, or bundled with Viper - either would work. On my Nexus 6 it seems flashing the EIA fix totally disables all sound from playing through, even texts and ringtones. However, flashing giantjon's Viper zip breaks auxiliary connectivity, and I have noticed using an audio_policy.conf file from a working ROM, copying and moving, setting permissions and rebooting works to get Viper and aux connectivity working - however, it's a major pain for upgrading multiple ROMs - my guess is this is why the flashable zip exists to begin with. I'm just hoping for a simpler solution I can flash right with my ROM and gapps and V4A, etc on every update, plus for kernel updates lol. If there is a flashable zip of what I am seeking compatible with the Nexus 6, I'd appreciate it if you could send me in the right direction - even on my desktop browser XDA search simply does not like this very heavily trafficked thread (or all that exists is the zip with META-inf, but at least I'll know if so). I appreciate all the work to get V4A working for the XDA community -whether you can help me further or not, your work is what led me to realize audio_policy.conf is what I needed to edit to get aux working again, and for that I am grateful.
The Following User Says Thank You to wrongway213 For This Useful Post: [ View ] Gift wrongway213 Ad-Free
Post Reply Subscribe to Thread

Tags
best settings, convolver, cure tech+, fx xhifi, irs impulse response sample, settings, viper4android v4a, virtual headphone surround engine+

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes