FORUMS
Remove All Ads from XDA

"ADB server didn't ACK" error while trying to access with sdk

22 posts
Thanks Meter: 1
 
By flaav8r, Junior Member on 10th November 2009, 03:18 AM
Post Reply Email Thread
10th November 2009, 05:10 AM |#11  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by simplyphp

The ADB server binds and listen to port 5037. If that port is taken and/or if the daemon is already running, you'll see that error message.

Start task manager and kill adb.exe (all the instances of it).

If that don't work, try rebooting your computer and your phone, and trying again.

If it still don't work, try this:
http://groups.google.com/group/andro...ae5da4a3c80aa8

I'm gonna give it a shot right now.
 
 
10th November 2009, 05:16 AM |#12  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by simplyphp

The ADB server binds and listen to port 5037. If that port is taken and/or if the daemon is already running, you'll see that error message.

Start task manager and kill adb.exe (all the instances of it).

If that don't work, try rebooting your computer and your phone, and trying again.

If it still don't work, try this:
http://groups.google.com/group/andro...ae5da4a3c80aa8

Haha, success. I'm gonna try and root it now.

Thank you so much.
10th November 2009, 05:20 AM |#13  
Senior Member
Thanks Meter: 71
 
More
Quote:
Originally Posted by flaav8r

Haha, success. I'm gonna try and root it now.

Thank you so much.

Np glad to help
10th November 2009, 05:31 AM |#14  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by simplyphp

Np glad to help

Sucussfully rooted, thanks again.
6th January 2011, 07:45 PM |#15  
Junior Member
Thanks Meter: 0
 
More
Sorry for reviving an ancient post, but I just wanted to say that I ran into the same issue and opening up "taskmgr" and killing the active instance of "adb.exe" resolved the issue.
13th May 2011, 01:40 PM |#16  
Junior Member
Thanks Meter: 1
 
More
Just for help :

I had the same issue and it was my Firewall which blocked the starting of deamon.
Turn off your Firewall can fix the problem
The Following User Says Thank You to percuwill For This Useful Post: [ View ] Gift percuwill Ad-Free
7th July 2011, 07:22 PM |#17  
dayze0's Avatar
Senior Member
Thanks Meter: 45
 
More
cheers guys, followed the instructions and flashed rec. radio
29th November 2012, 01:06 PM |#18  
Junior Member
Thanks Meter: 0
 
More
This solved it for me: edit adb_usb.ini
This solved it for me:

Edit ~/.android/adb_usb.ini file to make sure that there is no extra empty line after the 0x0006 line entry


For other users: I also found this:
Quote:

After killing ADB.exe run netstat (just "netstat", no parameters) and
see if port 5037 is opened. It probably will be. Wait a while. Run
netstat again, now there are less connections on the port. After a
port 5037 is no longer opened. Only then it's OK to run ADB again.

Please note that this worked for when I killed the ADB.exe process &
process tree from Sysintenal's Process Explorer.

Also, I still don't know why running ADB again before all connection
are closed led to the port never being freed (albeit netstat didn't
show any open connections anymore). Moreover, the problem that forced
me to kill ADB in the first place needs to be solved and there's
enough on that in the forum.

AsafR.

27th February 2013, 06:54 PM |#19  
Junior Member
Thanks Meter: 8
 
More
Thumbs up Problem is HTC Sync
Quote:
Originally Posted by lucbloom

This solved it for me:

Edit ~/.android/adb_usb.ini file to make sure that there is no extra empty line after the 0x0006 line entry


For other users: I also found this:

HTC Sync Manager has adb.exe at location C:\Program Files\htc\htc sync manager\htc sync\adb.exe

You have 2 options now:-
1) Delete this adb.exe
2) Copy latest adb.exe from android sdk to this path.
Note: You need to make the 2 copies of adb.exe in sync always(when android sdk is updated) else this problem will come up again.
On windows 7, you can make a link of adb.exe from android sdk to this folder, which will avoid copying manually.
C:\> cd "C:\Program Files\htc\htc sync manager\htc sync"
C:\Program Files\htc\htc sync manager\htc sync\> mklink adb.exe C:\<path to your sdk>\platform-tools\adb.exe
The Following User Says Thank You to swinder0161 For This Useful Post: [ View ] Gift swinder0161 Ad-Free
1st June 2013, 04:26 AM |#20  
lil-g-gamegenuis's Avatar
Member
Flag olathe, ks
Thanks Meter: 12
 
More
kill htc sync
nevermind someone already posted
5th June 2013, 12:57 AM |#21  
Junior Member
Thanks Meter: 0
 
More
I know this is old, but just in case... seems that USB3 doesn't always play nice with ADB, so if nothing else helps try a USB2 port...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes