FORUMS
Remove All Ads from XDA

Wifi/Data Disconnecting on Screen Sleep

36 posts
Thanks Meter: 0
 
By Jaden10, Member on 24th April 2010, 05:52 PM
Post Reply Email Thread
When my screen goes to sleep, my Wifi or my data connection stops (whichever one I'm using).

If I'm listening to the radio using Radio Time, the sound stops after the screen sleeps. An interesting thing to note is that if you go to the lock screen, it starts playing again. It seems like the screen just needs to be on. The problem seems to be limited to just certain applications because Pandora still plays after the screen turns off.

Another app, Android Web Desktop, which allows you to text and manage your files from the computer, doesn't work correctly either. Nothing loads while my screen is off but it starts loading once I turn my screen on.

I'm running on a Sprint HTC Hero with DamageControls v2.07.2 ROM for Android 2.1. I also have a Flan lockscreen. I don't know whether the problem is ROM related or what.
Does anybody know why this is happening and how I can fix this?
 
 
24th April 2010, 07:23 PM |#2  
OP Member
Thanks Meter: 0
 
More
Please Help!
24th April 2010, 07:36 PM |#3  
Senior Member
Thanks Meter: 20
 
More
Make sure always on mobile data in settings is checked.

Quote:
Originally Posted by Jaden10

When my screen goes to sleep, my Wifi or my data connection stops (whichever one I'm using).

If I'm listening to the radio using Radio Time, the sound stops after the screen sleeps. An interesting thing to note is that if you go to the lock screen, it starts playing again. It seems like the screen just needs to be on. The problem seems to be limited to just certain applications because Pandora still plays after the screen turns off.

Another app, Android Web Desktop, which allows you to text and manage your files from the computer, doesn't work correctly either. Nothing loads while my screen is off but it starts loading once I turn my screen on.

I'm running on a Sprint HTC Hero with DamageControls v2.07.2 ROM for Android 2.1. I also have a Flan lockscreen. I don't know whether the problem is ROM related or what.
Does anybody know why this is happening and how I can fix this?

24th April 2010, 07:54 PM |#4  
OP Member
Thanks Meter: 0
 
More
I just check the settings and I already had always on checked. Should I just wipe and see if the problem goes away? Am I the only one with this problem?
24th April 2010, 07:59 PM |#5  
Junior Member
Flag Akron, Ohio
Thanks Meter: 1
 
More
check the wifi sleep policy as well.

Settings>Wireless & Networks>Wifi Settings> [press menu] > Advanced >Wifi Sleep Policy

Setting it to never will make the wifi radio never disconnect, at the expense of battery, of course.
The Following User Says Thank You to bcispcpro For This Useful Post: [ View ] Gift bcispcpro Ad-Free
24th April 2010, 07:59 PM |#6  
Junior Member
Thanks Meter: 0
 
More
I have it too, although I sort of assumed it was by design. Makes for a pretty frustrating experience trying to use Gmote or Boxee Remote.
24th April 2010, 08:08 PM |#7  
OP Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by bcispcpro

check the wifi sleep policy as well.

Settings>Wireless & Networks>Wifi Settings> [press menu] > Advanced >Wifi Sleep Policy

Setting it to never will make the wifi radio never disconnect, at the expense of battery, of course.

I'm still having the problem kinda. It seemed to not turn it off as fast. It stopped working after about 30 seconds in Android Desktop and RadioTime kept playing but was very skippy. Are you having this problem? I don't understand why certain app work and certain don't.
24th April 2010, 09:40 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by bcispcpro

check the wifi sleep policy as well.

Settings>Wireless & Networks>Wifi Settings> [press menu] > Advanced >Wifi Sleep Policy

Setting it to never will make the wifi radio never disconnect, at the expense of battery, of course.

For problems with Gmote and Boxee Remote, this fixed my issue.
25th January 2012, 06:03 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by bcispcpro

check the wifi sleep policy as well.

Settings>Wireless & Networks>Wifi Settings> [press menu] > Advanced >Wifi Sleep Policy

Setting it to never will make the wifi radio never disconnect, at the expense of battery, of course.

That was a useful suggestion. To go a bit further on this point. You can turn on/off your wifi (and more) by using applications like timeriffic when you really don't need it. Eg, when you're sleeping. Timeriffic changes some of your profiles based on time so it would be a great option to add to this setting change.
3rd February 2012, 01:26 AM |#10  
Junior Member
Flag Fairland, OK
Thanks Meter: 0
 
More
Quote:
Originally Posted by nam_hee

That was a useful suggestion. To go a bit further on this point. You can turn on/off your wifi (and more) by using applications like timeriffic when you really don't need it. Eg, when you're sleeping. Timeriffic changes some of your profiles based on time so it would be a great option to add to this setting change.

I use Juice Defender to do the same thing and I let it manage my mobile data connection. Helps stretch out the times between charges a little bit despite me using my phone very heavily.
23rd November 2015, 11:57 PM |#11  
Solution , for me :)
http://www.pocketables.com/2013/10/a...over-wifi.html

Turn off WiFi optimization .
Post Reply Subscribe to Thread

Tags
data, disconnecting, locked, sleep, wifi

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes