FORUMS
Remove All Ads from XDA

[FIXED] Remount failed: operation not permitted

91 posts
Thanks Meter: 12
 
By Nextelian, Member on 20th May 2010, 03:11 PM
Post Reply Email Thread
18th December 2011, 09:52 PM |#21  
Member
Thanks Meter: 10
 
More
root commands: Permission denied
Dear Sirs,

I have been through this thread and tried everything but I have the same issue as the previous gentlemen.

I have HTC Desire Z with CM 7.0.3.

When I boot the phone normally and "adb shell", I can get a root prompt (id command shows root user, "cd" shows "/"). But ANY command I run brings permission denied (even ls, chmod and pwd). I literally can't do anything. Same whether I boot with/without S D card. I CAN however issue commands such as "adb pull /init.rc" if I exit and go back to DOS.

However if I boot into clockworkmod recovery and mount /data and /system, and then open an adb shell via USB, I can connect as root and browse everything, everything is fine and all commands work OK. /etc/fstab shows all partitions would be mounted as rw.

So it looks like some application during boot, is resetting the permission for /system to be ro, and also removing root's privileges.

Please could you let us know if there is a method to determine what app is doing this during boot. I cannot see anywhere in init.rc where I can catch this application that is doing this and prevent it from making /system inaccessible after boot.

Preferably if someone could point me to the complete log of the boot process that shows each command that is run, I might have a clue as to where in the boot up process, the /system partition suddenly becomes ro and root loses all permissions.

I suspect the other users in the forum may have a similar problem.

I have attached a copy of my init.rc that was adb pulled after full boot.

Thanks
Attached Files
File Type: txt initrc.txt - [Click for QR Code] (14.7 KB, 798 views)
 
 
19th December 2011, 05:50 AM |#22  
ajrty33's Avatar
Senior Member
Thanks Meter: 339
 
Donate to Me
More
this is the hero forum?

Sent from my HERO200 using XDA App
19th December 2011, 07:08 AM |#23  
Member
Thanks Meter: 10
 
More
Quote:
Originally Posted by ajrty33

this is the hero forum?

Sent from my HERO200 using XDA App

Hi I think the issue I have is the same regardless of what device, its specific to android rather than the hardware. Since its the same as what previous members are seeing, I wanted to ask if someone might be able to help (issue of "permission denied" is the same)...
24th January 2012, 11:41 PM |#24  
Äptiva's Avatar
Senior Member
Flag Louisville, KY
Thanks Meter: 43
 
More
Yeah this is an Android issue. I have a Gingerbreak rooted Cricket LG Optimus C running stock 2.2 Froyo rom (for the most part). While I have uninstalled most of the Cricket preinstalled bloatware, I have followed all instructions as far as using ADB to mount /system as rw with no results. It's the same exact error as everyone else.
The Following User Says Thank You to Äptiva For This Useful Post: [ View ] Gift Äptiva Ad-Free
24th February 2014, 09:46 AM |#25  
Member
Flag Empangeni
Thanks Meter: 6
 
More
Thumbs up I solved it for CM 11
I went to settings on CM 11, developers options and there was a root access menu there, it was set to apps only, set it to apps and ADB
5th February 2016, 01:46 PM |#26  
Junior Member
Thanks Meter: 0
 
More
Tried everything but the last thing worked at last...
Just download the app "adbd Insecure v2.00"
Cheers
14th August 2017, 06:28 PM |#27  
Junior Member
Thanks Meter: 0
 
More
Hi

---------- Post added at 06:28 PM ---------- Previous post was at 06:06 PM ----------

Vomit on your bike and cat mix
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes