FORUMS
Remove All Ads from XDA
OnePlus 6 On Sale

[ROOT] G2X Gingerbread 2.3.3. stock ROM with flashable zip in Clockworkmod Recovery

1,790 posts
Thanks Meter: 504
 
By jboxer, Senior Member on 9th September 2011, 12:17 PM
Post Reply Email Thread
23rd February 2012, 03:56 PM |#71  
Senior Member
Thanks Meter: 19
 
More
Quote:
Originally Posted by jboxer

If you used my unroot zip it should have deleted those files.

Boot into Clockwordmod Recovery and then connect your phone to the computer. CWM Recovery will run be seen on ADB with root permissions. Use ADEB commands to delete the two files.

Before issuing the following commands, after your phone is connected, use the menu in CWM Recovery to mount the system. If you don't mount the system you are seeing CWM's mini Android system and not the phone's. Then use the following ADB commands.

#adb shell rm /system/bin/su
#adb shell rm /system/xbin/su

Now use the CWM Recovery menu to unmount the system. Then reboot your phone.

#adb reboot

That should do the trick for you.

Awesome. Thank you so much. I will try this when I get home as I don't have ADB at work, but it sounds like it should do the trick.

The other thing I'm worried about is that when I was on 2.2.2 I rooted via SuperOneClick. Then I unrooted, flashed the OTA 2.3.3, and rooted using your root.zip update. I'm worried SuperOneClick may have left some crap behind in bin or xbin that Good For Enterprise may detect. Anything else I should be on the lookout for to delete when I ADB in from CWM? Busybox probably, but I worry there may be other files.

Thanks, again.
 
 
23rd February 2012, 04:00 PM |#72  
jboxer's Avatar
OP Senior Member
Flag Bangkok
Thanks Meter: 504
 
Donate to Me
More
As far as I know Super One Click just pushes superuser.apk (delete this if still in your system), su in system/bin and a logical link to su in /system/xbin. I think it might also install busybox but not sure. Busybox should not be a problem because it is a general utility that many programs use. The other problem is that the data files for superuser will be left behind in your /data subdirectory, but that probably is not a problem. AFter doing all the above and you still cannot install the program you want, figure out which data subdirectly belongs to superuser.apk and delete it.
26th February 2012, 05:07 PM |#73  
Senior Member
Thanks Meter: 19
 
More
Your instructions worked like a charm and I was then able to install GFE. Thanks again for the help.
4th April 2012, 06:28 AM |#74  
Junior Member
Thanks Meter: 0
 
More
No connection to market or gmail
Everything seems to have worked perfectly, but I no longer have a connection to the market or my gmail, either on cell data or wifi. I can still open pages on the browser. So far is just seems to me google programs. I used recovery to install the unroot .zip file and still had the same problem. I then restored the backup I made before installing the rooted version, but I still have no connection. Anything I'm missing here? Any help? I could live without the market if I had to, but my email is essential.
Dropbox is yet another vital app that has no connection.
10th December 2012, 03:28 PM |#75  
Seminoles's Avatar
Senior Member
Flag Lakeland
Thanks Meter: 68
 
More
Thanks for your OP used Nvflasher to flash CWM had to us a windows 7 computer 8 will not update drivers I'm on 2.3.4 with March 11 2012 baseband your root zip is working great. I know this is late but phone is new to me an insurance replacement for a MyTouch 4g and must say much better. Looking forward to trying out different ROM's I know old phone and not many still active but us to that. LOL

Sent from my LG-P999 using xda app-developers app
5th January 2013, 03:29 AM |#76  
Junior Member
Thanks Meter: 0
 
More
Unrooting and bringing back to stock.
Hey guys, I rooted my phone and installed Hellfire sandwhich about a month ago. The rom seemed to run good at first, and progressively get slower. I just picked up a Nexus 7 and have no desire to run custom roms on my phone anymore as the tablet has all the bells and whistles, therefore at this point i want to bring my phone back to original condition.

I used this guide to root my phone - http://forum.xda-developers.com/show....php?t=1594650 and installed HFS from there. I am looking at threads to unroot and some of them are using ADB. The first thing that I did is to load my Nandroid backup from when I oringinally rooted my phone, and I am receiving the message saying "Checking MD5 sums...MD5 mismatch!". I have gone to this thread- http://forum.xda-developers.com/showthread.php?t=714114, but I am unable to access my phone via ADB, as it's saying "Error: Device not found". I have tried to boot into CWM and plug the phone in there, but appears that all my drivers are not loading - http://puu.sh/1JH8J and it's still saying device not found. I have tried enabling USB debugging, as well as turning it off. When I plug the phone in, I only have the option of "Media Device (MTP)" or "Camera (PTP), no "charge only" option under "USB Computer Connection".

I am unsure what to do at this point. I have installed the "LGUnitedMobileDriver S4981MAN38AP22 ML WHQL Ver 3.8.1" drivers and still receiving the same error. Sorry if this has been addressed, as I'm sure it has, but can someone point me in the right direction. Thank you!

EDIT**
FIxed, Figured out my problem after transferring the zip numerous times
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes