FORUMS
Remove All Ads from XDA

[ROOT] Linux command lines if SuperOneClick fails

5 posts
Thanks Meter: 2
 
By Tamaris, Junior Member on 24th April 2011, 09:23 PM
Post Reply Email Thread
Hi.

I've tried many times to root my LG2X with Z4root, UniversalAndRoot, Visionary and SuperOneClick since I've bought it but it failed each time.

I've seen the [Root] topic in the developpement thread but I can't post there (less than 10 posts...) but I want to help someone to root his/her mobile.

I've searched a long time a good way to do so without SuperOneClick (which doesn't respond with Windows Seven or Ubuntu 11.04) but there is none.

There we go...

Disclaimer : I can't be responsible if you break your phone, cancel your warranty or launch your LG2X on the wall in rage.

If you want, there is already SuperOneClick which run smoothly for many geeks : LG2X SuperOneClick Forum and SuperOneClick Forum

My HTC Magic had been rooted with the command line and I've tried myself to do so with every bit of informations and tips I could find on Internet.

I recommand to test the SuperOneClick method and if it fails, come test this with a Linux terminal (psneuter, su-v2, busybox and the SuperUser.apk can be found in the SuperOneClick archive) :

Code:
adb push psneuter /data/local/tmp
adb push su-v2 /data/local/tmp
adb push busybox /data/local/tmp
adb shell
$ busybox chmod +x /data/local/tmp/psneuter
$ /data/local/tmp/psneuter

adb remount
adb shell

# busybox mv /data/local/tmp/su-v2 /system/xbin/su
# busybox chmod 6755 /system/xbin/su
# busybox chown 0.0 /system/xbin/su
# busybox cp /system/xbin/su /system/bin/su
# busybox chown 0.2000 /system/bin/su

# busybox cp /data/local/tmp/busybox /system/xbin
# busybox chmod 0755 /system/xbin/busybox
# busybox chown 0.2000 /system/xbin/busybox
# exit

adb install Superuser.apk
adb reboot
And... Normally you have permanent root on your LG2X.
You can check the files permissions with
Code:
ls -l /system/xbin/su /system/bin/su
-rwsr-sr-x root     root                26264 2011-04-23 20:07 su
-rwsr-sr-x root     shell               26264 2011-04-23 23:20 su
It seems that /system/xbin/su isn't necessary at all. The su command which gave you the root is the one in /system/bin/. And I had some problems with /system/xbin, I've deleted the folder (with rm /system/xbin or mv /system/xbin /dev/null, I can't recall) and applied mkdir on it again.

If this can be of help, I'll update this later.
The Following 2 Users Say Thank You to Tamaris For This Useful Post: [ View ] Gift Tamaris Ad-Free
 
 
24th April 2011, 09:38 PM |#2  
Hannes The Hun's Avatar
Member
Thanks Meter: 13
 
More
thanks for the detailed instructions, but super one click definitely works with win7 (64bit too) as long as you have the right drivers installed
24th April 2011, 09:54 PM |#3  
OP Junior Member
Thanks Meter: 2
 
More
Thanks but with Windows Seven 64 bits, Linux ou Windows Seven 32 bits with Virtualbox I end up with "SuperOneClick doesn't respond" or stuck on with "chmod psneuter" (with the drivers properly installed).

It's only an alternative solution if SuperOneClick doesn't run properly for another guy.
7th May 2011, 01:01 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Thanks a lot for that tips.

The problem I have now is that su isn't persistant.
When I use
$ su
It hangs up few seconds... and says "Permission denied"
I've used su-v2

Here are the su permission :
-rwsr-sr-x root shell 26324 2011-02-13 14:43 su

Is there a more up-to-date su, that will maybe fix the problem ?
Thanks.

EDIT :
Ok.
The wait time seems to come from SuperUser, I've removed it.
Now I have directly the "permission denied", and "stat failed with 2: No such file or directory" in the logcat.

Maybe that can help.
18th June 2011, 11:51 AM |#5  
BritSwedeGuy's Avatar
Senior Member
Flag Penela
Thanks Meter: 73
 
More
Exclamation
Quote:
Originally Posted by Hannes The Hun

thanks for the detailed instructions, but super one click definitely works with win7 (64bit too) as long as you have the right drivers installed

It didn't for me (after installing nightly 51)
With the step-by-step instructions I get "Failed to set prot mask (inappropriate ioctl for device)" when trying to execute psneuter.
30th July 2011, 10:54 PM |#6  
OP Junior Member
Thanks Meter: 2
 
More
Hi.
Sorry for the wait.

Have you resolved your problem with your rooting?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes