Remove All Ads from XDA

Call Forwarding - Unexpected response from network error

184 posts
Thanks Meter: 24
By zaghy2zy, Senior Member on 9th May 2011, 05:04 PM
Post Reply Email Thread
When I update my voicemail settings, or call forwarding, I get a "Unexpected response fron network" error message. I called my provider (Rogers) and said it appears to be correct on their system... However, it doesn't seem so because when people call me, they get forwarded to Google Voice... I already uninstalled Google Voice, and it was taken out already, however, it still forwards to there which is a USA number and I'm in Canada, so people who call me get forwarded to a long distance number and it bothers me and them so much...

Rogers told me to contact HTC but I want to hear your solutions first guys... BTW, I'm using the Virtuous ROM (which is almost entirely stock packages)


Sent from my HTC Vision using XDA App
9th May 2011, 10:44 PM |#2  
Junior Member
Flag snailem
Thanks Meter: 0
did you use the star codes to disable call forwarding?
10th May 2011, 07:20 AM |#3  
zaghy2zy's Avatar
OP Senior Member
Flag Toronto
Thanks Meter: 24
What are the star code? Already forgot them... heh

Sent from my HTC Vision using XDA App
25th July 2011, 12:12 AM |#4  
Junior Member
Thanks Meter: 1
I was getting the same error and this worked for my desire on orange:-

"Try sending ##21# which is the network code to cancel all forwarding."
The Following User Says Thank You to deadmonkey For This Useful Post: [ View ] Gift deadmonkey Ad-Free
7th September 2011, 10:43 AM |#5  
Junior Member
Flag Rayleigh
Thanks Meter: 0
Question Call Forwarding Problem
I have an unlocked AT&T Atrix on Orange UK running Gingerbread. As soon as you go and look at the Call Forwarding options the phone indicates that all calls are Forwarded and the Icon top left turns on, disabling 'Foward All' shows disabled for a few seconds then comes back with the 'Unexpected reponse from network' message, although calls are not actually Forwarded (can still receive calls). Old SIM card, but OK in old V3x phone. I tried with a '3' Network SIM and all works as expected, so definitely an Orange problem with Android/Atrix. I called Orange who sent some SIM updates one of which failed, called them again and they decided to send me a new SIM but this has made no difference at all.
Only way to reset the indicator and message once on, is to enter ##21# which does the job.
Just an annoying Network bug but interested if anyone knows how to get Orange (and I guess T-Mobile) to do anything about this as it seems from other research to affect several different phone makes and models.
26th November 2013, 10:07 PM |#6  
Junior Member
Thanks Meter: 0
Same issue
I'm Having the same issue on Rogers with my Xperia ion....still ahven't sorted it out
8th June 2017, 06:54 PM |#7  
nickel911's Avatar
Senior Member
Thanks Meter: 2
Any Resolution to this issue? I have what appears to be an unlocked Samsung Galaxy S7 Active from ATT and attempting to use my CRICKET SIM and I get this message.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes