Remove All Ads from XDA


16 posts
Thanks Meter: 9
By morak, Junior Member on 9th May 2011, 07:46 PM
Post Reply Email Thread
I just got OpenVPN working and thought I would share:


Installed tun.ko
Note: Skip this step if you are running Prime or any other ROM with the tun.ko module pre-installed.

Installed BusyBox using BusyBox Installer (Market). Installed to /system/xbin
Installed OpenVPN using OpenVPN Installer (Market) to /system/xbin
Installed OpenVPN Settings (Market)

Replaced OpenVPN binary with the one from:
UnBZ2'ed the file (I used 7-Zip on Windows for this)

adb remount
adb push openvpn-static-2.1.1 /system/xbin/openvpn
adb shell
chmod 555 /system/xbin/openvpn

Created /system/xbin/bb directory (requested in research I did, not sure if required)
mkdir /system/xbin/bb

Symlinked Busybox ifconfig and route /system/xbin/bb

ln -s /system/xbin/ifconfig /system/xbin/bb/ifconfig
ln -s /system/xbin/route /system/xbin/bb/route

Set up my usual OVPN config (configs must have absolute paths to certs!)
OpenVPN settings > Advanced > Load tun kernel module ON
OpenVPN settings > Advanced > TUN module settings
Load module using > insmod
Path to tun module > /system/lib/modules/tun.ko

I think this is everything I did, there was a bit of trial and error so I may have forgotten something.
Checked and the thing still boots afterward
The Following 9 Users Say Thank You to morak For This Useful Post: [ View ] Gift morak Ad-Free
9th May 2011, 11:54 PM |#2  
Thanks Meter: 0
Thanks a lot , will report back when i try it.
10th May 2011, 11:11 PM |#3  
Junior Member
Thanks Meter: 1
I get

insmod: init_module '/system/lib/modules/tun.ko' failed (Exec format error)
11th May 2011, 12:09 AM |#4  
OP Junior Member
Thanks Meter: 9
Assuming you have installed BusyBox, check the md5sum of your tun.ko:

# cd /system/lib/modules
# md5sum tun.ko

Response should be (or at least this is what I get):

7e09817dc4661b732f1a77fff76a10e6 tun.ko

If you don't get that response, I suggest you re-download the tun module, decompress it again and re-push it to your Transformer.
11th May 2011, 06:07 AM |#5  
Junior Member
Thanks Meter: 1
Busybox is installed. Tried both installers and both versions.

Md5sum is right.

Any other ideas?
11th May 2011, 03:29 PM |#6  
OP Junior Member
Thanks Meter: 9
Are you running stock? If you are running a different kernel the module probably won't work.
11th May 2011, 11:06 PM |#7  
redmongoose's Avatar
Senior Member
Thanks Meter: 12
Thanks worked a treat
20th May 2011, 02:17 AM |#8  
Thanks Meter: 0
thanks works perfect
28th May 2011, 10:54 PM |#9  
Senior Member
Flag New York
Thanks Meter: 5
I am getting my Transformer within a week. Can't wait to get this going on the device... Thanks a ton!
25th June 2011, 10:17 AM |#10  
duckdown's Avatar
Flag peel region
Thanks Meter: 0
It's running and connected but my IP is still showing up as my regular ISP 3G IP when I open a browser and go to

Any idea why the traffic doesn't appear to be routing through it?

It shows as 100% connected and the key icon is white in the taskbar...
25th June 2011, 05:15 PM |#11  
Junior Member
Thanks Meter: 5
Originally Posted by duckdown

Any idea why the traffic doesn't appear to be routing through it?

The default behaviour of OpenVPN is not to install a default route pointing out of the tun interface, unless the system you're connected to has IP forwarding and NAT enabled this wouldn't work anyway.

I can't post links, so google "openvpn config" and go to the first link. Look for the section titled: "Routing all client traffic (including web-traffic) through the VPN."
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes