Remove All Ads from XDA

 View Poll Results: Post your eMMC Serial

SEM04G 2.17GiB Gfree
97 Vote(s)
SEM04G 2.17GiB Visionary
67 Vote(s)
SEM04G 2.17GiB (Failed eMMC)
17 Vote(s)
M4G2DE 2.10GiB Gfree
115 Vote(s)
M4G2DE 2.10GiB Visionary
24 Vote(s)
M4G2DE 2.10GiB (Failed eMMC)
52 Vote(s)

Post your eMMC serial

1,733 posts
Thanks Meter: 170
By xdviper, Senior Member on 16th May 2011, 07:47 AM
Post Reply Email Thread
A lot of bricks been happening, and #G2root has come down to the eMMC chip being the culprit, it's not a defective one but one that goes bad after a while. It just dies for unknown reasons. I'd like people to post their eMMC serials, if recovery gives them an error such as "can't mount cache, data, etc"

You need adb setup for this, use one of the stickys to get started with adb

1, start up adb and type these in.
adb reboot recovery
2, after the device starts up in recovery, enter this
adb shell
3, and then this, your serial number should come up after mmc0:0001
cat /proc/kmsg | grep 'mmc0:0001'
It looks like M4G2DE 2.10 GiB is the bad one, judging from what the #G2root devs say, but lets see what our side is.


And unfortunaly I got the bad one too, rooted with gfree, this is what I got
<6>[ 8.328460] mmcblk0: mmc0:0001 M4G2DE 2.10 GiB

5/20/11 Edit: Added a poll, if you'd like to see more options please let me know.
The Following 2 Users Say Thank You to xdviper For This Useful Post: [ View ] Gift xdviper Ad-Free
16th May 2011, 08:36 PM |#2  
Thanks Meter: 2
<6>[ 8.596679] mmcblk0: mmc0:0001 SEM04G 2.17 GiB

That's what mine shows. Don't know if it's the good one?

I'm just curious that if emmc is the culprit then how come no one who rooted using the "non" gfree method never had this issue - at least no one in the forums so far has said that they used the non-gfree method and encountered this issue.

This is my second phone that I've rooted with gfree. The first one died when I was trying to restore IcedGlacier nandroid backup coming from RoyalGinger; with the same clockwork can't mount cache errors. I had the eng bootloader and had tried every thing (even sdparted) but couldn't get it to work.

All I'm trying to say is that it may be the combination of emmc and gfree? What do you think?

Since my current phone is also rooted using gfree; I'm contemplating to revert it back to stock and use the other rooting method.

Thanks for trying to find the cause of this issue.
16th May 2011, 08:44 PM |#3  
OP Senior Member
Thanks Meter: 170
It looks like you have the good emmc, but still can't be sure.

That's exactly what I wanna figure out, how many people used the other method to root and if they had any errors yet and which method they used. We all need to be a little bit more cooperative and help us figure this out.
16th May 2011, 09:30 PM |#4  
neidlinger's Avatar
Senior Member
Flag Cincinnati
Thanks Meter: 448
Originally Posted by xdviper

That's exactly what I wanna figure out, how many people used the other method to root and if they had any errors yet and which method they used. We all need to be a little bit more cooperative and help us figure this out.

Here is mine... hope it helps in your quest.
Attached Thumbnails
Click image for larger version

Name:	serial.JPG
Views:	3459
Size:	27.8 KB
ID:	598179  
The Following User Says Thank You to neidlinger For This Useful Post: [ View ] Gift neidlinger Ad-Free
16th May 2011, 11:42 PM |#5  
vqt's Avatar
Senior Member
Thanks Meter: 36
I rooted with g-free method. Mines shows up the same as the OP
M4G2DE 2.10 GiB. Does this mean I have the bad one? Getting a little concerned at this point. I have flashed a few roms, a few kernels and all of the radios in the past 2 months since I got the phone. I haven't had any problem. Waiting to see what others will do as in unrooting and re-rooting with another method.

Edit: I took the plunge and unrooted my phone to stock. Then rooted again with the visionary method. Worked fine. No problems.
16th May 2011, 11:49 PM |#6  
Junior Member
Thanks Meter: 0
Haven't had any problems, rooted via gfree.
It seems like I have the "better" emmc chip though, I've flashed maybe 10-20 times, different roms and kernels. No radios yet though.
Reading about this stuff has got me a bit paranoid, lol.
Attached Thumbnails
Click image for larger version

Name:	emmc.jpg
Views:	1926
Size:	20.9 KB
ID:	598312  
17th May 2011, 01:09 AM |#7  
Senior Member
Silicon Valley
Thanks Meter: 43
cat proc/kmsg | grep 'mmc0:0001'
I don't get any result when I run this command. I've tried in adb shell and in terminal emulator - no dice. If it matters, I'm rooted with gfree, running CM7 with faux123's kernel.
17th May 2011, 01:16 AM |#8  
Senior Member
Flag Vandling, PA
Thanks Meter: 1,139
I got the good one..
17th May 2011, 06:46 AM |#9  
Senior Member
Thanks Meter: 10
Feels like I won the lottery or something.... I got the "good one".

mmcblk0: mmc0:0001 SEM04G 2.17 GiB

Used method first, then used GFREE method after that method came out for CID 111111~. I knew my third exchange would be the charm! Or was it four? Lost count.. lol.

I've been scared and kept my phone s-off debloated stock, but now I feel like exploring.
Now to flash TRUEBLUE's panache ROM....
17th May 2011, 07:39 AM |#10  
Phateless's Avatar
Senior Member
Flag Oakland
Thanks Meter: 451
Personally I never liked the idea of CID unlock. If I want to unlock my phone I'll just ask T-mobile, they're very cooperative.

I have s-off with engineering bootloader and I'm happy.

Sent from my HTC Glacier using XDA Premium App
17th May 2011, 10:49 AM |#11  
Senior Member
New York City
Thanks Meter: 23
<6>[ 9.320648] mmcblk0: mmc0:0001 SEM04G 2.17 GiB

And never faced any problem with recovery.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes