FORUMS
Remove All Ads from XDA

Fix for Flash 10.3 on CM7

144 posts
Thanks Meter: 39
 
By onelikeseabass, Senior Member on 9th June 2011, 08:00 AM
Post Reply Email Thread
To get Flash 10.3 working on the stock browser you need to do two things:
1) force stop the browser process
2) Remove all permissions for /data/data/com.android.browser/app_plugins/com.adobe.flashplayer/.macromedia/Flash_Player/config.data

*Fix also works for Dolphin. Just change com.android.browser to mobi.mgeek.TunnyBrowser

Changing the permissions restricts the flash plugin or the stock browser or the webkit or I dunno what from reading config.data. This file is screwing with video playback of anything over 240p.

What's weird is that the config.data generated for 10.2 and 10.3 appears to be identical, except for the ProductVer string. Since the file contains settings for h264 high, baseline and main profiles, there's probably some change in 10.3 to the way it uses this information.

Either way, this is a bandaid for those that don't wish to use Opera until the heart of the issue is found/addressed.
The Following 14 Users Say Thank You to onelikeseabass For This Useful Post: [ View ] Gift onelikeseabass Ad-Free
 
 
9th June 2011, 09:07 AM |#2  
martonikaj's Avatar
Senior Member
Flag Seattle, WA
Thanks Meter: 1,707
 
More
how do you remove permissions? i saw the ability to do this was added in a while ago in the nighthlies, but I've never had to do it....
9th June 2011, 09:21 AM |#3  
onelikeseabass's Avatar
OP Senior Member
Thanks Meter: 39
 
More
Quote:
Originally Posted by martonikaj

how do you remove permissions? i saw the ability to do this was added in a while ago in the nighthlies, but I've never had to do it....

You'll need to use a file manager that supports it. I use File Expert while others prefer Root Explorer.

Btw, this is not the same as application permission control which is what you are thinking of.

HTC Vision (G2) - CM7 B100 w/AUS radio
Your is not short for you are, but you're is.|It's means it is and never ever anything else.|Pluralization by way of an apostrophe is always wrong!
9th June 2011, 09:30 AM |#4  
martonikaj's Avatar
Senior Member
Flag Seattle, WA
Thanks Meter: 1,707
 
More
Quote:
Originally Posted by onelikeseabass

You'll need to use a file manager that supports it. I use File Expert while others prefer Root Explorer.

Btw, this is not the same as application permission control which is what you are thinking of.

HTC Vision (G2) - CM7 B100 w/AUS radio
Your is not short for you are, but you're is.|It's means it is and never ever anything else.|Pluralization by way of an apostrophe is always wrong!

oh okay. ill try it.

Well no matter the file browser I chose, the data/data directory doesn't exist, it just shows up empty. Even running multiple searches in File Expert yielded no results :P
9th June 2011, 10:40 AM |#5  
onelikeseabass's Avatar
OP Senior Member
Thanks Meter: 39
 
More
Quote:
Originally Posted by martonikaj

oh okay. ill try it.

Well no matter the file browser I chose, the data/data directory doesn't exist, it just shows up empty. Even running multiple searches in File Expert yielded no results :P

Either you aren't rooted or you don't have superuser installed.

HTC Vision (G2) - CM7 B100 w/AUS radio
Your is not short for you are, but you're is.|It's means it is and never ever anything else.|Pluralization by way of an apostrophe is always wrong!
9th June 2011, 10:41 AM |#6  
martonikaj's Avatar
Senior Member
Flag Seattle, WA
Thanks Meter: 1,707
 
More
Quote:
Originally Posted by onelikeseabass

Either you aren't rooted or you don't have superuser installed.

HTC Vision (G2) - CM7 B100 w/AUS radio
Your is not short for you are, but you're is.|It's means it is and never ever anything else.|Pluralization by way of an apostrophe is always wrong!

I'm running CM7...

using terminal emulator i can just do a cd data/data/com.android.browser and it shows the listing. but if i go to the file manager it doesnt show it. Weird.

So i was able to edit the permissions. My superuser app wasnt properly giving superuser permission to the file explorer, which is weird because during that time it worked for terminal emulator just fine...

I removed all permissions for it, but flash still isnt working. :P

nvm. Fixed. Left the boxes on the far right checked, for 'Exe', and unchecked all other read and write permissions boxes. Working so far.
9th June 2011, 11:00 AM |#7  
sino8r's Avatar
Senior Member
Flag Birmingham, Alabama
Thanks Meter: 732
 
More
Nice find! Works perfectly...
9th June 2011, 06:36 PM |#8  
Senior Member
Thanks Meter: 236
 
More
Was just about to do this but looks like the newest nightly will incorporate this fix.

Edit: nevermind, something different.

Sent from my T-mobile G2
9th June 2011, 08:46 PM |#9  
c00ller's Avatar
Senior Member
Thanks Meter: 324
 
More
Quote:
Originally Posted by martonikaj

So i was able to edit the permissions. My superuser app wasnt properly giving superuser permission to the file explorer, which is weird because during that time it worked for terminal emulator just fine...

In File Expert, press Menu > More > Settings > File Explorer Settings > scroll to the bottom, make sure "Root Explorer" is checked
The Following User Says Thank You to c00ller For This Useful Post: [ View ] Gift c00ller Ad-Free
10th June 2011, 02:06 AM |#10  
Member
Thanks Meter: 5
 
More
I love you
10th June 2011, 03:44 AM |#11  
Senior Member
Thanks Meter: 236
 
More
Finally got around to this and the fix works great. Ditto the person above me.

Sent from my T-mobile G2
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes