Remove All Ads from XDA

[Q] su binary outdated??

1,390 posts
Thanks Meter: 192
By ldrifta, Senior Member on 8th July 2011, 04:54 AM
Post Reply Email Thread
ok so as the title says.... when i boot my phone up it says SU binary outdated, tap here to update.... so i tap and i get a fail...

Downloading manifest... fail!
30th July 2011, 09:23 AM |#2  
Tyra Misoux's Avatar
Junior Member
Thanks Meter: 2
also ran into this issue today. Whats the solution? Just wait until things become fixed?
Well, I know this is HTC section but It think this does not matter....
(Nexus-S, CM7, matr1x kernel)
30th September 2011, 02:13 AM |#3  
Junior Member
Thanks Meter: 0
same issue occurred on my nexus one with CM7.0 latest nightly ROM. trying to tap updating fail...... seeking for resolution to settle this issue....
2nd October 2011, 02:19 PM |#4  
ldrifta's Avatar
OP Senior Member
Flag Lynn, Mass
Thanks Meter: 192
i forget what i did exactly, but try replacing 'su' and 'superuser.apk' with a newer one..., make sure your updater/update-script is installing su properly
6th October 2011, 11:12 PM |#5  
Senior Member
Flag staples center, LA!
Thanks Meter: 3
my friends droid X is doing it too..anyone know whatsup w/ it?

im thinking of uninstalling su and downloading it again off the market....yay or nay?
7th October 2011, 04:41 PM |#6  
BeenAndroidized's Avatar
Senior Member
Thanks Meter: 108
Donate to Me
Got that last week. I hate the new superuser. Didn't work the same as the last version. Oh well, I'll just have to deal with it. BOO HOO HOO!
26th October 2011, 06:36 PM |#7  
Junior Member
Thanks Meter: 0
su binary outdated -nexus s
same thing happened to me. I got a notification saying su binary outdated click here to update. I clicked it and it failed to connect. so I just kept clicking retry again and again it worked after about 5 tries.
31st October 2011, 08:57 AM |#8  
Junior Member
San Antonio
Thanks Meter: 0
I went into the android market and updated it through there. It worked fine after that. =]]
23rd April 2012, 06:46 PM |#9  
texaslittleangel's Avatar
Senior Member
Flag Sydney, Australia
Thanks Meter: 20
I tried updating and I get the following message

"cannot update the su binary on phones that have some kind of write proteccion on the system partition like S-on"

Then I installed and ran the "fix" and when trying to fix, it force closes.

I have now deactivated the outdated su binary warning window from popping up but I am still wondering how to fix the problem.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes