[BUILD] **Complete FroYo Bundle** FRX07.1 - Maintenance Release

11,907 posts
Thanks Meter: 3,835
By arrrghhh, Inactive Recognized Developer on 13th July 2011, 05:45 PM
Post Reply Email Thread
FRX07.1 is here!!

This is a maintenance release - basically taking the newest components to make a completely up-to-date (as of Sept. 1).

Quite a lot has changed since FRX06 - the install process hasn't really, but be sure to read the changelog in the next post and the caveats in post #3!

<<<This is a link to the... FAQ Click it!!>>>

I have created a complete bundle of FroYo with a stable kernel from GIT (August 19 / 1348), and rootfs from GIT (Sept. 2).

Please, feel free to DONATE to the XDAndroid project!

Every little bit helps!


1. Download the full bundle (zip). (Updated September 1 2011)

If instead you just want the system.ext2 (zip) (Updated July 15 2011) file by itself... Don't download this if you're not sure! Grab the full bundle!

2. Extract it. You’ll see a folder, FRX07.1, copy its contents to the root of your SD card. If you want to run Android from a folder instead of all the files on the root of the card, follow the steps below.

3. Go into the STARTUPS folder. Grab the appropriate startup.txt for your device (if you don't know what device you have, you should read the FAQ), and move it to the root of the card (or where you run haret.exe from. If you want to change the location of the build, put a rel_path= statement in the cmdline section of the startup.txt. Mine is located two folders deep on the SD, so my rel_path=Androids/TP2Ref)

4. Screen calibration - you have three choices:
  • Re-use an old ts-calibration file if you have it and you know it's good.
  • Download the file and extract it to where you put the rest of the files (root of SD or in a folder - make sure it all stays together!)
  • Manually calibrate - boot with no ts-calibration file and watch the boot process - you'll be asked to hit 5 points to calibrate the screen. If you have issues calibrating, try an older kernel (1225 works well) Once you have the calibration file hold on to it (make 15 copies if it's a good one ), reboot & go back to the newest kernel!

6. Run haret.exe.. Profit!

Let it settle out on the first boot. Many have reported they had to reboot basically because it was so slow - if you let it sit for about 10 mins so the media scanner can go thru everything, etc. it will be much more pleasurable experience. If you want adb in and watch the processes via top, you'll see why the phone seems so slow - there's lots of background processes cranking because this is the first boot .

Please read the... FAQ
If you have any issues with the kernel, feel free to change it:
There are some devices that are having issues with the newest kernels. Please see the kernel autobuild service to get archived kernels. Once you download a replacement kernel, go to where you run haret.exe from - remove your old zImage/modules-xxxxx.tar.gz. Take the new zImage/modules-xxxxx.tar.gz and replace the old ones, same folder - where you run haret.exe from. Make sure the ‘zImage’ is named just that. Do not rename the modules file, do not extract it - should be in .tar.gz format.

See Incremental Updates for more information on updating the kernel and other components.

Random issues can often be solved by forcing the system to create a new data.img. If you're worried about losing data (all user data is stored in the data.img!!), Titanium Backup works quite well. If you wish, you can rename the data.img to something else, and let the system create a new one - just to see if it resolves your problem.

Similarly, if you wish try formatting your SD card - I prefer to use the HP Tool - do a full format, FAT32.

Even though this build is considered fairly stable, you are more than likely going to run into issues. The next post will address issues particular to this build - PLEASE READ THESE before asking questions! Feel free to post questions in this thread, I will do my best to address them. Big thanks to stinebd for releasing the system image, and of course the other developers for their hard work on making these kernels available.
Attached Files
File Type: zip - [Click for QR Code] (164 Bytes, 14577 views)
The Following 43 Users Say Thank You to arrrghhh For This Useful Post: [ View ] Gift arrrghhh Ad-Free
13th July 2011, 05:46 PM |#2  
OP Inactive Recognized Developer
Thanks Meter: 3,835
Donate to Me
  • BT - works! But audio doesn't route. See this thread if you're feeling adventurous and want to play with/don't mind using some unstable/incomplete code...
  • Audio stutters every 10sec. The only fix I've heard is using a kernel from G3rmo (unfortunately it is old), or
    kill -9 28
    Which kills the [battery] process. I'm sure this will have negative effects on the battery meter/battery life...
  • SD Card not working...? "Waiting for SD Card" appearing on boot...? Try putting this command in your startup.txt
    msmsdcc_1bit msmsdcc_fmax=14000000 msmsdcc_nopwrsave
    See gummbah30's post reminding us of these commands.
  • SD Card has partitions? (If you used a non-XDAndroid build the answer is YES) Then you need to add "no_partitions" to your startup.txt. Between the quotes on the set cmdline line. Do not put it on its own line, it goes in between the quotes! Make sure there is one space between each item.
  • Front buttons messed up/wrong? You can use my rootfs which incorporates g3rm0's layout. This custom rootfs is no longer necessary, I have committed the changes so you can use the autobuild rootfs (in conjunction with physkeyboard=blac in your startup.txt)!
  • Keyboard tiny/unusable? Either change the IME (long press on the input box) Get rid of it! I've heard "Hackers Keyboard" is a good alternative - many options. There's also "Better Keyboard", Swype, etc... Side load the APK using AndroidApps, adb install, etc.
The Following 9 Users Say Thank You to arrrghhh For This Useful Post: [ View ] Gift arrrghhh Ad-Free
13th July 2011, 05:46 PM |#3  
OP Inactive Recognized Developer
Thanks Meter: 3,835
Donate to Me
stinebd's Changelog:

Originally Posted by stinebd

Here’s a new release for you, folks. This is a major release with a ton of changes, new features, and fixes. Our friend hyc/highlandsun did most of the heavy lifting for this release. Highlights include a rewritten RIL with support for world phones and greatly improved CDMA support; fixes for the media codecs; fixes for MMS on Sprint; increased security with the Superuser app.

A list of changes is included below. The FRX07 system image is available for download now, and will require the use of a new rootfs image, also available now. Additionally, we have a new bundle containing everything needed to enjoy a full FRX07 system.

Note: Due to the incredibly long list of changes, this is a somewhat condensed, terse changelog describing only the overall scope of the changes.


  • frameworks/base:
    • Major frameworks changes for CDMA/GSM dual-mode worldphone support. (hyc)
    • Fixes for data connection handling to improve startup time. (hyc)
    • Fixes for wifi handling to avoid issues on hanged drivers. (hyc)
    • Stagefreight (media codecs) fixes. (hyc/viruscrazy)
    • Fixes for Sprint’s wonky MMS markup structure. (hyc)
    • Fix MediaScanner not finding audio files (including ringtones) in system.ext2
  • hardware/libhardware_legacy:
    • Minor GPS driver fixes. (Alex[sp3dev])
    • Rename wifi interfaces to wlan0 on all devices (hyc)
  • hardware/xdandroid-ril: Major RIL refactoring for improved performance on all devices, and added CDMA/GSM dual-mode worldphone support. (hyc)
  • packages/apps/Gallery3D: Switched back to Gallery3D as the gallery app (closes bug #111)
  • packages/apps/Mms: Fixes for Sprint’s wonky MMS markup structure. (hyc)
  • packages/apps/Phone: Fixes for CDMA/GSM dual-mode worldphone support. (hyc)
  • packages/apps/Superuser: Added the Superuser package for authorizing su privileges. This, along with our signed builds, provides greatly increased security for the end user (mostly against malicious apps from the Market).
  • system/extras/su: Added as a dependency for the Superuser package
  • vendor/qcom/android-open: Include missing stagefright codec symbols. (hyc/viruscrazy)

To coincide with the FRX07 system image, the following rootfs changes have been made:
  • init.froyo.rc modifications...
    • Adjust wpa_supplicant service for the new abstraction provided by libhardware_legacy, as well as interface rename
    • Abstract the hciattach service to provide bluetooth support on both chipsets
  • Rename wifi interface to wlan0 on all devices
  • apns-conf.xml updated
  • keymaps completely reorganized, and RHOD end-call keya has been remapped to be the Home key in Android.
  • default.prop: set to lock down the adb shell - su can be used with the Superuser app to authorize root access in adb if needed.

Layman's Changelog

(As in, the changelog I wrote )

FRX07.1 Changelog:
  • RHOD - all buttons on the front no longer wake the device. Only the power button wakes the device now.
  • Updated to the newest RIL
  • hyc's modified libs for video now baked in - *most* HQ YouTube videos (and other HQ videos) should finally work!
  • RHOD & TOPA - Userland (Android) now controls the LED by default now. If you need to debug sleep, you will have to change the behavior manually.
  • Facebook sync should now work, out-of-box.

FRX07 Changelog:
  • Updated RIL (thanks hyc!) - this covers many different bugs that were in the old RIL - I'm only going to cover the major ones...
    • CDMA now works correctly (for the most part). force_cdma (and north_am_dialing) is now deprecated (not needed/ignored!)
    • You can boot with a SIM in on a CDMA device and choose your GSM or CDMA on the fly under Settings.
    • Location based on towers now works on CDMA.
    • 1xRTT now displays correctly, but I never seem to get EVDO Rev.a... I always get 0. This is represented by a 3g icon, as this is what the Android framework provides.
    • Full MMS support! Please see this page for configuration instructions. Will need help fleshing out the list of carriers folks!
    • Spotty service, switching towers, etc should no longer cause the dreaded SoD (Sleep of Death) condition!
  • (Basic audio) 3.5mm support for RHOD400/500
  • Droidwall works out of the box now
  • Keyboard backlight now fades in/out
  • Gallery3D back in! Picasa Web Sync comes with it
  • A couple new apps added to AndroidApps folder:
    • rpierce99's app GetLogs
    • Titanium Backup
The Following 5 Users Say Thank You to arrrghhh For This Useful Post: [ View ] Gift arrrghhh Ad-Free
13th July 2011, 09:09 PM |#4  
crazy cat's Avatar
Senior Member
Flag München
Thanks Meter: 46
Cool man! Thanks for your work.
The Following User Says Thank You to crazy cat For This Useful Post: [ View ] Gift crazy cat Ad-Free
14th July 2011, 12:43 PM |#5  
Eodun's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 51
Well, in fact WEP works perfectly for me. The only thing that wifi fails is at turning it on after turning it off 2 times...

Also, with latest updates I can pair BT, haven't tried to transfer anything.
14th July 2011, 02:25 PM |#6  
OP Inactive Recognized Developer
Thanks Meter: 3,835
Donate to Me
Originally Posted by Eodun

Well, in fact WEP works perfectly for me. The only thing that wifi fails is at turning it on after turning it off 2 times...

Also, with latest updates I can pair BT, haven't tried to transfer anything.

Ah, I forget how different the bugs are for the TI chipsets. I'll change it, thanks!
16th July 2011, 03:11 AM |#7  
OP Inactive Recognized Developer
Thanks Meter: 3,835
Donate to Me
Updated to FRX07! Enjoy!
The Following User Says Thank You to arrrghhh For This Useful Post: [ View ] Gift arrrghhh Ad-Free
16th July 2011, 03:37 PM |#8  
Lothaen's Avatar
Senior Member
Thanks Meter: 417
woo FRX07 - I should really update my blackstone as its running 05 still
16th July 2011, 09:35 PM |#9  
ypsmav's Avatar
Inactive Recognized Developer
Thanks Meter: 490
It seems that the 20110716 Kernel is giving problem to the Blackstone/Topaz.
you may use the previous kernel, or wait until is fixed.
The Following User Says Thank You to ypsmav For This Useful Post: [ View ] Gift ypsmav Ad-Free
16th July 2011, 11:48 PM |#10  
Senior Member
Thanks Meter: 14
mass storage not connecting......anyone else facing this problem?
17th July 2011, 03:02 AM |#11  
OP Inactive Recognized Developer
Thanks Meter: 3,835
Donate to Me
Originally Posted by welard

mass storage not connecting......anyone else facing this problem?

USB mass storage has never worked (on looped mounts).

You can kinda fake it with Droid Explorer, it uses ADB to 'fake' USB mass storage.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes