FORUMS
Remove All Ads from XDA

Battery Fix 2.3.x

2,560 posts
Thanks Meter: 476
 
By jug6ernaut, Inactive Recognized Developer on 18th July 2011, 04:26 PM
Post Reply Email Thread
First thanks to kamma and his thread HERE. This fixed was 100% inspired by his attempt, i only had the benefit of having access to some files he didnt. This thread is based off his, but with the files from 2.3.3 which did not have the jumping issue.

I have NOT tested extensively, but in my limited experience(and that of a few others) this does fix the problem.

Code:
USE THIS SCRIPT AT YOUR OWN RISK

This is just a proof-of-concept fix. I dont guarantee any improvement, because i have not much time to test it.
I simply replace battery libs and apps extracted from ATT 2.2.3*.

How to:
1. Download CMW_Jug6_batfix.zip* (bellow in Attached Files)
2. Copy it to sdcard or sdcard-ext
3. Reboot into CWM recovery
5. Click "install zip from sdcard"
6. Choose zip from sdcard
7. Pick the CMW_Jug6_batfix.zip*
8. Install
9. Reboot
V2 - Removed BatteryManager.apk & BatteryReport.apk as they are not needed
Attached Files
File Type: zip CMW_Jug6_FIXv2.zip - [Click for QR Code] (231.0 KB, 16452 views)
The Following 44 Users Say Thank You to jug6ernaut For This Useful Post: [ View ] Gift jug6ernaut Ad-Free
18th July 2011, 04:27 PM |#2  
Senior Member
Flag Borneo
Thanks Meter: 515
 
Donate to Me
More
Gonna flash this now and reboot frenzy!
18th July 2011, 04:28 PM |#3  
Vangelis13's Avatar
Senior Member
Flag 300 meters from the Rhein
Thanks Meter: 9,706
 
More
Brilliant, will try immediately! Does it matter if you switch between roms, do you have to re-apply then?
18th July 2011, 04:28 PM |#4  
Senior Member
Flag London
Thanks Meter: 137
 
More
Will test, thanks Jug.

Guess I would need to deodex it for a deodexrom?
18th July 2011, 04:41 PM |#5  
jug6ernaut's Avatar
OP Inactive Recognized Developer
Flag San Antonio, Tx
Thanks Meter: 476
 
More
Quote:
Originally Posted by Vangelis13

Brilliant, will try immediately! Does it matter if you switch between roms, do you have to re-apply then?

Yes as you go between roms you would need to reapply, that is until(if its working 100%) its added to the roms themeselves.

Quote:
Originally Posted by Ronaldo_9

Will test, thanks Jug.

Guess I would need to deodex it for a deodexrom?

it has both, but if you want u can remove the 2 .odex files from the zip.
The Following User Says Thank You to jug6ernaut For This Useful Post: [ View ] Gift jug6ernaut Ad-Free
18th July 2011, 04:45 PM |#6  
sublimejosh2000's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 354
 
Donate to Me
More
Its not as easy as just removing the odex files.... lol... it has to be actually "deodexed" there is a difference. I will do this if you don't know how...
Quote:
Originally Posted by jug6ernaut

Yes as you go between roms you would need to reapply, that is until(if its working 100%) its added to the roms themeselves.



it has both, but if you want u can remove the 2 .odex files from the zip.



Sent from my Cyanbreaded Gingered Atrix!
18th July 2011, 05:02 PM |#7  
EclipseX's Avatar
Senior Member
Flag Quinta do Conde
Thanks Meter: 322
 
Donate to Me
More
installing now....will report tomorow
18th July 2011, 05:09 PM |#8  
NoNameAtAll's Avatar
Senior Member
Thanks Meter: 57
 
More
Quote:
Originally Posted by sublimejosh2000

Its not as easy as just removing the odex files.... lol... it has to be actually "deodexed" there is a difference. I will do this if you don't know how...



Sent from my Cyanbreaded Gingered Atrix!

I recommend this.

Sent from my MB860 using XDA App
18th July 2011, 05:09 PM |#9  
OSNPA's Avatar
Senior Member
Thanks Meter: 62
 
More
Installed at 85% battery life, was thinking it was actually closer to 95% at the time I ran this as I hadn't done much since it was fully charged. Didn't wipe battery stats or anything, it started back up at 84%. Did a few things to see how quickly it would drop, when it came down to 81%, I rebooted and wiped battery stats and davlk cache. Took a while on reboot after those wipes, started up at 80%. Still think it should have been higher than the 85% it started at, so I'm charging up to 100% and running Battery Calibration app. Will edit this post when I get the results, but it's not bouncing around like it was before. Awesome work Jug6!

Edit: Charged it to full charge, wouldn't charge past 98%, so I ran the battery calibration app, restarted, and on restart is said 99% and full charged. It was recommended in the app to fully discharge battery and then fully recharge without interruption. Will try to drain it quickly -> Pandora!
18th July 2011, 05:19 PM |#10  
jug6ernaut's Avatar
OP Inactive Recognized Developer
Flag San Antonio, Tx
Thanks Meter: 476
 
More
Quote:
Originally Posted by sublimejosh2000

Its not as easy as just removing the odex files.... lol... it has to be actually "deodexed" there is a difference. I will do this if you don't know how...



Sent from my Cyanbreaded Gingered Atrix!

I would appreciate it, I won't b able to until around 4cst. Granted I'm running this on an deobexed rom.

/me admits his knowledge of compatibility between deobexed/obexed is very lacking lol

Sent from my MB860 using Tapatalk
18th July 2011, 05:31 PM |#11  
Senior Member
Flag NYC
Thanks Meter: 17
 
More
Will try it out if enough people give good feedback, lol.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes