FORUMS
Remove All Ads from XDA

Bugs in OTA 2.3.3 for Desire Z - add yours

262 posts
Thanks Meter: 33
 
By whpsnp, Senior Member on 22nd July 2011, 08:36 PM
Post Reply Email Thread
While generally being quite happy with the Gingerbread update for my Desire Z, clearly there are a few glitches.

First of all, my DZ is a Nordic version with the characters Æ, Ø, Å, Ä and Ö on the hardware keyboard.

On 2.2 before the OTA there was a bug which consistently caused capitalization of Æ, Ø and Å (æøå) when using the hardware keyboard. I don't know about Ä and Ö which are only used in Swedish and not in Danish and Norwegian.
This bug is now fixed using the native keyboard but still present using Scandinavian Keyboard which I have installed from Market. I must admit that I have not contacted the developer to ask if this could be a bug in the app.

Sadly, I have now experienced another bug related to the hardware keyboard [B]after[B] updating to 2.3 - today it happened for the second time.
When typing in Whatsapp and the SMS app (and possibly other apps) using the hardware keyboard pressing "S" will open the SMS app, pressing "G" will open Gmail and pressing "B" will open the built-in browser (not Dolphin HD which is set to default). This is fixed by a reboot (temporarily, it seems). Incidentally, the bug disappeared just now without a reboot while checking if it was also present in Gmail.

The missing pictures bug in HTC's gallery app is still there - still using QuickPic.

Anything that is not listed here - please add to the thread.

EDIT:
As many others I also get the constant Sense restarting thing which is driving me insane!

Also the brightness setting itself to maximum many times.

A handful random reboots. A couple happened with no apps open and doing nothing on the phone - I just happened to notice when it rebooted.

Since monomer888's advise I haven't had another shortcut typing bug happen (as of yet). Thanks!

I'm running software version 2.42.405.2 CL84109
 
 
23rd July 2011, 07:43 AM |#2  
monomer888's Avatar
Senior Member
Thanks Meter: 170
 
More
Quote:
Originally Posted by whpsnp

[..]Sadly, I have now experienced another bug related to the hardware keyboard [B]after[B] updating to 2.3 - today it happened for the second time.
When typing in Whatsapp and the SMS app (and possibly other apps) using the hardware keyboard pressing "S" will open the SMS app, pressing "G" will open Gmail and pressing "B" will open the built-in browser (not Dolphin HD which is set to default). This is fixed by a reboot (temporarily, it seems). Incidentally, the bug disappeared just now without a reboot while checking if it was also present in Gmail.[..]

You can try this:
Quote:

Quote:

Originally Posted by Snotmann
If i type a "S" in a SMS, on the hardware keyboard, i get the message that the SMS will be saved and the screen went back to the SMS Overview.

Did someone have the same issue ?

Have had this happen to me before. Fix it by doing this:

Settings -> Applications -> Quick Launch -> Delete all shortcuts

Also [..] restart just to be on the safe side.

No guarantees but it might work.
The Following User Says Thank You to monomer888 For This Useful Post: [ View ] Gift monomer888 Ad-Free
23rd July 2011, 07:21 PM |#3  
Junior Member
Flag Kolding
Thanks Meter: 0
 
More
My phone doesn't show album art in the music player, and it still doesn't work after several restarts, and dismounting and mounting sd card. Hope it gets fixed soon

Sent from my HTC Vision using XDA App
23rd July 2011, 07:48 PM |#4  
Member
Flag Poá/SP
Thanks Meter: 10
 
More
- when exit from a fullscrren app, sometimes the status bar doesnt fit all screen, leting a space (about 10% of the screen space). Expanding the status bar fix it

- Portuguese translation erros remains from the first rom 1.34!!!!!:
Call volume is "Volume de ligação recebida" - shuold be "Volume da ligação"
The tips widget is "Dicar", should be "Dicas"
And a few others, that I don't remember now.
24th July 2011, 01:04 PM |#5  
Senior Member
Thanks Meter: 26
 
More
I've only seen some minor UI bugs and most recently, the capital letters typing a text message. That only happens when I try to type too quickly after opening the thread.

I must admit that I havent seen the gallery bug yet but then I don't really use the camera.

Might be worth posting your version number to track regional bugs.
Mine is 2.42.405.2
28th July 2011, 11:34 AM |#6  
Member
Thanks Meter: 14
 
More
Brightness will be stuck at max waking from sleep sometimes. Brightness slider has no effect. Fixes itself if you sleep then wake again.
28th July 2011, 12:37 PM |#7  
mikeinashed's Avatar
Senior Member
Flag Manchester
Thanks Meter: 6
 
More
Playback of videos not taken with the camera is very stuttery. THis wasn't the case in 2.2.
28th July 2011, 01:31 PM |#8  
Junior Member
Thanks Meter: 0
 
More
I had the missing gallery pictures problem and the brightness problem as well-I have it normally on auto-bright, but sometimes when I wake it or reboot it, it automatically changes to full brightness and I have to select auto-bright again.

Also, Sense restarts after almost anything.
28th July 2011, 02:20 PM |#9  
Member
Thanks Meter: 1
 
More
After installing, deleting or moving an app, returning to the home makes sense crash and restart.
I have a gallery bug aswell, can click on some line with pic and wording not shown.
I had once a bug in the unlock pin screen, tapping 7 was actually hitting 4, same if I hold on 7, i see the pressed status of the 4 button onscreen. It happened when i had no charge at all and plugged the phone to the usb port of my running pc. It was also impossible to switch on the phone, i had to plug it out.
Can't remember more right now.

Sent from my HTC Vision using XDA App
28th July 2011, 02:28 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Sense crashing sometimes when leaving app
Newsreader crashing when returning from browser
The shortcut bug (pressing Searchkey once on hardware keyboar solve this)
The 10% status bar bug
Coming up some more soon


Sent from my HTC Vision using XDA App
29th July 2011, 02:27 AM |#11  
noneabove's Avatar
Senior Member
Thanks Meter: 276
 
More
I was wondering if anyone had noticed if there is still this bug or if you could test to check for me:

Start an app in portrait mode, slide out the keyboard for landscape mode, hit the home key. Do your apps/widgets load right away or within a couple seconds? For me it has always been that it will take 15-20 seconds for the screen to load, all I will see is the status bar and my background, no loading screen, no errors, nothing but that. Let me know if you had this prior to updating and also if you have it after, thanks!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes