FORUMS
Remove All Ads from XDA

Brainstorming: how to completely disable DataTracker-FD and Fast Dormancy

674 posts
Thanks Meter: 168
 
By metalboy94, Senior Member on 25th July 2011, 05:23 PM
Post Reply Email Thread
Being fed up with the random wakelocks that Dialer produced on my Gingerbread P500, I spent a while searching for the cause. It turned out to be DataTracker-FD (found out using the amazing BetterBatteryStats app - http://www.cri.ch/sven/doku.php/comp...erbatterystats ), which deals with Fast Dormancy (http://www.computerworld.com/s/artic...y_performance_ ).

Now, in theory, Fast Dormancy should be a great feature! But, if your network does not support it, DataTracker-FD will still drain a lot of battery through the wakelock. The SGSII secret code for deactivating it doesn't work on the P500, and neither does the nwk_info.db method. Luckily, you can deactivate (or change its timeout) through the LG hidden menu...

1. Dial 3845#*500#.
2. Go to Modem Setting > PDP Setting > [0] Set Fast Dormancy
3. Select your desired timeout (or "Disabled"). You should now be done! (will look at Battery Usage in a little bit, to see if a reboot/Dialer FC is also needed)
Optional step 4. If you still see no difference, set your desired timeout (or "Disabled") a few more times.

Hope it helps.


/* Edit: It doesn't seem to help, we might be back to square one. Does anyone have any idea on how to completely disable Fast Dormancy? We might need a dev to look at the source code of Dialer and make some modifications... Right now, if your phone stays awake after using Data, the only current workaround is FCing Dialer from Applications. */

EDIT 2: A SECOND TEST, USING THE ABOVE METHOD TO DISABLE FAST DORMANCY, YIELDS POSITIVE RESULTS! THE WAKELOCK IS NOT THERE ANYMORE, EVEN AFTER SEVERAL RECONNECTIONS TO HSDPA!

It needs way more testing though, I will reconnect to data and leave the phone idle (screen off), then see what happens, and I will reboot the phone to see if the setting persists.

EDIT 3: Yes, the setting persists, and the wakelock is still not running! The final test will be done after it has completely charged, because there still is a small possibility that the wakelock is so far not active just because the phone was charging.


Edit 4: Straight after unplugging the phone, DataTracker-FD started running, without being connected to HSDPA (I was in a phonecall). In 17 minutes (of mostly talking on the phone) it drained 1% of the battery - so, it should last for about 29 hours with the same usage. Now I have started HSDPA and left the phone idle for 10 minutes, to see how much it drains and how much it drains after I turn data off. It just might be that, while the phone is still awake, it doesn't drain a large amount of battery. If it actually still drains a lot, this tweak definitely only /seems/ to work while charging (maybe BetterBatteryStats was reporting false data or FD just doesnt' work when charging).

Edit 5: Here's a pleasant surprise. Right after connecting to HSDPA and putting the phone to sleep, the Awake bar in Battery Usage faded out. In 5 minutes of idling with data activated, the phone drained another 1% battery - not sure how well that is, since it amounts to 8 hours of data on a full charge, but it's better than 12 hours of idling with no data on a full charge. Currently repeating the test. Just got an email on Yahoo pushed, I'll get to see the influence on awake time of that as well.

Edit 6: After 10 minutes of idling with data ON, a bit over 1% of the battery is gone. This is a fantastic value, and the Awake bar is only dotted in this period of time. DataTracker-FD seems to be running a bit in the background during the data connection, but stopped once I turned it off. It might just be me, though, because aLogCat still can't find any entries for Fast Dormancy. Now leaving the phone idle with no data for a while to look at the evolution of Awake time.


Edit 7: After about 45 minutes of complete idling, the battery went down 2%. This would mean the battery would last for about a day and a half, which is meh, considering I OC'd the phone to 730 and don't really use a task manager.

The conclusion: YES, disabling Fast Dormancy does work using the above method, and it does help battery life!


Edit 8: After another unrelated reboot, DataTracker-FD is once again awake after using data, but this time it draws significantly less battery. The Battery Usage graph shows no difference between sleep times and awake-because-of-FD times.

Edit 9: During the night, the phone drained 30% battery, once again because of some random action of DataTracker-FD. This is still not a definite fix.
The Following 5 Users Say Thank You to metalboy94 For This Useful Post: [ View ] Gift metalboy94 Ad-Free
 
 
25th July 2011, 05:41 PM |#2  
Senior Member
Flag Riga
Thanks Meter: 42
 
More
"Connection problem or invalid MMI code" when I dial that number..
I remember that long ago I dialed the number and everything was fine.
25th July 2011, 05:42 PM |#3  
metalboy94's Avatar
OP Senior Member
Flag Bucharest
Thanks Meter: 168
 
More
Well you shouldn't literally call it, just type it in Dialer and it should open the hidden menu.
25th July 2011, 05:44 PM |#4  
Senior Member
Flag Riga
Thanks Meter: 42
 
More
Quote:
Originally Posted by metalboy94

Well you shouldn't literally call it, just type it in Dialer and it should open the hidden menu.

When I just type it in dialer, nothing happens.
25th July 2011, 05:46 PM |#5  
metalboy94's Avatar
OP Senior Member
Flag Bucharest
Thanks Meter: 168
 
More
I see. It might not work on CM.
26th July 2011, 07:47 AM |#6  
metalboy94's Avatar
OP Senior Member
Flag Bucharest
Thanks Meter: 168
 
More
Updated the OP a couple of times, you might want to read it.
26th July 2011, 08:48 AM |#7  
masteryx's Avatar
Senior Member
Flag Bucharest
Thanks Meter: 279
 
More
Considering I am still on Froyo v2.2.2, could this be of interest for me too? There's no abnormal battery drain on my phone, but if I can improve the battery life by tweaking this setting, I'd gladly do it.
26th July 2011, 09:21 AM |#8  
metalboy94's Avatar
OP Senior Member
Flag Bucharest
Thanks Meter: 168
 
More
Quote:
Originally Posted by masteryx

Considering I am still on Froyo v2.2.2, could this be of interest for me too? There's no abnormal battery drain on my phone, but if I can improve the battery life by tweaking this setting, I'd gladly do it.

I didn't have such problems on Froyo either. It MIGHT help, but as you can see from the numerous edits to the OP, it's not a clear win yet.
26th July 2011, 10:43 PM |#9  
Senior Member
Thanks Meter: 186
 
More
So it need to be disabled twice to stop working?

I've been looking for this service since using that Battery App but theres not much information of that in the web.
27th July 2011, 10:29 AM |#10  
metalboy94's Avatar
OP Senior Member
Flag Bucharest
Thanks Meter: 168
 
More
I'm not sure just how many times, but it took about 3-4 times for me until I was completely sure the wakelock stopped running and the phone went into deep sleep each time I locked it.
27th July 2011, 04:01 PM |#11  
Senior Member
Thanks Meter: 186
 
More
Yeah I think I got it doing it twice, FC phone and rebooting, btw maybe you can check system/etc/flex/flex.db and flex.xml there are fast dormancy settings there
Post Reply Subscribe to Thread

Tags
dormancy, fast, optimus one, p500

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes