FORUMS
Remove All Ads from XDA

How to install OpenVPN on GT 10.1

31 posts
Thanks Meter: 6
 
By armavista, Member on 25th July 2011, 06:53 PM
Post Reply Email Thread
Hi everyone,

I tried to gather some information to install OpenVPN on the Galaxy Tab 10.1, but could not complete the install.

I already installed successfully OpenVPN Installer, BusyBox Installer, OpenVPN Settings, copied tun.ko to modules folder (/system/lib/modules).

I ran those commands (first had read only errors but eventually succeeded with adb console) :
insmod /modules/tun.ko
ln -s /system/bin/busybox/system/xbins/bb/ route
ln -s /system/bin/busybox/system/xbins/bb/ ifconfig

Then, when i launch OpenVPN Settings, it starts connecting but finally says "FATAL: Linux ifconfig failed, could not start external program".

Anybody could tell me how to do it properly? Is it even possible on the Galaxy Tab 10.1?

Many thanks!!!
 
 
1st August 2011, 02:51 PM |#2  
Senior Member
Thanks Meter: 10
 
More
I'm about to try it right now, I have ovpn running on my galaxy s, just going to create certificates for my tablet, and copy the config across and see if it works.

I believe the default kernel includes tun support.. or so I have been told.. will find out I guess.
1st August 2011, 04:00 PM |#3  
armavista's Avatar
OP Member
Thanks Meter: 6
 
More
Thanks! Keep me updated please.
5th August 2011, 03:40 PM |#4  
Senior Member
Thanks Meter: 9
 
More
Anyone able to make progress on getting openvpn working?
15th August 2011, 10:17 PM |#5  
Junior Member
Flag Pretoria
Thanks Meter: 2
 
More
Hi. I just wanted to add that if anyone have any more info on openvpn and tun.ko for the gt-7100 that i too would be greatful.

Vissie
18th August 2011, 08:33 PM |#6  
Member
Thanks Meter: 2
 
More
I have openvpn working. I installed busybox installer, openvpn and openvpn settings from the market place.

I Used root explorer and made the directory /system/xbin/bb. I also used root explorer to make this directory read/write. Then I used a terminal app to do

Su
ln -s /system/xbin/route /system/xbin/bb/route
ln -s /system/xbin/ifconfig /system/xbin/bb/ifconfig

after this make the directory read only. In openvpn settings point tun.ko path to

/data/media/openvpn/openvpn/tun.ko

add your config and that should do it
22nd August 2011, 04:01 PM |#7  
wojmzy's Avatar
Member
Flag Katowice
Thanks Meter: 5
 
More
i still can't connect
Well when i comment
Quote:

iproute /data/local/bin/iproute-wrapper.sh

openvpn connects but i cant browse my local lan
when i uncomment this line nothing happens when i try to connect
what did i missed?
one more question - im using ccd folders with different push commands on my vpn server - this doesnt seem to work aswell.
Anyone could post stepby step iproute configuration for our devices?
thanks
Wojtek
23rd August 2011, 01:21 AM |#8  
armavista's Avatar
OP Member
Thanks Meter: 6
 
More
I've been trying again and again.
I always get "FATAL: Linux ifconfig failed, could not start external program".
Anyone could post a complete tutorial ?
Thanks.
23rd August 2011, 06:59 PM |#9  
armavista's Avatar
OP Member
Thanks Meter: 6
 
More
I did it!!!
I installed OpenVPN Installer, BusyBox Installer, OpenVPN Settings, copied tun.ko to modules folder (/system/lib/modules), then copied the configuration files of my VPN (ca.crt and client.ovpn) to /sdcard/openvpn.

I ran those commands with adb tools :
mount -o remount,rw /system
insmod /modules/tun.ko
mkdir /system/xbin/bb
ln -s /system/xbin/busybox /system/xbin/bb/ifconfig
ln -s /system/xbin/busybox /system/xbin/bb/route

In the advanced settings of OpenVPN Settings, the path to tun module is "/system/lib/modules/tu", the path to configurations is "/sdcard/openvpn" and the path to openvpn binary is "/system/xbin/openvpn".

Then i launched OpenVPN Settings, entered the username and password and it connected.

I hope it can help...
The Following User Says Thank You to armavista For This Useful Post: [ View ] Gift armavista Ad-Free
24th August 2011, 04:47 AM |#10  
Senior Member
Thanks Meter: 9
 
More
Which kernel are you using -- stock or ??
24th August 2011, 06:05 AM |#11  
Member
Thanks Meter: 2
 
More
I'm running the stock kernel.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes