Remove All Ads from XDA

[Q] Can't install large apps anymore

15 posts
Thanks Meter: 3
By boggiano, Junior Member on 14th August 2011, 04:27 AM
Post Reply Email Thread
Suddenly I can't download from market any large apps ( about 25 MB), using logcat I see "... not enough free space in internal downlad storage".

90% of the installed apps are on the sd, and I have a lot of free space :
SD 3 GB free
Internal 1,36 free
Emmc 11 free

I tried to clear cache and vm cache from recovery, but no luck.

I am using a cyanogenmod rom.

Any advice,pls ?
14th August 2011, 12:25 PM |#2  
Senior Member
Flag Melbourne
Thanks Meter: 441
Donate to Me
Are you using the new market? If so that has been causing the same problems for me
14th August 2011, 04:08 PM |#3  
OP Junior Member
Thanks Meter: 3
Originally Posted by natious

Are you using the new market? If so that has been causing the same problems for me

I tried both: at the beginning I had the old market, after I tried with the new one: same result!

I looked around and I found that the problem could be the /cache folder.

I have:

/dev/block/stl1 30.7M 4.1M 26.7M /cache

If the system uses the /cache downloading I could never install an app like that (about 28MB).

Can I mount/link the /cache fs in another place ?

Funny situation, indeed!!
I switched from cyano to overcome (full wipe).
My /cache was 30 MB and with 4k used, so I could install one big application!
I started to install another one.... no space left!

Again... now I have /cache with 4MB used, so I can't install any other big application!!

Browsing with root file manager I really can't see anything of 4MB size (even hidden!!)


Using the script in this thread

stratosk - 27/07/2011
# Corgar - 28/07/2011 ( changed location of cache in dbdata for onenand i/o, decreased cache dimension to 50mb )
# Remount /cache partition with a larger one (54.5 MB / 50mb cache)

# create a file 54.4 MB
dd if=/dev/zero of=/data/cache.img bs=1024 count=55808

# create ext4 filesystem 
mke2fs -F -T ext4 /data/cache.img

# unmounting old cache partition
umount /cache

# mount 
losetup /dev/block/loop7 /dbdata/cache.img
mount -t ext4 /dev/block/loop7 /cache

chown system.cache /cache
chmod 770 /cache
All the applications can be installed!!
The Following User Says Thank You to boggiano For This Useful Post: [ View ] Gift boggiano Ad-Free
24th February 2012, 10:36 AM |#4  
Junior Member
Thanks Meter: 0
i have same problem
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes